Status

defect
--
major
RESOLVED FIXED
14 years ago
14 years ago

People

(Reporter: zeitgeist, Assigned: mikepinkerton)

Tracking

unspecified
Camino0.9
PowerPC
macOS

Details

Reporter

Description

14 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.7.6) Gecko/20050331 Camino/0.8.3
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.7.6) Gecko/20050331 Camino/0.8.3

Not the first time this has happened, my bookmarks in Camino disappeared after
quiiting and restart. 
There was no Camino or System crash.
Fortunately I backed up my bookmarks as an html file, but unfortunately, Camino
then wouldn't import them.
I could however open the html page into Camino as a page, and then have to
manually start adding bookmarks from that list, which is a PIA, as there are LOTS.
Any idea how I can overcome this problem, and restore the bookmarks the way they
were, or otherwise import the html page as bookmarks?

Reproducible: Couldn't Reproduce

Steps to Reproduce:
1.
2.
3.
Not possible, it's a random occurrence.


Expected Results:  
I thought that trying to import the bookmarks html file would restore my bookmarks.
*** Bug 290203 has been marked as a duplicate of this bug. ***
Simon, could this be the xpfe component stuff that was causing the vanishing
history in the nightlies last month?

Otherwise, it's just two random reports from the 0.8 branch that both lost
bookmarks this week....
I don't think this would be related to the history issue, since xpfe bookmarks
is different enough that they would not interfere.

Maybe this happens when the disk is full? We should probablyl use a safe save
mechanism for bookmarks.

Comment 4

14 years ago
Disk nowhere near full in my case, sorry for the duplicate post!  Let me know
how/if I can help.
Have either of you experienced a reoccurance of this, either with 0.8.3 or 0.8.4?  

I'm tempted to close this as these are the only two reports I've seen, and there
have been no reports of disappearing bookmarks in the nightlies, either, but I
won't until at least after Simon comes back from vacation....
scc told me camino has been eating his bookmarks of late. we need to get to the
bottom of this.
Target Milestone: --- → Camino0.9
this weekend i put in a two-stage writing of the bookmarks, so we shouldn't
overwrite the existing bookmark file unless the write of the plist is
successful. we should still figure out what's going on, but that might prevent
this from happening.
*** Bug 295051 has been marked as a duplicate of this bug. ***
Again, a report from the branch where upon lauching Camino, the Bookmarks were
suddenly gone, no prior crash; from the dupe:

Should have said in the original report that all my bookmarks, and the default
bookmarks to which they were added, were present and working well in 10.4.0.

The .plist file is there, and 4K in size which I suspect is the problem...my
backup is 524K...when I go to bookmark manager both "Bookmark Menu" and
Bookmark Bar" are empty...I attached the 4K file...(attachment 184204 [details])

I then subbed in the backup .plist and things are back to normal. Not sure
whether the 10.4.1 upgrade or Camino blew it away, but the create time on the
.plist file is this afternoon, about the time I launched Camino...thanks

Comment 10

14 years ago
Perhaps we should add a functionality like what AddressBook has, a menu item
called "backup bookmarks" which creates a backup file in the profile directory.
Just in case.
(In reply to comment #10)
> Perhaps we should add a functionality like what AddressBook has, a menu item
> called "backup bookmarks" which creates a backup file in the profile directory.

We have that feature already, just not by that name...File: Export Bookmarks,
File: Import Bookmarks :-)

I find it interesting that no one has reported losing bookmarks on the trunk,
and Mike has recently added some additional protection on the trunk (comment 7),
which sounds almost like an automated bookmarks protection system....
Can we see the original 524K file? If this is put back as Bookmarks.plist, does
it get nuked on the next save? Did the user add another bookmark which caused it
to get nuked?
Are people still seeing this on the branch (0.8.4)?

Comment 14

14 years ago
Eliot,
You can always try to import your backup in another browser, then export and try
to import that file in Camino.  Then at least you have a bunch of browsers to try.
I saw this while hacking on another issue. If any of the member vars of
BookmarkItem or BookmarkFolder become nil, then the dictionary creation process
fails and we loose all the bookmarks. Oddly, I don't see exceptions being thrown.
Status: UNCONFIRMED → NEW
Ever confirmed: true
we haven't heard of anything recently from 09a, i think we can mark this fixed.
Status: NEW → RESOLVED
Closed: 14 years ago
Resolution: --- → FIXED
So what I saw when I had some dirty code in my tree was that one of the member
vars of BookmarkItem was nil, so [NSDictionary dictionaryWithObjectsAndKeys] was
leaving out all the items after that nil one (since nil is the "end" marker).
The last item in the list is "children", so we'd leave out all the chillins.
I also notice that when saving bookmarks, we don't do any checks that we've
actually loaded them (though various members will be nil, so we happen to just
not save anything). I wonder if there are cases where loading fails, we createa
dummy root item, and then save it?
You need to log in before you can comment on or make changes to this bug.