Closed Bug 289873 Opened 15 years ago Closed 11 years ago

15 flash (audio) players work, 16 don't

Categories

(Core :: Plug-ins, defect, major)

x86
Windows XP
defect
Not set
major

Tracking

()

RESOLVED WORKSFORME

People

(Reporter: bdejong, Unassigned)

References

()

Details

(Keywords: perf)

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.6) Gecko/20050317 Firefox/1.0.2
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.6) Gecko/20050317 Firefox/1.0.2

When using flash players to play audio files, using 15 players works, but more
don't:

WORKS => http://freesound.iua.upf.edu/flashtest.php?x=15
DOESN'T WORK => http://freesound.iua.upf.edu/flashtest.php?x=16
DOESN'T WORK => http://freesound.iua.upf.edu/flashtest.php?x=20
DOESN'T WORK => http://freesound.iua.upf.edu/flashtest.php?x=40
etc...

This number is a GLOBAL number: if you open more tabs or more instances (making
the count of flash players larger than 15) the player fails. Checked on about 4
different computers and both OSX and Windows XP.

Internet Explorer doesn't seem to have problems with more than 15 players, and
using up to 100 players (or more) doesn't impose any problems.

guess: problem is not related to audio, as it works in Internet Explorer and
isn't OS-dependent.

Reproducible: Always

Steps to Reproduce:
1. http://freesound.iua.upf.edu/flashtest.php?x=15, works
2. http://freesound.iua.upf.edu/flashtest.php?x=16, doesn't work

Actual Results:  
step 1 works
step 2 doesn't

Expected Results:  
step 2 should work, i.e. should produce sound.

tried a multitude of possible fixes: using different ID's, unique flash links (
"xxxx.swf?id=random_number_here" ) to stop firefox from caching, tried
recreating the flash player, etc etc... Nothing worked.
I can confirm this bug with basically the same issue.
Flash portion of the page is the PLAY > buttons.

WORKS: http://www.reviveourhearts.com/SeekingHim/flash-test.php?x=13
DOESN'T WORK: http://www.reviveourhearts.com/SeekingHim/flash-test.php?x=14

(NOTE there are always 2 extra players on the screen so x=13+2 = 15)

When I hit 16 or more players in screen the sound only plays while you are
rolling over the play buttons. Very Frustrating.
I was developing my own pages and experienced the same thing.  I have one
speaker.swf file that plays a different sound based on FlashVars. If there are
16 or more of these speakers loaded in the page, flash audio in Firefox will not
stream the mp3 however it will in IE.  
Hello, I can confirm that problem.
I use the 
Mozilla/5.0 (Windows; U; Windows NT 5.0; de; rv:1.8.0.1) Gecko/20060111 Firefox/1.5.0.1
and Windows 2000
and I test this with the macromedia flash 7 and 8

I've made last year a website that contains 25 flash audio players. When you start one off the players the sound hangs, lags and stucks or if you switch to an other programm the sound also stops. You can fix this problem only when you permanently moce your move over an link on your site or when you scroll up and down (keep the window "active").
IE show and play the site well.
Today I tried to find the problem. And I find get the result as you, I reduced the flash players on the page step by step down to 15, and 15 or less flash movies the page is "shown" and play the sound correct (without lags).

If tried today the newest firefox beta 
firefox-1.6a1.en-US.win32.installer.exe     
but there is the same problem.

So I think this is a real bug and a programmer has set a limit to 15 flash movies (eg. memory)

You can test the bug here:
www.hell-is-open.de/konzerte/specials/psoa/2005/partysan_2005_music.php
there are more than 15 flashs.
Here is a version with 15 flashs that works correct
www.hell-is-open.de/konzerte/specials/psoa/2005/flash_player_ok.htm

(sorry for my bad english)
Klaus-Peter from germany
I can confirm this bug with Firefox 2.0 under WinXP SP2.

Mozilla/5.0 (Windows; U; Windows NT 5.1; de; rv:1.8.1.1) Gecko/20061204 Firefox/2.0.0.1


More than 16 Flash players work in IE 7, but not in Firefox. 
I could NOT reproduce this bug under Mac OS X with Firefox 2:

Mozilla/5.0 (Macintosh; U; Intel Mac OS X; de; rv:1.8.1.1) Gecko/20061204 Firefox/2.0.0.1

Could someone please change OS: All to OS: Windows?
I am not able to do so. 
I can confirm the bug .. when there are too many Flash players open then Firefox will only play a tiny portion (about 0.5 sec) of audio when a Flash audio button is activated, and then pause until you mouseover another Flash player.

Please see here for an example:

http://listen2russian.com/lesson02/c/index.html

Bug found in Firefox 2.0.0.1; WinXP, SP2; Flash Player 9.28


There is NO PROBLEM with the audio using IE6 or IE7.

I hope someone knows what is going on!

Thanks,
J.



OK, I think I managed to find a workaround for this bug.

At the top of the page:

http://listen2russian.com/lesson02/c/index.html

I now load an invisible .swf file that contains 6 seconds of pure silence. For some reason, if this is playing while the other 16 or so other Flash players load then they seem to play their audio without a hiccup.

The .swf file is here:

http://listen2russian.com/flash/ffix.swf

I call this the 'Cone of Silence' workaround :)


The original page without the cone of silence (without the ffix.swf) is here:

http://listen2russian.com/lesson02/c/15playerbug.html

Notice the audio hiccups on this page.


This workaround was successful in FF 2.0.0.1 under IE7 on WinXP.

The workaround doesn't appear to work for Opera....
Another workaround (that works with every javascript-enabled browser) is to display the play button as an image, and replace it with the flash <object> via javascript when the button is clicked. 

Although, I haven't found a convenient way, yet, to unload the flash afterwards. (Apart from a fixed timeout.)
Assignee: bross2 → nobody
I'm not able to reproduce this bug using Firefox 2.0.0.3 on Windows XP SP 2 and Flash 9.0 r28. Can those of you that are seeing this please try with a new profile? http://kb.mozillazine.org/Profile_Manager
Samuel I tried (with the same versions as you, the XP being XP Pro) making a new profile and also new machines and I get the skipping.  On some I get a pause only on the longer sounds of the above page and on another I get bad skipping even on short sounds (testing on office machines).  I also noticed the same problem in Opera (fresh installed just for testing this also fresh install of flash player).  Under Linux I have been unable to reproduce this issue in Opera or Firefox.  So it must be something in common with Opera and Firefox on Windows or at least how the flash plugin installs on windows for those browsers.  
Recently we tested this on Mac OSX and were unable to reproduce it there but did on another 2 Windows XP boxes.  
Having the problem in Opera as well makes it sound like something is wrong on the plugin end, not on the browser end. (Or even, potentially, something with the system. But trying it on new systems and seeing the same issue confuses that option.)

I'm not really sure what to make of this, but given that it's something with plugins, I'm sending this to Core for better triage.
Component: General → Plug-ins
Product: Firefox → Core
QA Contact: general → plugins
Hi folks,

Mind if I pop in?  We're launching a new website called Samplebase tomorrow.  We've been beating our heads against the wall with this issue and have finally found our way here.  I'm very happy to see that we're not alone, yet am bummed that the bug status still reads "unconfirmed".  Seems to me that it would be easy to confirm it after all the buzz.  Anyway, we are using little Flash buttons for audio previews on our website.  We did a LOT of testing to narrow the problem of gapping audio playback and Firefox indeed is the issue.  IE 6 and 7 have no problem, this tested on multiple machines.  Safari has no problems, this tested on multiple machines.  But Firefox (Mac and PC) will consistently start the audio preview for a second, stop...wait for around 5 seconds, start, stop, wait for 5 or so seconds, etc.  It was driving us mad!  We implemented the fix above "Cone of Silence" (thank you!) and all seems to be fine now.  

The issue seems to become noticeable after 10 separate instances of Flash have been added to a single page. 

Cheers,

MB
FYI "Flash 9.0.28.0 unstable with IE7 when 20+ windows ope"  circa 2007 http://www.adobe.com/cfusion/webforums/forum/messageview.cfm?forumid=44&catid=184&threadid=1235294&enterthread=y 

but .28.0 is kinda old ... A beta version of Flash Player 9 Update 3, 9.0.60.120, is available at http://labs.adobe.com/downloads/flashplayer9.html

do the newer version(s) of flash fix this problem for you?


Keywords: perf
I can confirm that we are experiencing the same exact issue with latest builds of firefox and flash.  This is a very frustrating situation.  Would love to see a fix or get clarification on where the issue is coming from (plugin or player). 
=> OS=windows

Coran, can you test vista?
Midihead, can you supply a URL that shows the problem?
Has anyone checked with adobe/macromedia?

(Bram, reporter, seems to be gone)
OS: All → Windows XP
Hardware: All → PC
Samuel in comment #12
> ... I'm sending this to Core for better triage.

Samuel, No one yet from core has commented - were you hoping for someone specific to comment?
Sorry Wayne I have no access to Vista.
Sorry guys I've been listening, but there's not a lot to add: this bug still occurs in 2.0.0.6. I've made another test page for easy testing:

http://freesound.iua.upf.edu/flashtest.php?count=13 (ok)
http://freesound.iua.upf.edu/flashtest.php?count=14 (ok)
http://freesound.iua.upf.edu/flashtest.php?count=15 (ok)
http://freesound.iua.upf.edu/flashtest.php?count=16 (BROKEN)
http://freesound.iua.upf.edu/flashtest.php?count=17 (BROKEN)
http://freesound.iua.upf.edu/flashtest.php?count=18 (BROKEN)
etc

 - bram
Confirming. Using
 http://freesound.iua.upf.edu/flashtest.php?count=15 (ok)
 http://freesound.iua.upf.edu/flashtest.php?count=16 (BROKEN)
behaves as described on trunk with player 9,0,45,0 installed and
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a8pre) Gecko/2007081505 Minefield/3.0a8pre

Similar behavior with FF2 2.0.0.6, player 9,0,47,0 on vista

BTW, the 15/16 count is for the COMBINED total of all player files in all open tabs (and perhaps windows, I didn't test that).

Michele, behavior is similar with Version 9,0,60,120 in vista with FF2.  HOWEVER, after some combination of activity (I wasn't able to nail down the combination of steps) it won't play at all, even if there is one http://freesound.iua.upf.edu/flashtest.php?count=1 


=========================================

Ilan has a testcase which matches the symptoms of this bug AND the description of bug 292707 which cites checkKey(event as part of the cause.

works - http://www.spellingright.com/test.php?words=accordion,accountant,accumulate,accurate,accuracy,accuse,accusation
 
fails - http://www.spellingright.com/test.php?words=accordion,accountant,accumulate,accurate,accuracy,accuse,accusation,accustomed,ace,ache,achieve 
(note - make sure it displays at least 16 words+sentences)


=========================================

Ilan's testcase has an interesting symptom, mouse and tab activity help "stimulate" the sound production.  Create multiple tabs with one being spellright, click a sentence.  Now mouse over the sentence link or click other tabs and go back to the spellright tab.

The freesound URL behaves similarly when clicking tabs.


=====================
It would be interesting to know if this happens on MAC or linux.
Status: UNCONFIRMED → NEW
Ever confirmed: true
This does not happen in Linux, 16 or 20+ are OK in Linux.

This does happen in Opera in Windows BTW. 
Thanks Wayne -- 

We set up a test page where you can click on very basic pages with different number of flash files on them.  You'll see when you get to 16 in Windows Vista / XP / FF 2+ (and Trunk build) this issue presents itself.

http://www.spellingright.com/firefoxbug/

Hello,

I confirm the bug. I've been struggling for a few days now and it's my lucky day to have found this page.

I have 5 simple buttons, each of which loads sound from an external mp3 file. When pressed, the sound staggers, stops and chokes. The clip goes to its final position after onSoundComplete event, in which case it just pauses because the playback never finishes. It just freezes.

I tried emebedding with embed, swfobject - nothing works.
I discovered that when you 'stimulate' the button somehow, eg but changing the quality of the movie, it wakes up and proceeds.

In IE, paradoxically, everything works fine. I guess it's an exception to the rule.

ps. I tried the silent cone - no change..
joey33, does your issue respond as described at the end of comment 20, i.e. moving the mouse over the button(s) or other mouse actions helps, and you see similar behavior when you test http://www.spellingright.com/firefoxbug/flashtest17-3e.htm ?
Hello,

Yes, I've visited the page already when going through the thread and the sound chokes. However, when I just move the mouse over T H E button it wakes up.

This is the case with at least 15 buttons.

Regards,
Joey33

 
We (the Flash Player team) are investigating this bug. Thanks for the rich information and test cases.
One more observation, I think I've discovered sth you might find worth investigating.

I found a website with ringtones and mobile phone gadgets. Anyway, on the page there are 28 play buttons and all of them work fine! They are embedded in the page the same way as mine, ie via Swfobject.

What's even more surprising is that when that website is open in another tab in FF, my page (with 25 buttons) works ALSO FINE. When I close the tab, the sound on my page chokes again.

You can check it up here:
http://www.wapster.pl/gsm,polifoniczne_dzwonki.dhtml 

I guess it is a matter of js scripts, though cannot figure out precisely.
The website is in my native lang - Polish, but the play buttons hopefully look standard enough;)

Regards,
Joey33
Hello gents.  For some reason I've not been getting email notifications of replies here.  Must check my mail settings.  Anyway, we implemented the "Cone of Silence" fix using a floating div containing a teeny, tiny Flash movie that continuously loops 2 seconds of a silent wav file.  So, when you scroll anywhere, the div follows and your audio "stream" does not suffer.

To see this in action, go to: http://www.samplebase.com and click on any of the music categories.  Our audio demos were dead in the water until we came up with this solution.  Now, no problems!

Glad to see that the Flash gurus are on the case!

MB
Possibly related issue on YouTube's Democratic Debate page (http://youtube.com/democraticdebate).  It has 38 Flash videos on a single page.  I am able to watch about 8 of them by pressing the play button on each in turn.  After that, the next video has no sound.  Closing the tab and reloading the page lets me watch the next one normally.
I should have mentioned, I'm running:
- Windows Vista
- Firefox 2.0 (Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.8.1.6) Gecko/2007072518 Firefox/2.0.0.6)
- Flash 9.0 r47
I am running the following:
- Windows Vista (up to date patches as of 12 Nov 2007
- Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.8.1.9; .NET CLR 2.0.50727) Gecko/20071025 Firefox/2.0.0.9
- Flash 9,0,47,0

Addons
- NoScript 1.1.8
- Tab Mix Plus 0.3.6
- Talkback 2.0.0.9
- YSlow 0.8.0
- Greasemonkey 0.7.20070607.0
- Firefox Companion for eBay 1.1
- Firebug 1.05
- FFClickOnce 0.6
- DOM Inspector 1.8.1.9

I found that I was having the same kinda symptoms where a Flash based video would run initially when Firefox would start and then would stop running any videos after a random period of time.  This is the closest bug I've found to this issue.  For example Firefox would start and would work fine for the first dozen or so YouTube videos then would stop working until I stopped all instances of Firefox and reloaded.  When it wouldn't work the video would show the first 4-6 seconds and then stop or it would restart at the beginning.  It wouldn't matter who's Flash Based videos, none would work once it broke.   An example would be the break would start on YouTube and then nothing else would work such as Google Video.   

I tried updating Flash to no success. 

Yesterday I removed the Microsoft Windows ns_mswmp.dll and that appears to resolve it.  I had the version 4/13/2007 release of the ns_mswmp.dll.   

hi - I work with Ilan on SpellingCity.com and we are launching the site despite the firefox bug. Our workaround is to post a warning (visible only to Firefox users) making them aware of the problem with Firefox.  :-<

Does anyone know of any way to launch someone towards fixing this? Not to be crass but could we pay someone to get this fixed for the next bugfix release?
I wanted to provide an update... I decided to give the proposed "Cone of Silence" work around another try.  At first, I was encouraged as the first page that I tested (www.samplebase.com) provided by "Midihead" above seemed to work.  I opened up another tab with our own test pages on (spellingright.com) and they seemed to work (without the "Cond of Silence" implementation).  I tried our pages on another computer, again everything seemed to work with no changed to our pages.

I'm now thinking that an updated Flash plugin has fixed this problem.  Further investigation and messing around with the proposed "Cone of Silence" solution indicated that the initial success of the loaded pages was temporary.  Even the samplebase.com page which initially worked, stopped working after additional tabs with Flash files were loaded.  Even after those tabs were closed, flash files on this page would choke when clicked on.

I have some questions that maybe someone can clarify further:

1) Has this been determined to be a Firefox Flash Plugin problem or a Firefox Browser problem?

2) If this is a Firefox Browser problem, does anyone actually know what the problem with code is?  Meaning, the failure ocurrs after 15 Flash files are loaded on the page.  Is "15" hard coded into Firefox somewhere?  Is it possible to increase that number to 50?  If it isn't hard coded, than what is the actual programmatic cause of the problem?

As "johnegood" mentioned we'd be happy to work with someone from "Core" Firefox team to resolve this issue, maybe on a paid basis as we feel it is a significant enough bug.

Any other thoughts / comments would be appreciated.  I'd hate to see the new release of Firefox NOT ADDRESS this issue.

Thanks

I have tested various configurations of our pages, with and without the proposed "cone
Can this bug still be reproduced with the most recent Flash Player release, 9r115: www.adobe.com/go/getflashplayer

If yes.... The Flash Player team has not yet investigated this bug, so I can't say whether the bug is a Firefox or Flash bug. We do plan to look into this soon.
I just installed 9r115, on a page with more than 15 flash files, none of the files play.  You can try this yourself using the URL below.  You can try other pages with less files by clicking on any of the designated URLs at the top of the page.

http://www.spellingright.com/firefoxbug/flashtest16-3e.htm

15 files or less works fine.


also fails with 9r115 in same manner with opera 9.25
Sounds like a bug then in the Flash Player Windows plug-in, not in the Flash Player ActiveX control. Thanks again for the great info and we will look into it.
Ok well I went out and did some more testing for this bug. My findings are posted here:

http://compuwizard123.pastebin.com/f36398225

The only real anomaly was the vista machine working with r115 but I do not think that was true since I have other sources that say it doesn't work. I think this proves that the bug is definitely the flash plugin since same computer with same browser version but different version of flash r47 -> r115 works with r47 but not with r115. The audio was "laggy" and did only work sometimes when hovering over the pause/play buttons with over 16 flash players on all the old versions of flash pre r115.

Hopefully this helps.
On both:
 - WinXP Firefox 2.0.0.12 with Flash 9,0,115,0
 - WinXP Safari 3.0.4 with Flash 9,0,115,0

I can confirm that:
  http://freesound.iua.upf.edu/flashtest.php?count=15 works, and
  http://freesound.iua.upf.edu/flashtest.php?count=16 doesn't work.

However, since IE7.0.5730.11, also with Flash 9,0,115,0, works with both count=15 and count=16, this would seem to confirm a problem in the Flash Windows plugin, but not the ActiveX control, as pointed out in comment #37.
I wanted to let those of us who are very frustrated by this issue (including us) that I have found a Flash / JS API (free) product that at least for us (www.spellingcity.com) for the most part, solves our issues with Firefox / Adobe Flash Plugin that relate to this particular issue.

This solution is strictly to play sound files, if you need to display more than 15 flash files at any given time, this does not solve your issue.

This solution utilizes a single Flash file that accepts through JavaScript API's multiple sound files (MP3s).  You are than able to control when / how to play the individual sound files.  The soundfiles can be loaded on the file or initially pre-loaded.  We have yet to update our site with this product in production, but are working on re-developing our pages with it, and so far, it's been teriffic.

The product is called "soundmanager2" and you can download it / read it about it here:

http://www.schillmania.com/projects/soundmanager2/

and here

http://code.google.com/p/soundmanager2/

Hope this helps many of you, good luck.
I wanted to let everyone know that I just got a response from Adobe about this issue.  I had opened a ticket with them a while back about this and they finally responded.  I'd like to attach the Adobe file that they actually e-mailed me, but instead, below is a copy of the text of their response. 

---- BELOW IS RESPONSE FROM ADOBE ----
Thank you for contacting Adobe Technical Support.
I do apologize for the late reply. We do appreciate you finding the time
to report this bug. This has been replicated on our end and labeled as
a bug by our engineering team.
Please know that this is being worked on by engineering and hopefully it
will be fixed by the next update of Flash player.
Thank you.
Regards,
Thomas S
Flash Player Support Engineer
Adobe Systems, Inc.
---- END OF RESPONSE FROM ADOBE ----
Although this problem is frustrating, there is some comfort in discovering that we are not alone.  

There are several pages on our site which require more than 15 instances of a flash audio player.  They work fine in IE, but freeze completely in FF.  We decided to publish the page anyway, pending a work-around or fix.  You can test this yourself by trying to click any of the round "play" buttons on this page:

http://www.jingles.com/jam/radioids/demodl-HH.html

I am using FF 2.0.0.14 and Shockwave Flash 9.0 r115, and have confirmed the problem on several different computers (all Win XP SP2) as well as receiving trouble reports from visitors to our site.  Any progress update or recommendation on a solution would be appreciated.

jon 
Also being tracked by Adobe at http://bugs.adobe.com/jira/browse/FP-191 though neither of the bugs are clear as to who owns the problem.
I was facing pretty much the same issue, but I wasn't reaching 15 player.

I can't tell if this problem was occurring before as I had never experienced it before.
It seems that you can't have flash animation on more than 8 tabs, if you open additional tabs the animation will works but there will be no sound.
I realized this while browsing video on youtube and noob.us, at one point when I was doing "open link in new tab" the new page opened but there was no sound in it (No sound were still playing from the other tabs either, I had paused the other video). But if I closed on of the other tabs the I could open a new on and it was working. Also, even if the sound was not working on the new tab if I went back to an older one the sound was working when pressing PLAY.

win XP pro sp2
firefox 3 release candidate 1
Onboard sound card: SoundMAX Integreated Digital HD Audio

Chris
Duplicate of this bug: 458004
(In reply to comment #43)
> Also being tracked by Adobe at http://bugs.adobe.com/jira/browse/FP-191 though
> neither of the bugs are clear as to who owns the problem.

can someone verify this is fixed (per adobe) in flash 10?
works for me using flash 10
Status: NEW → RESOLVED
Closed: 11 years ago
Resolution: --- → WORKSFORME
Duplicate of this bug: 363885
You need to log in before you can comment on or make changes to this bug.