Add download count to Firefox product page

RESOLVED WONTFIX

Status

RESOLVED WONTFIX
14 years ago
6 years ago

People

(Reporter: chris.blore, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

14 years ago
Currently, there's a fixed download count near the top of GetFirefox.com
(otherwise known as the Firefox product page) that reads "Join more than 44
million others and make the switch today."

It would be a good idea if it could instead read "Join 44,503,871 others (and
counting) and make the switch today", using the new Spreadfirefox.com Syndicated
Download Counter.

Comment 1

14 years ago
I agree that the counter should be updated based on the data from the feed at:
http://feeds.spreadfirefox.com/downloads/firefox

But I believe it would be more user-friendly to leave the information somewhat
vague.
"More than 44 million" is a thing which the casual surfer will easily understand
and remember, while "44,503,871" will just be registered as a "bunch of digits".

The text could change to "almost 45 million" if the actual count surpasses, say,
44.8 million, to "more than 45 million" if that number is exceeded, and so forth.
Also, one might include special texts for special "milestones", e.g. 50 million.
Unless the number can be made to increase à la Gmail (or even a textified
version of http://ed.agadak.net/greasemonkey/ffCounter/ffCounter.php ), I think
it's best to extract the number of millions from the feed and just slot it into
the current text.

It's becoming impractical to update the download count manually every million.

Also, this bug's severity should be "enhancement".
(Reporter)

Comment 3

14 years ago
To be honest, I think it best that things are left as they are because of the
problems we experienced with load immediately after the launch of the counter.
We really don't need such an increase in traffic being caused by the inclusion
of a dynamic counter on the product page!

If nobody has any objections, I'm requesting this bug be marked INVALID.

Comment 4

14 years ago
you mean, WONTFIX
(Reporter)

Updated

14 years ago
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → WONTFIX
Product: mozilla.org → Websites
Component: www.mozilla.org → General
Product: Websites → www.mozilla.org
You need to log in before you can comment on or make changes to this bug.