XUL Error Pages do not function properly with JavaScript disabled

VERIFIED WORKSFORME

Status

()

VERIFIED WORKSFORME
14 years ago
9 years ago

People

(Reporter: djcater+bugzilla, Assigned: benjamin)

Tracking

(Blocks: 1 bug)

Trunk
mozilla1.8beta4
x86
All
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: has patch in bug 292624, URL)

(Reporter)

Description

14 years ago
When JavaScript is disabled, and XUL error pages are enabled, the error pages
have severe loss of functionality.

Reproducible: Always

Steps to Reproduce:

0. javascript.enabled == false, browser.xul.error_pages.enabled == true.
1. Attempt to load the URL for this bug.

Actual Results:

The error page loaded, but nothing was present except for the 'Try Again' button.

Expected Results:

The error page should have loaded the same as it would have done with
javascript.enabled == true.

I have a suspiscion that this is caused because the URI (that appears in the
location bar) is the URI of the page that failed, and not a chrome URI. I might
of course be completely wrong... JavaScript is not disabled for other chrome
places (the browser would be in trouble otherwise!)

Comment 1

14 years ago
WFM, with Mozilla 1.8b1/Firefox 1.0.2 and the settings from step 0 I still get
the usual Address Not Found errorpage, maybe this is a Linux-only bug?

Comment 2

14 years ago
Confirmed with linux trunk 2005041505

Please always include build ID when reporting a bug.  Reports are generally
useless without them
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Reporter)

Comment 3

14 years ago
Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8b2) Gecko/20050416 Firefox/1.0+

Bug 290219 depends on: Bug 236839
Depends on: 236839

Comment 4

14 years ago
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b2) Gecko/20050422
Firefox/1.0+

Confirming on WinXP SP2, came across this while working on bug 280190 (error
page restyling)

OS needs to change to All.  Additionally, this might need to block aviary1.1
since I hear error pages will be turned on by default?

Updated

14 years ago
OS: Linux → All

Updated

14 years ago
No longer depends on: 236839

Updated

14 years ago
Summary: XUL Error Pages do not funcion properly with JavaScript disabled → XUL Error Pages do not function properly with JavaScript disabled
(Reporter)

Updated

14 years ago
Flags: blocking-aviary1.1?

Updated

14 years ago
Flags: blocking1.8b4?
(Assignee)

Comment 5

14 years ago
I probably have a solution for this at the same time as bug 292624.
Flags: blocking1.8b4?
Flags: blocking1.8b4+
Flags: blocking-aviary1.1?
note bug 189204, which is claimed to wfm.
(Assignee)

Updated

14 years ago
Assignee: adamlock → benjamin
Whiteboard: has patch in bug 292624
Target Milestone: --- → mozilla1.8beta4

Comment 7

14 years ago
this worksforme now.  It got fixed between 2005062305 and 2005062407, perhaps
bug 221490

Comment 8

14 years ago
wfm too with latest nightly FF build, on WinXP. Try to open e.g. ww.mozilla.org.
Resulting error page is complete and functional. Resolving.
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → WORKSFORME
Verified with Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8b4) Gecko/20050716
Firefox/1.0+
Status: RESOLVED → VERIFIED

Updated

14 years ago
Flags: blocking1.8b4+
You need to log in before you can comment on or make changes to this bug.