nsObjectFrame's PaintSelf call does the wrong thing for paint layers

RESOLVED WORKSFORME

Status

()

Core
Layout: Misc Code
RESOLVED WORKSFORME
13 years ago
3 years ago

People

(Reporter: dbaron, Assigned: dbaron)

Tracking

(Blocks: 1 bug, {css1})

Trunk
mozilla1.8beta2
x86
Linux
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [patch])

Attachments

(2 attachments, 2 obsolete attachments)

(Assignee)

Description

13 years ago
nsObjectFrame's PaintSelf call does the wrong thing for paint layers.

Testcase to come later, but patch now, so I don't lose it.
(Assignee)

Comment 1

13 years ago
Created attachment 180687 [details] [diff] [review]
patch

This obviously isn't tested very well yet.

Perhaps we should put this display check inside of PaintSelf itself.  It'll
mean calling it more, but I maybe that's OK.
(Assignee)

Updated

13 years ago
Blocks: 289480
(Assignee)

Updated

13 years ago
Status: NEW → ASSIGNED
Whiteboard: [patch]
Target Milestone: --- → mozilla1.8beta2
(Assignee)

Comment 2

13 years ago
Actually, we may want to drop the PaintSelf completely due to the shared style
contexts.  And I don't think this has much to do with Acid2.
No longer blocks: 289480
(Assignee)

Comment 3

13 years ago
(In reply to comment #1)
> Perhaps we should put this display check inside of PaintSelf itself.  It'll
> mean calling it more, but I maybe that's OK.

Actually, probably not, since we need it for bug 78087.
(Assignee)

Updated

13 years ago
Blocks: 289480
(Assignee)

Comment 4

13 years ago
Created attachment 181393 [details]
testcase (draft)
(Assignee)

Comment 5

13 years ago
Created attachment 181394 [details]
testcase (draft)
Attachment #181393 - Attachment is obsolete: true
(Assignee)

Comment 6

13 years ago
Hmm, this patch doesn't actually seem to help any of the testcases.
(Assignee)

Comment 7

13 years ago
Created attachment 181460 [details] [diff] [review]
patch

This is cleaned up a little, but it doesn't actually work.
Attachment #180687 - Attachment is obsolete: true
the code that's patch here will go away in bug 309521
Depends on: 309521
So is this still an issue now that bug 309521 is fixed?  That is, is there a bug when rendering a plug-in in an nsObjectFrame?

Comment 10

12 years ago
This is completely fixed in the latest trunk build of Firefox, possibly because bug 317375 have been fixed.
(Assignee)

Updated

12 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → WORKSFORME

Comment 11

7 years ago
The testcase seems to have regressed badly in Firefox 4.0b8. Should this bug be reopened?
(Assignee)

Comment 12

7 years ago
regressed how?

Comment 13

7 years ago
Sorry, not really a regression - I was referring to red visible in the testcase, which is apparently the correct rendering - IE8 and Chrome render the same (though Chrome shows some additional rendering issues).
You need to log in before you can comment on or make changes to this bug.