Last Comment Bug 290444 - "display: inherit;" applied to TR moves all cells under first cell of previous line
: "display: inherit;" applied to TR moves all cells under first cell of previou...
Status: VERIFIED INVALID
: testcase
Product: Core
Classification: Components
Component: Layout: Tables (show other bugs)
: Trunk
: All All
: -- normal (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2005-04-15 02:20 PDT by Marc-Etienne VARGENAU
Modified: 2005-04-20 00:59 PDT (History)
2 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Test case showing the bug (870 bytes, text/html)
2005-04-15 02:23 PDT, Marc-Etienne VARGENAU
no flags Details
Expected display (851 bytes, text/html)
2005-04-15 02:24 PDT, Marc-Etienne VARGENAU
no flags Details

Description Marc-Etienne VARGENAU 2005-04-15 02:20:26 PDT
User-Agent:       Mozilla/5.0 (X11; U; SunOS sun4u; fr-FR; rv:1.7.5) Gecko/20041221
Build Identifier: Mozilla/5.0 (X11; U; SunOS sun4u; fr-FR; rv:1.7.5) Gecko/20041221

I have a table of 3 rows of 6 cells. The second row is painted red by applying
"background-color: red;" to the TR.

If I apply "display: inherit;" to the TR, all red cells are moved under the
first cell of the first row.

Reproducible: Always

Steps to Reproduce:
Load file "bug.html"
Actual Results:  
All red cells are moved under the first cell of the first row.

Expected Results:  
I would expect a "normal" table like file "normal.html".

Internet Explorer displays "bug.html" like "normal.html".

Opera displays all red cells under the first cell of the first row AND does the
same for the third row.
Comment 1 Marc-Etienne VARGENAU 2005-04-15 02:23:05 PDT
Created attachment 180785 [details]
Test case showing the bug
Comment 2 Marc-Etienne VARGENAU 2005-04-15 02:24:14 PDT
Created attachment 180786 [details]
Expected display
Comment 3 Anne (:annevk) 2005-04-15 06:17:48 PDT
This is not because of 'display:inherit'. This is because you are applying
'display:table-row-group' to the TR element (albeit indirectly).

Not sure what the result should be though; Opera does something different.
Comment 4 Boris Zbarsky [:bz] (Out June 25-July 6) 2005-04-15 09:26:39 PDT
Mozilla's rendering is correct.  See
http://www.w3.org/TR/CSS21/tables.html#anonymous-boxes for the reason.

Note that IE doesn't really allow display changes on HTML table-related
elements, other than to "none".  So IE is just ignoring your CSS altogether.
Comment 5 Bernd 2005-04-16 02:23:36 PDT
as Boris said, dont compare to IE if display types are involved
Comment 6 Anne (:annevk) 2005-04-16 02:43:56 PDT
Please note that IE is correct per CSS 2.1 as browsers may ignore 'display' on
HTML table elements. (<http://www.w3.org/TR/CSS21/tables.html#q2>)
Comment 7 Marc-Etienne VARGENAU 2005-04-19 07:58:32 PDT
Thank you for the explanation.

In fact, what I wanted to do is the following.

I want do display or not some rows in the table, depending in the style sheet used.

In the "display all rows" style sheet, I had put 
"display: inherit;"
and in the "display only relevant rows" style sheet, I had put
"display: none;"

So the question is: what should I put instead of "display: inherit;" ?
Comment 8 Anne (:annevk) 2005-04-19 11:48:56 PDT
display:table-row
Comment 9 Marc-Etienne VARGENAU 2005-04-20 00:59:57 PDT
Thank you.

Note You need to log in before you can comment on or make changes to this bug.