broswer cannot display data in raw MARC 21 format

VERIFIED DUPLICATE of bug 211239

Status

()

VERIFIED DUPLICATE of bug 211239
14 years ago
14 years ago

People

(Reporter: dlarmore, Assigned: bugs)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.7) Gecko/20050414 Firefox/1.0.3
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.7) Gecko/20050414 Firefox/1.0.3

In the page at
http://authorities.loc.gov/cgi-bin/Pwebrecon.cgi?AuthRecID=4843868&v1=1&HC=12&PID=28883,
when user clicks on "Print or Save Search Results" icon at bottom of page,
browser loads the "Email search results" page instead.  

Reproducible: Always

Steps to Reproduce:
1. Go to above URL.
2. Click on "Print or Save Search Results."


Actual Results:  
Browser displayed E-mail records request failure page: "Your Email request
failed! Use the browser's "Back Button" to return to your search results and
make sure you entered your Email address correctly in the box."

Expected Results:  
Browser should display the data in raw MARC 21 format for export into a
library's online public access catalog system.  The display should be a single
line of text with the following data:
02087cz   2200337n 
4500001000800000005001700008008004100025035002100066035001700087035002100104035001600125906001800141010001700159040001800176053003800194053004200232150001300274450001900287450003700306550004600343550001900389670009300408670030600501670004300807670005900850670032400909670038801233675008101621952003201702953001501734484386820000626085735.0920518i|
anannbabn          |a ana        a(DLC)sh 92002816  a(DLC)5086759 
a(DLC)sp 92002816  a(DLC)258300  t0019ute07v0  ash 92002816  
aDLCcDLCdDLC 0aTK5105.875.I57cTelecommunication
0aZA4195bZA4201cInformation resources  aInternet  aDARPA Internet 
wnneaInternet (Computer network)  wgaWide area networks (Computer
networks)  aWorld Wide Web  aWork cat.: 92016450: Malamud, C. Exploring the
Internet : a technical travelogue, c1993.  aQuarterman, J.S. The Matrix,
c1990:bp. 278-345 (Internet is an internetwork of many networks all running the
TCP/IP protocol suite, connected through gateways, and sharing common name and
address spaces. It is large not only covering the United States, but also
extending to Canada, Europe, and Asia)  aEngr. index:bv. 89, pt. VII, p.
5071.  aByte. Feb. 1992, "Applying the Internet":bp. 111-118.  aOCLC
Micro:bv. 6, No. 4, Aug. 1990, p. 36-37 (Internet is an interconnected set of
networks that is primarily North American in origin and use, but is increasingly
developing connections to worldwide information resources. It started with
ARPAnet, a wide-area experimental network connecting host and terminal
servers)  a94234135: Brown, S. The Internet via Mosaic and World Wide Web,
c1994b(Although the World Wide Web is primarily used on a global scale as a
part of the Internet, it is feasible for a two-machine network to run the WWW
client/server software. Many corporations are looking into WWW as an inexpensive
yet up-to-date method of handling hypermedia applications on a local area
network.)  aASTI;aHennepin;aIAC;aMcGraw-Hill dict. sci. tech.;aRandom
House;aWeb. 3  aLC pattern:  World Wide Web  afg11bta25


If you need more information about the MARC 21 format, see
http://www.loc.gov/marc/specifications/spechome.html or its governing ANSI/NISO
standard at
http://www.niso.org/standards/resources/Z39-2.pdf?CFID=1936452&CFTOKEN=10603642

Comment 1

14 years ago
simplified :

<form action="/cgi-bin/Pwebrecon.cgi" method="post" autocomplete="OFF"
enctype="application/x-www-form-urlencoded">
<input alt="Print" or="" save="" name="SAVE" src="/images/save.gif" type="image"
align="center" border="0">
<input alt="Enter" email="" address="" name="EMAIL" src="/images/email.gif"
type="image" align="center" border="0">
</form>

It seems that the webserver can't see if you clicked the print or the email
button. It has nothing to do with MARC 21.

Comment 2

14 years ago
Note that neither input is having a value. I don't think that they get submitted
if they're missing a value.

Comment 3

14 years ago

*** This bug has been marked as a duplicate of 211239 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
v
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.