CSS: display: run-in example of W3.org's CSS 2.1 does not work

RESOLVED DUPLICATE of bug 2056

Status

()

RESOLVED DUPLICATE of bug 2056
14 years ago
14 years ago

People

(Reporter: burnus, Assigned: dbaron)

Tracking

1.7 Branch
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

14 years ago
The example uses:
-----------------------
H3 { display: run-in }
    <H3>A run-in heading.</H3>
    <P>And a paragraph of text that
       follows it.
-----------------------

Which should render as
A run-in heading. And a paragraph of text that follows it.
^^^^^^^^^^^^^^^^^- This is h3

<h3> and <p> actually render as block. If I set both to inline, then it works,
but the next <p> object is then also "inline".

(I actually try to get <dt> and <dd> render in the same line, but the next <dt>
should be on a different line.)

This is with Gecko/20050414 Firefox/1.0.3 SUSE/1.0.3-0.1.

Comment 1

14 years ago
Searching for 'run-in' would have turned up the bug this is a duplicate of...

*** This bug has been marked as a duplicate of 2056 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.