javascript strict warnings in bookmarksMenu.js

VERIFIED FIXED in Firefox1.5

Status

()

Firefox
Bookmarks & History
--
trivial
VERIFIED FIXED
13 years ago
12 years ago

People

(Reporter: Jason Barnabe (np), Assigned: Jason Barnabe (np))

Tracking

(Blocks: 1 bug)

Trunk
Firefox1.5
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment, 1 obsolete attachment)

(Assignee)

Description

13 years ago
Warning: anonymous function does not always return a value
Source File: chrome://browser/content/bookmarks/bookmarksMenu.js
Line: 495, Column: 12
Source Code:
      return;
      
Warning: anonymous function does not always return a value
Source File: chrome://browser/content/bookmarks/bookmarksMenu.js
Line: 501, Column: 14
Source Code:
        return;
        
Warning: anonymous function does not always return a value
Source File: chrome://browser/content/bookmarks/bookmarksMenu.js
Line: 503, Column: 14
Source Code:
        return;
        
Warning: anonymous function does not always return a value
Source File: chrome://browser/content/bookmarks/bookmarksMenu.js
Line: 509, Column: 2
Source Code:
  },
  
Warning: redeclaration of var i
Source File: chrome://browser/content/bookmarks/bookmarksMenu.js
Line: 943, Column: 13
Source Code:
    for (var i=0; i<buttons.childNodes.length; i++) {
    
Warning: assignment to undeclared variable child
Source File: chrome://browser/content/bookmarks/bookmarksMenu.js
Line: 45
(Assignee)

Comment 1

13 years ago
Created attachment 181467 [details] [diff] [review]
patch
Assignee: vladimir+bm → jason_barnabe
Status: NEW → ASSIGNED
Attachment #181467 - Flags: review?(mconnor)
Comment on attachment 181467 [details] [diff] [review]
patch

rs=mconnor over IRC, looks fine. Request approval if you can find someone
willing to check in.
Attachment #181467 - Flags: review?(mconnor) → review+
(Assignee)

Comment 3

13 years ago
Needs checkin.
(Assignee)

Updated

13 years ago
Whiteboard: [checkin needed]
(Assignee)

Updated

13 years ago
Attachment #181467 - Flags: approval-aviary1.1a?

Comment 4

13 years ago
Comment on attachment 181467 [details] [diff] [review]
patch

a=asa
Attachment #181467 - Flags: approval-aviary1.1a? → approval-aviary1.1a+
Jason, could you make another patch now that the redeclarations aren't a
problem? The plan is to have all these strict warning patches landed after the
1.1 alpha.
(Assignee)

Comment 6

13 years ago
Created attachment 182919 [details] [diff] [review]
[checked in] patch minus the redeclaration fix

There ya go.
Attachment #181467 - Attachment is obsolete: true
Attachment #182919 - Flags: review?(mconnor)
(Assignee)

Updated

13 years ago
Whiteboard: [checkin needed]
Any update for the current patch? Deer Park Alpha 1 was released some days ago,
so it should be ready for checkin?
OS: Windows XP → All
Hardware: PC → All
*** Bug 296654 has been marked as a duplicate of this bug. ***
Blocks: 296661
Attachment #182919 - Flags: review?(mconnor) → review?(benjamin)

Updated

13 years ago
Attachment #182919 - Flags: review?(benjamin) → review+
Attachment #182919 - Flags: approval-aviary1.1a2?

Updated

13 years ago
Attachment #182919 - Flags: approval-aviary1.1a2? → approval-aviary1.1a2+
Whiteboard: [checkin needed]
Checking in bookmarksMenu.js;
/cvsroot/mozilla/browser/components/bookmarks/content/bookmarksMenu.js,v  <-- 
bookmarksMenu.js
new revision: 1.45; previous revision: 1.44
done
Whiteboard: [checkin needed]
Attachment #182919 - Attachment description: patch minus the redeclaration fix → [checked in] patch minus the redeclaration fix
This is fixed, afaict.
Status: ASSIGNED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → FIXED
No warnings visible... => v.
Status: RESOLVED → VERIFIED
Target Milestone: --- → Firefox1.5
sorry for bugspam, long-overdue mass reassign of ancient QA contact bugs, filter on "beltznerLovesGoats" to get rid of this mass change
QA Contact: mconnor → bookmarks
You need to log in before you can comment on or make changes to this bug.