Closed Bug 29142 Opened 20 years ago Closed 20 years ago

Pref. comboboxes: Keyboard (no focus), scrollbar doesn't work (mouse)

Categories

(SeaMonkey :: Preferences, defect, P3)

x86
Linux
defect

Tracking

(Not tracked)

VERIFIED DUPLICATE of bug 26508

People

(Reporter: burnus, Assigned: matt)

Details

In Linux snapshoot 2000-02-24-09. Open Preferences|Internet search. The combobox
contains a scrollbar, which isn't moveable using the mouse. (If you `drag' the
highlighted item, the list scrolls though.)
If I focus the check box I can change its state using space, if I now open the
combobox, I cannot use screen up/down, home/end, arrow up/down (but space works,
it still changes the checkbox state).
It isn't always clear where the focus is (hitting several times TAB and you are
lost since the items don't show their focused/unfocused state). Clicking on the
checkbox and then shift-tab you can use the arrow keys to select an item, using
alt/crtl/shift+arrow doesn't open the box (I don't know whether this should be
the case, using Windows Alt-arrow-down worked). BTW: In this case the combobox
gets its I-have-the-focus drawing style (which persists, when clicking tab to
the checkbox)

Tobias
This bug is still with us as of 2000031615 i686-pc-linux-gnu.  Indeed, the
preferences combo boxes are generally horked.  The best example is the font
preferences box (if you have enough fonts), or the internet search box.  The
scrollbar on the open combo box simply doesn't work.  Unlike the original
report, drag-scrolling no longer works.  This makes the fonts and search engines
on the lower parts of the combo boxes inaccessible.

Suggest changing to NEW.
Scratch that.  Suggest changing to duplicate of Bug 26508.
blizzard et al: d'you think this should be dup'd...? sure sounds similar.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Yeah, this sounds like a dup.

*** This bug has been marked as a duplicate of 26508 ***
Status: NEW → RESOLVED
Closed: 20 years ago
Resolution: --- → DUPLICATE
verif.
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.