bugzilla.mozilla.org has resumed normal operation. Attachments prior to 2014 will be unavailable for a few days. This is tracked in Bug 1475801.
Please report any other irregularities here.
Bug 291585 (processblack)

It Marks emails in my inbox as unread

RESOLVED INVALID

Status

MailNews Core
Networking: IMAP
RESOLVED INVALID
13 years ago
8 years ago

People

(Reporter: Miguel García, Unassigned)

Tracking

1.7 Branch
x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; es-ES; rv:1.7.6) Gecko/20050321 Firefox/1.0.2
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; es-ES; rv:1.7.6) Gecko/20050321 Firefox/1.0.2

My Thunderbird, marks as unread, messages i've read. I've got more than 3000
emails in my inbox and thunderbird marks as un read some of then as unread.
Sometimes, if I mark as read, thunderbird crash and sometimes, before mark the
emails as read, it starts marking as unread the messages... i can see it doing
it alone.

I've not install any extensions or themes in last week

Reproducible: Always

Steps to Reproduce:
1. When I open Thunderbird, it takes to many time rendering the inbox (no the
other folders)
2. When it shows me the inbox, more than 3000 emails are unread.
3.

Actual Results:  
if I mark as read the messages, in a pair of minutes, it starts marking then as
unread... Sometimes it crash.

Expected Results:  
last week I instal the MessageFaces Extensions for Thunderbird and Attachmente
Extractor.

I'm Using SaferFox Theme, and Contacts Sidebar extension.
(Reporter)

Updated

13 years ago
Alias: processblack
How big is the folder on the harddisk ?
How many space Do you have left on your Harddisk ?
Did you ever used the compact folder option ?
(Reporter)

Comment 2

13 years ago
(In reply to comment #1)
> How big is the folder on the harddisk ?
> How many space Do you have left on your Harddisk ?
> Did you ever used the compact folder option ?
> 

Inbox.sbd folder is 979MB, Mail folder 6.6GB
I hav 34.5 GB left on my hard Disc
I Never use Compact Folder Option

I traying to delete some emails, but i can't. Deleted imails are in my inbox
when i restart Thunderbird.
Then use the compact function. Compact doesn't mean compress with .zip or
something like that. 
Thunderbird store all messages from one folder in one single file. 
If you delete a mail, the mail is NOT removed from the file, it's only 
"marked as deleted". They are only removed if you compact the folder (that why
we have this function).
BTW: Which Version of Thunderbird are you using (ALWAYS include such
informations in a bug report)
 
I bet that you have problems with the 2GB limit of mail folders.

David: what's the current mailbox limit and shouldn't we add a warning if TB
hits this limit ?
Or is this limit gone with biesi's fix in necko ?
Assignee: mscott → bienvenu
Status: UNCONFIRMED → NEW
Component: General → MailNews: Database
Ever confirmed: true
Product: Thunderbird → Core
Version: unspecified → 1.7 Branch
(Reporter)

Comment 4

13 years ago
(In reply to comment #3)
> Then use the compact function. Compact doesn't mean compress with .zip or
> something like that. 
I do it when before reply comment #1. Nothing happens.

> BTW: Which Version of Thunderbird are you using (ALWAYS include such
> informations in a bug report)
Sorry! I think I told you! :) I'm using 1.0.2 version but it happens when i was
using 1.0 version.

> I bet that you have problems with the 2GB limit of mail folders.
> 
> David: what's the current mailbox limit and shouldn't we add a warning if TB
> hits this limit ?
How can I know it?

> Or is this limit gone with biesi's fix in necko ?
uf! I don't understand this question! I don't kown what Biesi means! Sorry, i'm
Spanish! :)
First create a backup of your mail directory on your hdd.
Now start TB and create a new subfolder and move all messages from the inbox in
this subfolder. Now look on your HDD and look at the size of your new folder.
It it's under 2GB right click on the inbox at the folder view (left side) in
Thunderbird and select "Compact this folder".

If this now worked and the inbox is small again on your hdd you can move you
mails back to the inbox.

>uf! I don't understand this question! I don't kown what Biesi means! Sorry, i'm
>Spanish! 
I asked David bienvenu (the assigned developer) this question...
(Reporter)

Comment 6

13 years ago
(In reply to comment #5)
> First create a backup of your mail directory on your hdd.
> Now start TB and create a new subfolder and move all messages from the inbox in
> this subfolder. Now look on your HDD and look at the size of your new folder.
> It it's under 2GB right click on the inbox at the folder view (left side) in
> Thunderbird and select "Compact this folder".

Ok! i'll do it now. But first, I was writting this when you answer:
"I think that unread marked emails are emails that I imported from Outlook 2003,
because they haven't got the account column filled and the date is equal to the
date I started using Thunderbird."

I going to do it now.
(Reporter)

Comment 7

13 years ago
(In reply to comment #5)
I've moved emails from my inbox to a new subfolder. I compact the new subfolder.
I reestart TB because when I select "inbox" in TB, program doesn't respond. When
I restart, it shows me the emails ok, but, there were only imported emails from
outlook (read comment #6), directly downloaded emails to thunderbird, are not in
the inbox either in the new folder.
I hope you did a backup as I told you..
Did you compact the inbox after you moved the mails to the new subfolder ?
Something is broken (could be the import or somethign else) and I'm lost why and
how this happened...

(Reporter)

Comment 9

13 years ago
(In reply to comment #8)
> I hope you did a backup as I told you..
> Did you compact the inbox after you moved the mails to the new subfolder ?
> Something is broken (could be the import or somethign else) and I'm lost why and
> how this happened...
> 
> 
Yes, i did the backup! i'll try it again Tomorrow... Thank U very much!
(Reporter)

Comment 10

13 years ago
(In reply to comment #8)
> I hope you did a backup as I told you..
> Did you compact the inbox after you moved the mails to the new subfolder ?
> Something is broken (could be the import or somethign else) and I'm lost why 
and
> how this happened...

I create a new folder, I move the emails to that new folder. I compact inbox 
folder, but nothing happends. I move an email from the new folder to inbox. I 
delete that email and then I compact inbox folder. It works. I compact new 
folder and works too. I move emails to new folder, then restart TB and problem 
is still there... Imported emails from Outlook are duplicated and marked as 
unread....

I notice that problem happends only with imported mails from outlook... I wish 
i can delete them to use thunderbird again! :) I can't delete them, because, 
when I re-start TB, they are there again! :(

Thank u!
(Reporter)

Comment 11

13 years ago
Hi! Can you tell me how can I delete all the emails from my inbox? Only from my
inbox, I want to keep the other emails in my subfolders. Probably theres an
archive that contains all the emails from my inbox somewhere in my HDD.

Thank U very much!
You can delete the file "inbox." and "inbox.msf" in your profile...
(Reporter)

Comment 13

13 years ago
(In reply to comment #12)
> You can delete the file "inbox." and "inbox.msf" in your profile...

Ok! Do you want me to do something else to know something about de bug? As more
as I try to compact, move and delete folders, I don't get any good results and
Imported emails are always there...

Thank you very Much! :)
The developer would need the files ( I think) but I don't know if and when he
have timt to look at this....
It could be difficult to fix this without...
(Reporter)

Comment 15

13 years ago
(In reply to comment #14)
> The developer would need the files ( I think) but I don't know if and when he
> have timt to look at this....
> It could be difficult to fix this without...
> 

Ok! I've got a copy of my files in another computer (I copied them in another
profile folder with the same result). I'll try to fix the bug, web the developer
needs then in that computer, ok?

Thank U
QA Contact: database
(Assignee)

Updated

10 years ago
Product: Core → MailNews Core

Comment 16

10 years ago
I'm seeing this with Tb 2.0.0.18 - several times now a lot of emails have been marked unread in one folder. The folder has about 8800 emails at the moment, and is 5.26MB on disk. The IMAP server is cyrus-imapd 2.2.13-13ubuntu3 on Ubuntu 8.04. It's fairly repeatable, all I need to do is mark a lot of emails read, then read a few more and it'll mark a few thousand unread again. Rebuilding the index and compacting the folder don't help.

Comment 17

9 years ago
what does http://www.processblack.com/ have to do with this?
do you see this started in safe mode?

if is you see this problem, please attach imap log as an attachment
 https://wiki.mozilla.org/MailNews:Logging
Assignee: bienvenu → nobody
Component: Database → Networking: IMAP
QA Contact: database → networking.imap

Comment 18

8 years ago
If the server state is incorrect, i.e., removing the .msf file doesn't fix the issue, then the bug is most likely that the server is losing your state.

Comment 19

8 years ago
if you still see this issue in version 3 please comment in the bug
(assuming this is server issue)
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.