Closed Bug 29162 Opened 22 years ago Closed 21 years ago

[RFE]Should be able to "Edit Frame" as implemented in 4.x

Categories

(Core :: DOM: Editor, enhancement, P1)

enhancement

Tracking

()

VERIFIED DUPLICATE of bug 14156
Future

People

(Reporter: roberts, Assigned: sfraser_bugs)

Details

(Keywords: helpwanted)

Build 2000022408, Win95

Go to http://client/international.  This is a page with 2 frames, the 
International Client Product Marketing intranet page.
Choose Edit Page from File Menu
The frames keep flashing, sometimes with text in them.  Sometimes just the 
background color.  In 4.x I actually choose "edit frame" but this option doesn't 
seem available in Seamonkey.  Guess this is 2 bugs 1) the flashing 2) will we 
have edit frames
Keywords: beta1
I believe that the decision has already been made that we are going to release
note the flashing.  There is already another bug (or two) on changing the menu
text to be "Edit Frame" so this bug should track the flashing issue.
Component: Browser-General → Editor
Keywords: relnote
Target Milestone: M15
Putting on PDT- radar for beta1..will release note.
Whiteboard: [PDT-]
Is this cross-platform or windows-specific? (I assume XP?)
Keywords: beta1, relnote
OS: Windows 95 → All
Hardware: PC → All
Summary: Editing page http://client/international just flashes → Should be able to "Edit Frame" as implemented in 4.x
Whiteboard: [PDT-]
There are several parts of disabling frameset editing; the flashing part of this 
bug is a duplicate of one of those bugs (#14599?).

I am changing the summary to be the "edit frame" functionality request.
move to M16
Simon--is this functionality we are going to be able to provide easily or should
we push it off for a point release?
Keywords: 4xp
Target Milestone: M15 → M16
Reassign to sfraser; he may have a duplicate of this bug
Assignee: brade → sfraser
updating keyword and status whiteboard to reflect that this is a beta 2 feature 
work bug that the Composer team deems a must fix for beta 2.
Severity: normal → major
Keywords: beta2
Priority: P3 → P1
Whiteboard: Composer feature work
Keywords: nsbeta2
Not a beta requirement.
Status: NEW → ASSIGNED
Keywords: beta2, nsbeta2
Summary: Should be able to "Edit Frame" as implemented in 4.x → [RFE]Should be able to "Edit Frame" as implemented in 4.x
Whiteboard: Composer feature work
Target Milestone: M16 → M17
I suggest we make sure the required strings "Edit Page" and "Edit Frame" 
are in the DTD for M16 to help localiztion.
Target Milestone: M17 → Future
updating qa contact
QA Contact: asa → sujay
adding help wanted keyword
Keywords: 4xphelpwanted
adding some keywords
Keywords: mozilla0.9, nsbeta1
dup


*** This bug has been marked as a duplicate of 14156 ***
Status: ASSIGNED → RESOLVED
Closed: 21 years ago
Resolution: --- → DUPLICATE
verified in 2/12 build.
Status: RESOLVED → VERIFIED
[RFE] is deprecated in favor of severity: enhancement.  They have the same meaning.
Severity: major → enhancement
You need to log in before you can comment on or make changes to this bug.