The Signature is not appearing in a new message

VERIFIED FIXED in M14

Status

SeaMonkey
MailNews: Account Configuration
P3
normal
VERIFIED FIXED
18 years ago
13 years ago

People

(Reporter: Ninoschka Baca, Assigned: Alec Flett)

Tracking

Trunk
x86
Windows NT

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [PDT+]fix in hand)

(Reporter)

Description

18 years ago
Build 2000-02-23-08M14: NT4
Haven't tried Linux or Mac but Alec suspects that the same will occur.

Overview: The signature is not appearing in a new message.

Steps to reproduce:
1. Open Account Settings and select an Identity panel
2. In the Identity panel select the checkbox for a signature
3. Select the "Choose" button and select a signature
4. Select the "OK" button to close Account Settings
5. Select the "New Msg" button

Actual Results: Notice that the signature does not appear. Go back to the 
Identity panel and notice that the path to the signature file references a URL. 
If I delete the URL and type in an absolute path such as "C:\sig.txt" then the 
signature appears in the new message.

Expected Results: After selecting the "Choose" button to select a signature 
file, the signature should automatically appear when creating a new message.
(Reporter)

Comment 1

18 years ago
If this is not fixed then it should be Release Noted.
QA Contact: lchiang → nbaca
(Assignee)

Comment 2

18 years ago
I have a two-line fix for this in my tree, which only affects the choose button
for signatures. VERY low risk.
Basically we were setting the "nativePath" part of the nsIFileSpec, instead of
the "URLString" part.
Keywords: beta1
(Assignee)

Updated

18 years ago
Status: NEW → ASSIGNED
Target Milestone: M14
(Assignee)

Comment 3

18 years ago
*** Bug 29197 has been marked as a duplicate of this bug. ***
(Assignee)

Comment 4

18 years ago
I just discovered a related bug (happens whether or not this bug is fixed) that
I'll file a bug for - if you are on an identity panel, then switch to another
server in the same panel that does not have a signature, the signature value
gets pulled over from the other server.
I'll file a bug on that...
Whiteboard: fix in hand

Comment 5

18 years ago
Putting on the PDT+ radar, please get reviewed and approval for check in ASAP.
Whiteboard: fix in hand → [PDT+]fix in hand
(Assignee)

Comment 6

18 years ago
I had a slight problem with my fix, but I've fixed it and gotten it reviewed by
seth.

Comment 7

18 years ago
Alec fixed this.
Status: ASSIGNED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → FIXED
(Reporter)

Comment 8

18 years ago
Will check this on 3/01. Also waiting on a commercial Mac build.
Whiteboard: [PDT+]fix in hand → [PDT+]fix in hand, waiting on a commercial Mac build to verify.
(Reporter)

Comment 9

18 years ago
Build 2000-03-01-08M15: NT4, Linux 6.0, Mac 8.5.1
Verified Fixed. I can see the signatures for HTML or Plain messages.
Status: RESOLVED → VERIFIED
Whiteboard: [PDT+]fix in hand, waiting on a commercial Mac build to verify. → [PDT+]fix in hand

Comment 10

18 years ago
Hmm.. no signature in 2000040708
Status: VERIFIED → REOPENED
Resolution: FIXED → ---

Comment 11

18 years ago
re-verifying this.  We have a new bug on the signature breakage.
http://bugzilla.mozilla.org/show_bug.cgi?id=34117
Status: REOPENED → RESOLVED
Last Resolved: 18 years ago18 years ago
Resolution: --- → FIXED

Comment 12

18 years ago
verified
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.