Crash on start when Gnopernicus is running [@ nsHTMLTextFieldAccessible::GetXULTextBox ]

RESOLVED INVALID

Status

()

Core
Disability Access APIs
--
critical
RESOLVED INVALID
13 years ago
7 years ago

People

(Reporter: Milan Zamazal, Assigned: Nian Liu(n/a in a long time))

Tracking

({crash})

1.7 Branch
x86
Linux
crash
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(crash signature)

Attachments

(2 attachments)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (compatible; Konqueror/3.3; Linux; en_US, cs) KHTML/3.3.2 (like Gecko)
Build Identifier: sun-mozilla1.7-b28 accessibility build, identified as "Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7) Gecko/20050421"

When I enable accessibility in gnome-control-panel, start Gnopernicus and then start  
Gnopernicus, Mozilla usually crashes with segmentation fault.  Sometimes, it doesn't  
crash on startup, but crashes after pressing Ctrl-L.  Rarely, it doesn't crash at all.  
  
If Gnopernicus is not running, Mozilla never crashes when it starts.  

Reproducible: Sometimes

Steps to Reproduce:
1. Enable accessibility in gnome-control-panel. 
2. Start Gnopernicus with speech output enabled. 
3. Start Mozilla. 
 
Actual Results:  
Mozilla crashed with segmentation fault. 

Expected Results:  
It should start and run happily. 

I use current Debian testing/unstable.  Gnopernicus is hand compiled, version 0.10.7.  
Window manager is Sawfish.  Other software versions: Gtk+ 2.6.4, ATK 1.8.0, AT-SPI 
1.6.2, GNOME 2.8, XFree86 4.3. 
 
Start of the gdb traceback: 
#0  0xb59920e6 in nsHTMLTextFieldAccessible::GetXULTextBox () 
   from /usr/local/stow/mozilla-sun/lib/mozilla/components/libaccessibility.so 
#1  0xb599169b in nsHTMLTextFieldAccessible::GetName () 
   from /usr/local/stow/mozilla-sun/lib/mozilla/components/libaccessibility.so 
#2  0xb599ebcc in getNameCB () 
   from /usr/local/stow/mozilla-sun/lib/mozilla/components/libaccessibility.so 
#3  0xb7b75107 in atk_object_get_name () from /usr/lib/libatk-1.0.so.0 
#4  0xb3f457bc in 
_ORBIT_skel_small_Accessibility_DeviceEventController_unImplemented4 () 
from /usr/lib/libspi.so.0 
#5  0xb3f42d85 in _ORBIT_skel_small_Accessibility_Accessible__get_name () 
   from /usr/lib/libspi.so.0 
#6  0xb5e2f587 in ORBit_POA_setup_root () from /usr/lib/libORBit-2.so.0 
#7  0xb5e34335 in ORBit_OAObject_invoke () from /usr/lib/libORBit-2.so.0 
#8  0xb5e1f83e in ORBit_small_invoke_adaptor () from /usr/lib/libORBit-2.so.0 
#9  0xb5e2f8d5 in ORBit_recv_buffer_return_sys_exception () 
   from /usr/lib/libORBit-2.so.0 
#10 0xb5e2fc9c in ORBit_recv_buffer_return_sys_exception () 
   from /usr/lib/libORBit-2.so.0 
#11 0xb5e3003c in ORBit_recv_buffer_return_sys_exception () 
   from /usr/lib/libORBit-2.so.0 
#12 0xb5e34221 in ORBit_handle_request () from /usr/lib/libORBit-2.so.0 
#13 0xb5e1c61e in giop_connection_handle_input () from /usr/lib/libORBit-2.so.0 
#14 0xb5e3b249 in link_connection_set_max_buffer () 
   from /usr/lib/libORBit-2.so.0 
#15 0xb5e3d080 in link_servers_move_io_T () from /usr/lib/libORBit-2.so.0 
#16 0xb7a74582 in g_main_depth () from /usr/lib/libglib-2.0.so.0 
#17 0xb7a755f8 in g_main_context_dispatch () from /usr/lib/libglib-2.0.so.0 
#18 0xb7a75930 in g_main_context_dispatch () from /usr/lib/libglib-2.0.so.0 
#19 0xb7a75ed3 in g_main_loop_run () from /usr/lib/libglib-2.0.so.0

Updated

13 years ago
Severity: normal → critical
Keywords: crash

Updated

13 years ago
Assignee: general → aaronleventhal
Component: General → Disability Access APIs
Product: Mozilla Application Suite → Core
QA Contact: general → accessibility-apis
Summary: Crash on start when Gnopernicus is running → Crash on start when Gnopernicus is running [@ nsHTMLTextFieldAccessible::GetXULTextBox ]
Version: unspecified → 1.7 Branch

Comment 1

13 years ago
Created attachment 181964 [details]
nsHTMLFormControlAccessible.cpp

In case anyone needs the source file for debugging (it's only available in the
Sun source package), i've attached it to the bug. It contains
nsHTMLTextFieldAccessible::GetXULTextBox, nsHTMLTextFieldAccessible::GetName
(and maybe some other functions that aren't in the official version).

Updated

13 years ago
Assignee: aaronleventhal → browser-china-atf

Comment 2

13 years ago
Comment on attachment 181964 [details]
nsHTMLFormControlAccessible.cpp

assuming this is the right version of the file ...

>// Get XUL Textbox which contains this HTML inputField 
>nsIDOMNode* nsHTMLTextFieldAccessible::GetXULTextBox()
>{
>  if (!mDOMNode)
>    return nsnull;
...

>  // Set upperDepth to ensure finding all kinds of XUL Textbox successfully
>  // 1. XUL Textbox (normal) is the grandparent of HTML inputField
>  // 2. XUL Textbox (type=autocomplete) is the parent of the grandparent of HTML inputField
>  const PRInt32 upperDepth = 3;
>
>  nsCOMPtr<nsIDOMNode> parentNode = mDOMNode;
>  for (PRInt32 i = 0; i < upperDepth; i++) {

i'm betting that GetParentNode returned null:
>     parentNode->GetParentNode(getter_AddRefs(parentNode));
>     nsCOMPtr<nsIDOMXULTextboxElement> textBoxElt = do_QueryInterface(parentNode);
>     if (textBoxElt)
>       return textBoxElt;
>  }
>
>  return nsnull;
>}

Comment 3

13 years ago
Louie should take a look.
Assignee: browser-china-atf → Louie.Zhao

Comment 4

13 years ago
Thanks for the reporting. This bug only happends in Sun Mozilla 1.7 A11y build.
The trunk code has different way to deal with HTML TextField accessible. I'll
fix this issue in "Sun Mozilla 1.7 A11y build" and you can try the new coming build.

Comment 5

13 years ago
Created attachment 182037 [details] [diff] [review]
patch v1

Since I can't reproduce the bug on SuSE Linux, I can't verify the fix. I think
the judgement of timeless is right and I attached the patch here for reference.
If you have built Sun Mozilla 1.7 from the source, can you help to verify
whether this patch is ok? Otherwise, you can try the coming Sun Mozilla 1.7
build next week. Thanks very much.

Updated

13 years ago
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
(Reporter)

Comment 6

13 years ago
Unfortunately the patch didn't fix the problem, Mozilla still crashes on startup.   All I can 
see is a transparent window frame and I can hear the following messages from 
Gnopernicus: "create window", "create window", "toolbar". 
 
Here is the complete output from Mozilla 1.7-b34, after applying patch v1: 
 
% /usr/local/stow/mozilla-sun/bin/mozilla 
No Persistent Registry Found. 
Type Manifest File: /home/pdm/.mozilla/.registry_pdm/components/xpti.dat 
nsNativeComponentLoader: autoregistering begins. 
*** Registering nsSystemPrefModule components (all right -- a generic module!) 
*** Registering docshell_provider components (all right -- a generic module!) 
*** Registering XRemoteServiceModule components (all right -- a generic module!)*** 
Registering JavaScript_Debugger components (all right -- a generic module!) 
*** Registering nsP3PModule components (all right -- a generic module!) 
*** Registering application components (all right -- a generic module!) 
*** Registering xpconnect components (all right -- a generic module!) 
*** Registering necko_core_and_primary_protocols components (all right -- a generic 
module!) 
*** Registering nsCJVMManagerModule components (all right -- a generic module!) 
*** Registering nsLayoutModule components (all right -- a generic module!) 
*** Registering nsChromeModule components (all right -- a generic module!) 
*** Registering XRemoteClientModule components (all right -- a generic module!) 
*** Registering nsRDFModule components (all right -- a generic module!) 
*** Registering nsWalletViewerModule components (all right -- a generic module!)*** 
Registering nsMorkModule components (all right -- a generic module!) 
*** Registering nsLayoutDebugModule components (all right -- a generic module!) 
*** Registering nsUCvMathModule components (all right -- a generic module!) 
*** Registering nsLDAPProtocolModule components (all right -- a generic module!)*** 
Registering nsUConvModule components (all right -- a generic module!) 
*** Registering nsJarModule components (all right -- a generic module!) 
*** Registering Browser_Embedding_Module components (all right -- a generic module!) 
*** Registering nsAutoConfigModule components (all right -- a generic module!) 
*** Registering necko_secondary_protocols components (all right -- a generic module!) 
*** Registering nsGfxPSModule components (all right -- a generic module!) 
*** Registering nsPluginModule components (all right -- a generic module!) 
*** Registering nsComposerModule components (all right -- a generic module!) 
*** Registering BOOT components (all right -- a generic module!) 
*** Registering nsProfileModule components (all right -- a generic module!) 
*** Registering nsWidgetGtk2Module components (all right -- a generic module!) 
*** Registering nsTypeAheadFind components (all right -- a generic module!) 
*** Registering nsFindComponent components (all right -- a generic module!) 
*** Registering embedcomponents components (all right -- a generic module!) 
*** Registering mozMySpellModule components (all right -- a generic module!) 
*** Registering nsWalletModule components (all right -- a generic module!) 
*** Registering nsWebServicesModule components (all right -- a generic module!) 
*** Registering mozSRoamingModule components (all right -- a generic module!) 
*** Registering nsSecurityManagerModule components (all right -- a generic module!) 
*** Registering nsInspectorModule components (all right -- a generic module!) 
*** Registering TransformiixModule components (all right -- a generic module!) 
*** Registering nsGfxGTKModule components (all right -- a generic module!) 
*** Registering nsUniversalCharDetModule components (all right -- a generic module!) 
*** Registering nsEditorModule components (all right -- a generic module!) 
*** Registering nsPrefModule components (all right -- a generic module!) 
*** Registering nsTransactionManagerModule components (all right -- a generic module!) 
*** Registering mozSpellCheckerModule components (all right -- a generic module!) 
*** Registering nsI18nModule components (all right -- a generic module!) 
*** Registering nsXMLExtrasModule components (all right -- a generic module!) 
*** Registering ipcd components (all right -- a generic module!) 
*** Registering nsImageLib2Module components (all right -- a generic module!) 
*** Registering nsFileViewModule components (all right -- a generic module!) 
*** Registering xpcomObsoleteModule components (all right -- a generic module!) 
*** Registering nsPrefMigrationModule components (all right -- a generic module!) 
*** Registering nsCookieModule components (all right -- a generic module!) 
*** Registering nsGnomeVFSModule components (all right -- a generic module!) 
*** Registering nsParserModule components (all right -- a generic module!) 
*** Registering appshell components (all right -- a generic module!) 
*** Registering NSS components (all right -- a generic module!) 
*** Registering nsAccessibilityModule components (all right -- a generic module!) 
*** Registering PKI components (all right -- a generic module!) 
*** Registering nsSoftwareUpdate components (all right -- a generic module!) 
*** Registering nsGfxXprintModule components (all right -- a generic module!) 
nsNativeComponentLoader: autoregistering succeeded 
*** Registering -venkman handler. 
*** Registering x-jsd protocol handler. 
*** Registering x-application-jsd content handler. 
*** Registering -chat handler. 
*** Registering x-application-irc handler. 
*** Registering irc protocol handler. 
*** Registering LDAP datasource components (all right -- a JavaScript module!) 
nNCL: registering deferred (0) 
nNCL: registering deferred (0) 
nNCL: registering deferred (0) 
+++ JavaScript debugging hooks installed. 
nsNativeComponentLoader: autoregistering begins. 
nsNativeComponentLoader: autoregistering succeeded 
nNCL: registering deferred (0) 
nsNativeComponentLoader: autoregistering begins. 
nsNativeComponentLoader: autoregistering succeeded 
nNCL: registering deferred (0) 
*** Chrome Registration of package: Checking for contents.rdf at 
jar:resource:/chrome/comm.jar!/content/necko/ 
*** Chrome Registration of locale : Checking for contents.rdf at 
jar:resource:/chrome/en-US.jar!/locale/en-US/necko/ 
*** Chrome Registration of package: Checking for contents.rdf at 
jar:resource:/chrome/comm.jar!/content/xbl-marquee/ 
*** Chrome Registration of package: Checking for contents.rdf at 
jar:resource:/chrome/comm.jar!/content/iecompat/ 
*** Chrome Registration of package: Checking for contents.rdf at 
jar:resource:/chrome/embed-sample.jar!/content/embed/ 
*** Chrome Registration of locale : Checking for contents.rdf at 
jar:resource:/chrome/embed-sample.jar!/locale/en-US/embed/ 
*** Chrome Registration of skin   : Checking for contents.rdf at 
jar:resource:/chrome/embed-sample.jar!/skin/classic/embed/ 
*** Chrome Registration of package: Checking for contents.rdf at 
jar:resource:/chrome/comm.jar!/content/editor/ 
*** Chrome Registration of package: Checking for contents.rdf at 
jar:resource:/chrome/comm.jar!/content/editor-region/ 
*** Chrome Registration of locale : Checking for contents.rdf at 
jar:resource:/chrome/en-US.jar!/locale/en-US/editor/ 
*** Chrome Registration of locale : Checking for contents.rdf at 
jar:resource:/chrome/US.jar!/locale/US/editor-region/ 
*** Chrome Registration of package: Checking for contents.rdf at 
jar:resource:/chrome/comm.jar!/content/mozldap/ 
*** Chrome Registration of locale : Checking for contents.rdf at 
jar:resource:/chrome/en-US.jar!/locale/en-US/mozldap/ 
*** Chrome Registration of package: Checking for contents.rdf at 
jar:resource:/chrome/pipnss.jar!/content/pipnss/ 
*** Chrome Registration of locale : Checking for contents.rdf at 
jar:resource:/chrome/en-US.jar!/locale/en-US/pipnss/ 
*** Chrome Registration of package: Checking for contents.rdf at 
jar:resource:/chrome/pippki.jar!/content/pippki/ 
*** Chrome Registration of locale : Checking for contents.rdf at 
jar:resource:/chrome/en-US.jar!/locale/en-US/pippki/ 
*** Chrome Registration of package: Checking for contents.rdf at 
jar:resource:/chrome/comm.jar!/content/navigator-platform/ 
*** Chrome Registration of package: Checking for contents.rdf at 
jar:resource:/chrome/comm.jar!/content/navigator/ 
*** Chrome Registration of package: Checking for contents.rdf at 
jar:resource:/chrome/comm.jar!/content/navigator-region/ 
*** Chrome Registration of locale : Checking for contents.rdf at 
jar:resource:/chrome/en-US.jar!/locale/en-US/navigator/ 
*** Chrome Registration of locale : Checking for contents.rdf at 
jar:resource:/chrome/US.jar!/locale/US/navigator-region/ 
*** Chrome Registration of locale : Checking for contents.rdf at 
jar:resource:/chrome/en-unix.jar!/locale/en-US/navigator-platform/ 
*** Chrome Registration of package: Checking for contents.rdf at 
jar:resource:/chrome/comm.jar!/content/communicator/ 
*** Chrome Registration of locale : Checking for contents.rdf at 
jar:resource:/chrome/en-US.jar!/locale/en-US/communicator/ 
*** Chrome Registration of package: Checking for contents.rdf at 
jar:resource:/chrome/comm.jar!/content/communicator-platform/ 
*** Chrome Registration of package: Checking for contents.rdf at 
jar:resource:/chrome/comm.jar!/content/communicator-region/ 
*** Chrome Registration of locale : Checking for contents.rdf at 
jar:resource:/chrome/US.jar!/locale/US/communicator-region/ 
*** Chrome Registration of locale : Checking for contents.rdf at 
jar:resource:/chrome/en-unix.jar!/locale/en-US/communicator-platform/ 
*** Chrome Registration of package: Checking for contents.rdf at 
jar:resource:/chrome/toolkit.jar!/content/global/ 
*** Chrome Registration of locale : Checking for contents.rdf at 
jar:resource:/chrome/en-US.jar!/locale/en-US/global/ 
*** Chrome Registration of package: Checking for contents.rdf at 
jar:resource:/chrome/toolkit.jar!/content/global-platform/ 
*** Chrome Registration of package: Checking for contents.rdf at 
jar:resource:/chrome/toolkit.jar!/content/global-region/ 
*** Chrome Registration of locale : Checking for contents.rdf at 
jar:resource:/chrome/US.jar!/locale/US/global-region/ 
*** Chrome Registration of locale : Checking for contents.rdf at 
jar:resource:/chrome/en-unix.jar!/locale/en-US/global-platform/ 
*** Chrome Registration of package: Checking for contents.rdf at 
jar:resource:/chrome/comm.jar!/content/communicator/downloadmanager/ 
*** Chrome Registration of skin   : Checking for contents.rdf at 
jar:resource:/chrome/classic.jar!/skin/classic/global/ 
*** Chrome Registration of skin   : Checking for contents.rdf at 
jar:resource:/chrome/classic.jar!/skin/classic/communicator/ 
*** Chrome Registration of skin   : Checking for contents.rdf at 
jar:resource:/chrome/classic.jar!/skin/classic/editor/ 
*** Chrome Registration of skin   : Checking for contents.rdf at 
jar:resource:/chrome/classic.jar!/skin/classic/messenger/ 
*** Chrome Registration of skin   : Checking for contents.rdf at 
jar:resource:/chrome/classic.jar!/skin/classic/navigator/ 
*** Chrome Registration of skin   : Checking for contents.rdf at 
jar:resource:/chrome/modern.jar!/skin/modern/communicator/ 
*** Chrome Registration of skin   : Checking for contents.rdf at 
jar:resource:/chrome/modern.jar!/skin/modern/editor/ 
*** Chrome Registration of skin   : Checking for contents.rdf at 
jar:resource:/chrome/modern.jar!/skin/modern/global/ 
*** Chrome Registration of skin   : Checking for contents.rdf at 
jar:resource:/chrome/modern.jar!/skin/modern/messenger/ 
*** Chrome Registration of skin   : Checking for contents.rdf at 
jar:resource:/chrome/modern.jar!/skin/modern/navigator/ 
*** Chrome Registration of skin   : Checking for contents.rdf at 
jar:resource:/chrome/jdstheme.jar!/skin/jdstheme/global/ 
*** Chrome Registration of skin   : Checking for contents.rdf at 
jar:resource:/chrome/jdstheme.jar!/skin/jdstheme/communicator/ 
*** Chrome Registration of skin   : Checking for contents.rdf at 
jar:resource:/chrome/jdstheme.jar!/skin/jdstheme/editor/ 
*** Chrome Registration of skin   : Checking for contents.rdf at 
jar:resource:/chrome/jdstheme.jar!/skin/jdstheme/messenger/ 
*** Chrome Registration of skin   : Checking for contents.rdf at 
jar:resource:/chrome/jdstheme.jar!/skin/jdstheme/navigator/ 
***** Chrome Registration: Selecting skin jdstheme/1.0 as default 
*** Chrome Registration of package: Checking for contents.rdf at 
jar:resource:/chrome/comm.jar!/content/cookie/ 
*** Chrome Registration of locale : Checking for contents.rdf at 
jar:resource:/chrome/en-US.jar!/locale/en-US/cookie/ 
*** Chrome Registration of package: Checking for contents.rdf at 
jar:resource:/chrome/comm.jar!/content/wallet/ 
*** Chrome Registration of locale : Checking for contents.rdf at 
jar:resource:/chrome/en-US.jar!/locale/en-US/wallet/ 
*** Chrome Registration of package: Checking for contents.rdf at 
jar:resource:/chrome/content-packs.jar!/content/content-packs/ 
*** Chrome Registration of locale : Checking for contents.rdf at 
jar:resource:/chrome/en-US.jar!/locale/en-US/content-packs/ 
*** Chrome Registration of package: Checking for contents.rdf at 
jar:resource:/chrome/help.jar!/content/help/ 
*** Chrome Registration of locale : Checking for contents.rdf at 
jar:resource:/chrome/en-US.jar!/locale/en-US/help/ 
*** Chrome Registration of package: Checking for contents.rdf at 
jar:resource:/chrome/comm.jar!/content/p3p/ 
*** Chrome Registration of locale : Checking for contents.rdf at 
jar:resource:/chrome/en-US.jar!/locale/en-US/p3p/ 
*** Chrome Registration of package: Checking for contents.rdf at 
jar:resource:/chrome/comm.jar!/content/autoconfig/ 
*** Chrome Registration of locale : Checking for contents.rdf at 
jar:resource:/chrome/en-US.jar!/locale/en-US/autoconfig/ 
*** Chrome Registration of package: Checking for contents.rdf at 
jar:resource:/chrome/venkman.jar!/content/venkman/ 
*** Chrome Registration of locale : Checking for contents.rdf at 
jar:resource:/chrome/venkman.jar!/locale/en-US/venkman/ 
*** Chrome Registration of skin   : Checking for contents.rdf at 
jar:resource:/chrome/venkman.jar!/skin/modern/venkman/ 
*** Chrome Registration of package: Checking for contents.rdf at 
jar:resource:/chrome/inspector.jar!/content/inspector/ 
*** Chrome Registration of locale : Checking for contents.rdf at 
jar:resource:/chrome/inspector.jar!/locale/en-US/inspector/ 
*** Chrome Registration of skin   : Checking for contents.rdf at 
jar:resource:/chrome/inspector.jar!/skin/classic/inspector/ 
*** Chrome Registration of skin   : Checking for contents.rdf at 
jar:resource:/chrome/inspector.jar!/skin/modern/inspector/ 
*** Chrome Registration of skin   : Checking for contents.rdf at 
jar:resource:/chrome/inspector.jar!/skin/jdstheme/inspector/ 
*** Chrome Registration of package: Checking for contents.rdf at 
jar:resource:/chrome/chatzilla.jar!/content/chatzilla/ 
*** Chrome Registration of locale : Checking for contents.rdf at 
jar:resource:/chrome/chatzilla.jar!/locale/en-US/chatzilla/ 
*** Chrome Registration of skin   : Checking for contents.rdf at 
jar:resource:/chrome/chatzilla.jar!/skin/modern/chatzilla/ 
*** Chrome Registration of package: Checking for contents.rdf at 
jar:resource:/chrome/sroaming.jar!/content/sroaming/ 
*** Chrome Registration of locale : Checking for contents.rdf at 
jar:resource:/chrome/sroaming.jar!/locale/en-US/sroaming/ 
*** Chrome Registration of skin   : Checking for contents.rdf at 
jar:resource:/chrome/sroaming.jar!/skin/modern/sroaming/ 
*** Chrome Registration of skin   : Checking for contents.rdf at 
jar:resource:/chrome/sroaming.jar!/skin/classic/sroaming/ 
*** Chrome Registration of skin   : Checking for contents.rdf at 
jar:resource:/chrome/sroaming.jar!/skin/jdstheme/sroaming/ 
*** Chrome Registration of package: Checking for contents.rdf at 
jar:resource:/chrome/layoutdebug.jar!/content/layoutdebug/ 
*** Chrome Registration of locale : Checking for contents.rdf at 
jar:resource:/chrome/layoutdebug.jar!/locale/en-US/layoutdebug/ 
GFX: dpi=96 t2p=0.0666667 p2t=15 depth=24 
++WEBSHELL == 1 
++DOMWINDOW == 1 
++WEBSHELL == 2 
++DOMWINDOW == 2 
Note: styleverifytree is disabled 
Note: frameverifytree is disabled 
CSS Error (chrome://communicator/skin/formatting.css :48.15): Expected color but found 
'#blue'.  Error in parsing value for property 'color'.  Declaration dropped. 
Note: verifyreflow is disabled 
WARNING: GetDefaultCharsetForLocale: need to add multi locale support, file 
nsUNIXCharset.cpp, line 189 
WARNING: GetDefaultCharsetForLocale: need to add multi locale support, file 
nsUNIXCharset.cpp, line 189 
++WEBSHELL == 3 
++DOMWINDOW == 3 
###!!! ASSERTION: You can't dereference a NULL nsCOMPtr with operator->().: 
'mRawPtr != 0', file ../../../dist/include/xpcom/nsCOMPtr.h, line 711 
Break: at file ../../../dist/include/xpcom/nsCOMPtr.h, line 711 
 
Program /usr/local/stow/mozilla-sun/lib/mozilla/mozilla-bin (pid = 8352) received signal 
11. 
Stack: 
_ZN13nsProfileLock18FatalSignalHandlerEi+0x00000146 
[/usr/local/stow/mozilla-sun/lib/mozilla/components/libprofile.so +0x0002E0CE] 
UNKNOWN 0xffffe420 
UNKNOWN [/usr/local/stow/mozilla-sun/lib/mozilla/components/libaccessibility.so 
+0x0009CF73] 
UNKNOWN [/usr/local/stow/mozilla-sun/lib/mozilla/components/libaccessibility.so 
+0x000ACB0E] 
atk_object_get_name+0x000000CD [/usr/lib/libatk-1.0.so.0 +0x0000B107] 
UNKNOWN [/usr/lib/libspi.so.0 +0x000297BC] 
_ORBIT_skel_small_Accessibility_Accessible__get_name+0x00000018 
[/usr/lib/libspi.so.0 +0x00026D85] 
UNKNOWN [/usr/lib/libORBit-2.so.0 +0x00030587] 
ORBit_OAObject_invoke+0x00000035 [/usr/lib/libORBit-2.so.0 +0x00035335] 
ORBit_small_invoke_adaptor+0x0000018E [/usr/lib/libORBit-2.so.0 +0x0002083E] 
UNKNOWN [/usr/lib/libORBit-2.so.0 +0x000308D5] 
UNKNOWN [/usr/lib/libORBit-2.so.0 +0x00030C9C] 
UNKNOWN [/usr/lib/libORBit-2.so.0 +0x0003103C] 
ORBit_handle_request+0x00000051 [/usr/lib/libORBit-2.so.0 +0x00035221] 
giop_connection_handle_input+0x0000010E [/usr/lib/libORBit-2.so.0 +0x0001D61E] 
UNKNOWN [/usr/lib/libORBit-2.so.0 +0x0003C249] 
UNKNOWN [/usr/lib/libORBit-2.so.0 +0x0003E080] 
UNKNOWN [/usr/lib/libglib-2.0.so.0 +0x00024582] 
g_main_context_dispatch+0x00000098 [/usr/lib/libglib-2.0.so.0 +0x000255F8] 
UNKNOWN [/usr/lib/libglib-2.0.so.0 +0x00025930] 
g_main_loop_run+0x00000183 [/usr/lib/libglib-2.0.so.0 +0x00025ED3] 
gtk_main+0x000000B3 [/usr/lib/libgtk-x11-2.0.so.0 +0x0011FC13] 
UNKNOWN [/usr/local/stow/mozilla-sun/lib/mozilla/components/libwidget_gtk2.so 
+0x0003325E] 
UNKNOWN [/usr/local/stow/mozilla-sun/lib/mozilla/components/libnsappshell.so 
+0x000456CC] 
UNKNOWN [/usr/local/stow/mozilla-sun/lib/mozilla/mozilla-bin +0x0001BA3B] 
main+0x00000328 [/usr/local/stow/mozilla-sun/lib/mozilla/mozilla-bin +0x0001C890] 
__libc_start_main+0x000000F4 [/lib/tls/libc.so.6 +0x00015974] 
Sleeping for 5 minutes. 
Type 'gdb /usr/local/stow/mozilla-sun/lib/mozilla/mozilla-bin 8352' to attach your 
debugger to this thread. 
 
 
 

Updated

13 years ago
Blocks: 291034

Updated

12 years ago
Assignee: Louie.Zhao → nian.liu
Blocks: 333488
Status: ASSIGNED → NEW

Comment 7

11 years ago
This is for the Sun 1.7 branch only. 
Status: NEW → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → INVALID
Crash Signature: [@ nsHTMLTextFieldAccessible::GetXULTextBox ]
You need to log in before you can comment on or make changes to this bug.