Closing last tab with close widget causes crash

RESOLVED FIXED in Camino0.9

Status

Camino Graveyard
Tabbed Browsing
--
critical
RESOLVED FIXED
13 years ago
13 years ago

People

(Reporter: Chris Lawson (gone), Assigned: Mike Pinkerton (not reading bugmail))

Tracking

({crash})

unspecified
Camino0.9
PowerPC
Mac OS X
crash
Bug Flags:
camino0.9 +

Details

Attachments

(1 attachment)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8b2) Gecko/20050424 Camino/0.8+
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8b2) Gecko/20050424 Camino/0.8+

The "Always Show Tab Bar" has no provision to prevent a user from clicking the
close widget in the last remaining tab. Once this is clicked, a crash that looks
very similar to the crash in bug 290874 occurs.

Reproducible: Always

Steps to Reproduce:
1. Launch Camino with "Always Show Tab Bar" pref checked.
2. Click close widget on single open tab.
Actual Results:  
Crash.

Expected Results:  
Close the browser window, or at least not crash.
This is mentioned in bug 162241 comment 17, so I'll confirm.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Flags: camino0.9?
Keywords: crash
(Reporter)

Comment 2

13 years ago
Just to clarify -- I haven't actually looked at a crash log for this and
compared it to the other bug's crash log. What I meant by my comment was that
the crash looks very similar just watching Camino. The browser view is filled
with the standard Panther pinstripe background for a few seconds, then Camino
dies horribly.

I'll see if I can get Talkback to realise Camino is crashing and get my hands on
a log.

cl
(Reporter)

Comment 3

13 years ago
Created attachment 181742 [details]
Crash log for most recent crash

Here's a log.
(Reporter)

Comment 4

13 years ago
Comment on attachment 181742 [details]
Crash log for most recent crash

And looking at the crash log from the other crash, this one *does* look fairly
similar. Same sort of thing seems to be happening, but in different
"functions." ( I forget the Objective-C term; all my experience is in C++.)

Comment 5

13 years ago
In Objective-C, functions that are part of objects are called methods.

Updated

13 years ago
Flags: camino0.9? → camino0.9+

Comment 6

13 years ago
Wevah:
The close box on the last tab when this option is on should either be hidden or
cause the window to close, as closing the last tab crashes Camino!

Japser:
Removing the close button would be the most obvious thing to do. a) this ensures
peole can't try and close it as showing it implicates the would be able to. b) I
think it would be just weird and "inconsistant" if trying to close a tab would
close a window en tough it's correct.

If we do this, please make sure that when removing the close button the site
icon and site title shift to the left to fill up the gap.

Wevah:
Thinking about it some more, if it were up to me I'd say make it semitransparent
and disable it.

Comment 7

13 years ago
(In reply to comment #6)
> Wevah:
> Thinking about it some more, if it were up to me I'd say make it semitransparent
> and disable it.

...Since that's what a window's close box does when you temporarily can't close it.
(Assignee)

Comment 8

13 years ago
oops, i swear i tried everything else ;)

i'd say we should hide the close box when the tab is the only one. not sure how
hard that is in the code.
Target Milestone: --- → Camino0.9
(Assignee)

Comment 9

13 years ago
landed. we disable the button as you're right, that's what the OS does.
Status: NEW → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.