freeze when closing a popup window containing an applet with a button

RESOLVED WORKSFORME

Status

()

Firefox
General
--
critical
RESOLVED WORKSFORME
13 years ago
13 years ago

People

(Reporter: De Moor Yves, Assigned: Blake Ross)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(3 attachments)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; fr-FR; rv:1.7.7) Gecko/20050414 Firefox/1.0.3
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; fr-FR; rv:1.7.7) Gecko/20050414 Firefox/1.0.3

when you open a popup window containing an applet and a button : <input
type="button" value="Cancel" id="Cancel" name="Cancel" onClick="window.close();"
/> and you click on the button executing a "window.close()", the browser is no
more usable. The gui seems to respond but do noting and you have to close your
browser (and most of the time kill the instance already running).

This is a problem with the button, because if you use a link tag it works fine :
<a href="javascript:window.close();">Cancel</a>

Reproducible: Always

Steps to Reproduce:
1.open a popupwindow containing an applet and a button with onClick="window.close()
2.click on the button, the window will close and the browser will stop responding
3.

Actual Results:  
the window will close and the browser will stop responding

Expected Results:  
Just close the window and continue working.
Can you please attach a testcase (using thge create new attachment link in this
bug) or provide a URL ?
Summary: freeze when closing a popup window containing an applet with a button → freeze when closing a popup window containing an applet with a button
(Reporter)

Comment 2

13 years ago
Created attachment 181990 [details]
Set 1 : the main page

the main page, you should use this page to test the bug.
This page is a part of a set which should be downloaded compleatly.
(Reporter)

Comment 3

13 years ago
Created attachment 181992 [details]
Set 1 : the popup window

The popup window, should only be openend unsing the button in the index.html
page
This page is a part of a set which should be downloaded compleatly.
(Reporter)

Comment 4

13 years ago
Created attachment 181994 [details]
Set 1 : a sample applet from java.sun.com

The applet loaded in the popup window
This page is a part of a set which should be downloaded compleatly.
(Reporter)

Comment 5

13 years ago
Added a set of file allowing to reproduce the bug.

1. Dowload all files from set 1 and place them in the same directory.
2. Launch the index.html page.
3. click on the button to open the popup window.
4. close the window using the button in the popup window.
5. your browser stop now responding, try to go to your home page, to load
another page, ...

PS : using jre 1.5.0_02-b09

Comment 6

13 years ago
Phew, lucky I just saved all tabs in a folder...

bug reproduced in Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b2)
Gecko/20050428 Firefox/1.0+
(Reporter)

Comment 7

13 years ago
Adding an on-line test-case so you don't need to download the files, just go to
http://home.tiscali.be/yvesdm/firefox/index.html

Hope this will help you to fix this annoying bug.
wfm with 
Mozilla/5.0 (Windows; U; Windows NT 5.2; de-DE; rv:1.8b2) Gecko/20050514
and Java Plug-in 1.5.0_01 for Netscape Navigator

Comment 9

13 years ago
Hi,
Firefox 1.0.4:
1.0.4: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7.8) Gecko/20050511
Firefox/1.0.4

Mozilla Suite 1.7.3 and 1.7.6:
1.7.3: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7.3) Gecko/20040910
1.7.6: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.6) Gecko/20050319

JRE: 1.5.0_02 and 1.4.2_08

All links become unresponsive, location bar does not expand up, navigation using
back/forward drop down lists (and buttons) utimately have no effect.

The mouse switches to the "hour glass" when selecting (back/forward list) or
typing a new url in the location bar, but nothing else occurs after waiting a
few minutes.

Closing the firefox (and Mozilla suite 1.7.8 too) have the process (firefox.exe
or mozilla.exe) linger in the task manager.

Closing the popup window using the link works fine as far as I tried.

===========
I first encountered this issue when dealing with the same applet being present
in the parent and in the popup window.

Thanks for the new point of view on this problem (button vs links). 

I got a "debug" applet that traces the lifecycle events I can attach to this
case if that would help.

Your insights are appreciated.

PatH
This is an automated message, with ID "auto-resolve01".

This bug has had no comments for a long time. Statistically, we have found that
bug reports that have not been confirmed by a second user after three months are
highly unlikely to be the source of a fix to the code.

While your input is very important to us, our resources are limited and so we
are asking for your help in focussing our efforts. If you can still reproduce
this problem in the latest version of the product (see below for how to obtain a
copy) or, for feature requests, if it's not present in the latest version and
you still believe we should implement it, please visit the URL of this bug
(given at the top of this mail) and add a comment to that effect, giving more
reproduction information if you have it.

If it is not a problem any longer, you need take no action. If this bug is not
changed in any way in the next two weeks, it will be automatically resolved.
Thank you for your help in this matter.

The latest beta releases can be obtained from:
Firefox:     http://www.mozilla.org/projects/firefox/
Thunderbird: http://www.mozilla.org/products/thunderbird/releases/1.5beta1.html
Seamonkey:   http://www.mozilla.org/projects/seamonkey/
(Reporter)

Comment 11

13 years ago
The bug can always be reproduced on

Mozilla/5.0 (Windows; U; Windows NT 5.1; fr-FR; rv:1.7.12) Gecko/20050919
Firefox/1.0.7

I have tried on other computers with the same config Win-xp pro and firefox
1.0.7 and java 1.5.0_04-b05

To reproduce it :
You can download the test case for offline test, 
or try it online at http://home.tiscali.be/yvesdm/firefox/index.html

Also note in the history that other person where able to reproduce it !!

Please try to investigate to fix this bug.
If you need more information, just contact me.

Yvesdm
WFM Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b4) Gecko/20050908
Firefox/1.4

Comment 13

13 years ago
ditto comment #12.  can reproduce at:
http://games.yahoo.com/games/login2?page=ch&cat=intermediate

you need a yahoo account, but afterwards, click into a room and you'll get a
pop-up java applet window.  when closing, browser will stop responding as
described above, requiring an explicit kill to stop the process.

Comment 14

13 years ago
Confirmed using Firefox 1.0.6 using http://home.tiscali.be/yvesdm/firefox/index.html

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-GB; rv:1.7.10) Gecko/20050717 Firefox/1.0.6

Using JRE version 1.5.0_04 Java HotSpot(TM) Client VM

Appears to be fixed in 1.5RC3.
(Reporter)

Comment 15

13 years ago
Seems to be fixed in version 1.5
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → FIXED
no patch = not fixed
Status: RESOLVED → UNCONFIRMED
Resolution: FIXED → ---
-> wfm
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago13 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.