extra Description label in some bugs of long list

RESOLVED FIXED in Bugzilla 2.20

Status

()

Bugzilla
Query/Bug List
RESOLVED FIXED
13 years ago
13 years ago

People

(Reporter: timeless, Assigned: Emmanuel Seyman)

Tracking

2.19.2
Bugzilla 2.20
Bug Flags:
approval +
approval2.20 +

Details

(URL)

Attachments

(1 attachment, 1 obsolete attachment)

(Reporter)

Description

13 years ago
note that the behavior is somewhat random (!!) i've tried POST and GET, both are
broken, sometimes the first item gets two descriptions, sometimes the secon.

reproducable: yes (safari, camino; mysql, postgresql)

steps for post:
1. load
http://landfill.bugzilla.org/bugzilla-tip/buglist.cgi?query_format=advanced&short_desc_type=allwordssubstr&short_desc=&long_desc_type=allwordssubstr&long_desc=&bug_file_loc_type=allwordssubstr&bug_file_loc=&status_whiteboard_type=allwordssubstr&status_whiteboard=&keywords_type=allwords&keywords=&emailassigned_to1=1&emailtype1=substring&email1=&emailassigned_to2=1&emailreporter2=1&emailcc2=1&emailtype2=substring&email2=&bugidtype=include&bug_id=1%2C2&votes=&chfieldfrom=&chfieldto=Now&chfieldvalue=&cmdtype=doit&order=Reuse+same+sort+as+last+time&field0-0-0=noop&type0-0-0=noop&value0-0-0=
2. click long list

steps for get:
1. load
http://landfill.bugzilla.org/bugzilla-tip/show_bug.cgi?id=2&id=1&format=multiple

expected results: no inconsistencies and no doubling.

actual results (POST):
    <tr>
      <td colspan="4">
        <b>Opened:</b>&nbsp;2000-06-15 18:07
      </td>
    </tr>
    <tr>
      <td colspan="4">
        <b>Description:</b>

      </td>
    </tr>
  </table>
<div >
        <table>
          <tr>
            <td align="left">
              <b><a name="c0" href="#c0">Description</a>:</b>&nbsp;&nbsp;<script 
                type="text/javascript"><!-- 
                  addReplyLink(0);
                //--></script>

            </td>
...
    <tr>
      <td colspan="4">
        <b>Opened:</b>&nbsp;2000-06-15 11:35
      </td>
    </tr>

    <tr>
      <td colspan="4">
        <b>Description:</b>
      </td>
    </tr>
  </table>
<div >
        <br>
        <span class="bz_comment">

          ------- <i>Comment
          <a name="c1" href="#c1">#1</a> From 
          <a href="mailto:cyeh&#64;bluemartini.com">Chris Yeh</a>
          2000-06-15 15:30 
          </i>
          -------
        </span>

Comment 1

13 years ago
*** Bug 298389 has been marked as a duplicate of this bug. ***

Comment 2

13 years ago
sorry about the dupe, i didn't know that the printing page was also known as the
'long list'
(Assignee)

Comment 3

13 years ago
This is a result of PROCESSing bug/comments.html.tmpl in
bug/show-multiple.html.tmpl. Quoting from the former :

        <table>
          <tr>
            <td align="left">
              <b><a name="c0" href="#c0">Description</a>:</b>&nbsp;&nbsp;<script
                type="text/javascript"><!--
                  addReplyLink(0);
                //--></script>
            </td>
            <td align="left" width="30%">
              Opened: [% bug.creation_ts FILTER time %]
            </td>
          </tr>
        </table>

This results in having the description and the Opened field show up twice
in a long list. Patching. 
(Assignee)

Comment 4

13 years ago
Created attachment 191575 [details] [diff] [review]
Remove description and opened fields from bug/show-multiple.html.tmpl since they appear in bug/comments.html.tmpl
Assignee: query-and-buglist → eseyman
Status: NEW → ASSIGNED
Attachment #191575 - Flags: review?

Comment 5

13 years ago
Comment on attachment 191575 [details] [diff] [review]
Remove description and opened fields from bug/show-multiple.html.tmpl since they appear in bug/comments.html.tmpl

>--- ./bug/show-multiple.html.tmpl.292096	2005-08-04 11:10:26.000000000 +0200
>-    <tr>
>-      <td colspan="4">
>-        <b>Opened:</b>&nbsp;
>-        [% bug.creation_ts FILTER time %]
>-      </td>
>-    </tr>
>-    <tr>
>-      <td colspan="4">
>-        <b>Description:</b>
>-      </td>
>-    </tr>

Could you please only remove "description" and leave the creation date alone?
Attachment #191575 - Flags: review? → review-

Updated

13 years ago
OS: MacOS X → All
Hardware: Macintosh → All
Target Milestone: --- → Bugzilla 2.20
(Assignee)

Comment 6

13 years ago
Created attachment 191884 [details] [diff] [review]
remove only description

This patch removes only the description field.
(Assignee)

Updated

13 years ago
Attachment #191575 - Attachment is obsolete: true
Attachment #191884 - Flags: review?

Comment 7

13 years ago
Comment on attachment 191884 [details] [diff] [review]
remove only description

r=LpSolit
Attachment #191884 - Flags: review? → review+

Updated

13 years ago
Flags: approval?
Flags: approval2.20?
(In reply to comment #5)
> Could you please only remove "description" and leave the creation date alone?

On the URL given in the head, the creation date is doubled as well. Assuming
that the reason for this is very similar, why don't we morph the bug and catch
both flies with one stone?
(Assignee)

Comment 9

13 years ago
(In reply to comment #8)
>
> On the URL given in the head, the creation date is doubled as well. Assuming
> that the reason for this is very similar, why don't we morph the bug and catch
> both flies with one stone?

I'ld assumed that the creation date was needed by one of the other templates
which processes this file. I didn't (and still don't) have the time to check if
this is the case or not.

IMHO, a file called comments.html.tmpl should really only contain comments.

Comment 10

13 years ago
The reason I asked manu to let the creation date alone is that I much prefer to
see it in the "head" of the bug than in comment 0. But feel free to override my
r- about the first patch if you disagree; Colin is with you too. ;)
Flags: approval?
Flags: approval2.20?
Flags: approval2.20+
Flags: approval+
Reviewers shouldn't override other reviewers' r-.

I agree to comment 10 that the creation date should be part of the head. And
from comment 9 I gather that the creation date doubling is not exactly the same
thing as the description doubling.

So let's address the creation date in another bug, and let's get this one
checked in :)

Comment 12

13 years ago
tip:

Checking in template/en/default/bug/comments.html.tmpl;
/cvsroot/mozilla/webtools/bugzilla/template/en/default/bug/comments.html.tmpl,v
 <--  comments.html.tmpl
new revision: 1.19; previous revision: 1.18
done
Checking in template/en/default/bug/show-multiple.html.tmpl;
/cvsroot/mozilla/webtools/bugzilla/template/en/default/bug/show-multiple.html.tmpl,v
 <--  show-multiple.html.tmpl
new revision: 1.25; previous revision: 1.24
done


2.20rc2:

Checking in template/en/default/bug/comments.html.tmpl;
/cvsroot/mozilla/webtools/bugzilla/template/en/default/bug/comments.html.tmpl,v
 <--  comments.html.tmpl
new revision: 1.18.2.1; previous revision: 1.18
done
Checking in template/en/default/bug/show-multiple.html.tmpl;
/cvsroot/mozilla/webtools/bugzilla/template/en/default/bug/show-multiple.html.tmpl,v
 <--  show-multiple.html.tmpl
new revision: 1.24.6.1; previous revision: 1.24
done
Status: ASSIGNED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.