[Feature Request] Java/Javascript blocking per domain.

VERIFIED DUPLICATE of bug 94035

Status

()

Firefox
Preferences
--
enhancement
VERIFIED DUPLICATE of bug 94035
13 years ago
13 years ago

People

(Reporter: Esteban, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.7.7) Gecko/20050414 Firefox/1.0.3
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.7.7) Gecko/20050414 Firefox/1.0.3

Just as you can block image loading, popups, and software installation from
specific sites in Preferences, it would be *extremely* useful to be able to
allow/ignore Java/Javascript in a per site basis. 

In my daily browsing, there are only a few sites that make a valuable use of
Java/Javascript. The others use it as a replacement of the old annoying popup ads. 

Ditto for Flash, but I'm not sure this one is in your hands.

If Javascript is turned off, you would have a list of 'allowed' sites/domains
from which the browser will execute Javascript. I myself would use this option,
and only allow GMail to begin with; then add sites as I find them. This is more
practical for me since useful J/JS is rare in my experience.

If Javascript is turned on, you would have a list of 'blacklisted'
sites/domains, so Firefox will ignore all Javascript code from them.

Reproducible: Always

Comment 1

13 years ago
Per-site JavaScript controllability is there. We call it 'CAPS'.
http://www.mozilla.org/projects/security/components/ConfigPolicy.html

For Java is Bug 94035.

*** This bug has been marked as a duplicate of 94035 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.