FTP(tree) View Source brings up download dialog

VERIFIED FIXED

Status

()

Core
Networking: FTP
P3
critical
VERIFIED FIXED
18 years ago
16 years ago

People

(Reporter: mkaply, Assigned: Scott MacGregor)

Tracking

({testcase})

Trunk
x86
Windows NT
testcase
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

18 years ago
From Bugzilla Helper:
User-Agent: Mozilla/4.72 [en] (Win95; I)
BuildID:    1999122808

If I ftp to ftp://ftp.mozilla.org and then select View Source, there is a trap 
in the reflow with a null layer.

Reproducible: Always
Steps to Reproduce:
1.Type ftp://ftp.mozilla.org in the URL bar
2.Select View source when it is finished loading


Actual Results:  A dialog display saying I was downloading an http-index file 
and then it trapped.

Expected Results:  On 4.X browser, view source simply shows the same content as 
the web browser did.

Comment 1

18 years ago
View source so reassigning to Rickg
Assignee: troy → rickg

Comment 2

18 years ago
hey Judson: this bug is not really a viewsource bug; I'm never being called by 
the docloader. If you want me to do viewsource on ftp dirlistings, that's fine. 
But you need to make sure that the mime table is set up correctly. (The same way  
you taught me to set it up for RTF). 

Let me know if I can be of any help, once you've hooked up the back end. 
(ps -- I'm not sure we even want to do this, but we can if you think it's 
necessary).
Assignee: rickg → valeski

Comment 3

18 years ago
potts. any clues on how to accomplish this nightmare? We should probably just
disable view source for ftp urls.

Updated

18 years ago
Severity: normal → critical
Keywords: crash
(Reporter)

Comment 4

18 years ago
Thie is a post to the hook from eric vaughn.

A similar callstack to this trap happened when downloading a bin file on Linux.

It appears that the trap at least is caused by the unknown type dialog. Whether 
or not view source should work is probably a separate issue.

The problem is this XUL dialog is using a fieldset. Fieldsets are very
problematic in XUL. There is a xul fieldset equivalent called
"titledbox". This works very well in xul. Its exactly like a box but has
an optional title. Here is an example:

<titledbox orient="vertical">
    <title><text value="the title"/></title>

    ... you stuff here..

</titledbox>

-Eric

Comment 5

18 years ago
Does the above comment apply to this bug? I don't think fieldsets are involved in 
view source. I'm copying the comment to bug 29360, where I think it actually 
wants to be.

Updated

18 years ago
Keywords: beta1
Target Milestone: M14
(Reporter)

Comment 6

18 years ago
The original reason I opened this bug was because of the crash. I posted Erics 
comments because they are the source of the crash. When you select View Source 
on FTP, you get an unknown type file dialog which then crashes. Unknown file 
type dialogs in other areas of the browser are causing crashes.

Since the original opening of this bug, I believe that intent has changed to 
disable View Source all together in FTP, since this behavior really isn't 
defined.

I just thought y'all might be interested in knowing why the original crash 
actually happened.

Comment 7

18 years ago
Putting on a PDT- for beta1.  Will relnote.
Keywords: relnote
Whiteboard: [PDT-]

Comment 8

18 years ago
removing "crash" from keyword list. I can't get this to crash on nt or linux.
Status: NEW → ASSIGNED
Keywords: crash

Comment 9

18 years ago
changing summary from :"Crash when View Source after ftp to
ftp://ftp.mozilla.org"
Summary: Crash when View Source after ftp to ftp://ftp.mozilla.org → FTP View Source brings up download dialog

Updated

18 years ago
Target Milestone: M14 → M15

Comment 10

18 years ago
Moving to M16.
Target Milestone: M15 → M16

Comment 11

18 years ago
scott, I think the view source content handler is asking for the content type
too early. does it go through the uri loader?

Updated

18 years ago
Keywords: beta1, relnote
Whiteboard: [PDT-]
Target Milestone: M16 → M19

Comment 12

18 years ago
Marking nsbeta2. Since view source is used frequently to analyze the page's 
structure, it should work consistantly.
Keywords: nsbeta2

Comment 13

18 years ago
Putting on [nsbeta2-] radar. Not critical to beta2.  Will do in nsbeta3.
Keywords: nsbeta3
Whiteboard: [nsbeta2-]

Comment 14

18 years ago
Side note..  Try this
1. Goto ftp://ftp.mozilla.org/
2. View Source
3. Press "More Info"
4. The source for the plug-in finder window appears.  ROTFL :)

Comment 15

18 years ago
relnote.
Whiteboard: [nsbeta2-] → [nsbeta2-] [nsbeta3-]

Comment 16

18 years ago
robert-- welcome to necko!
Assignee: valeski → rjc
Status: ASSIGNED → NEW

Comment 17

18 years ago
Hi dougt, welcome to necko :)
Assignee: rjc → dougt

Updated

18 years ago
Blocks: 62354

Comment 18

18 years ago
Scott, per email, I am assigning you my MIME related bugs.  
Assignee: dougt → mscott

Updated

17 years ago
Blocks: 53201

Comment 19

17 years ago
Still occuring on 2001031204 (win98).

Updating keywords.
Keywords: nsbeta2, nsbeta3 → mozilla0.9, nsbeta1

Comment 20

17 years ago
Making component networking: FTP.
Component: Layout → Networking: FTP
Keywords: nsCatFood
Whiteboard: [nsbeta2-] [nsbeta3-]

Comment 21

17 years ago
works in today's build.
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → FIXED

Comment 22

17 years ago
Marking verified in the May 21 build
Status: RESOLVED → VERIFIED

Comment 23

17 years ago
+ testcase: will check for View Source to return HTML viewer's HTML w/ XUL tree 
view.
Keywords: testcase

Updated

16 years ago
Summary: FTP View Source brings up download dialog → FTP(tree) View Source brings up download dialog
You need to log in before you can comment on or make changes to this bug.