Crash [@ nsDirEnumerator::HasMoreElements()] or [@ CarbonCore.557.0.0]

RESOLVED WORKSFORME

Status

()

Core
XPCOM
--
critical
RESOLVED WORKSFORME
13 years ago
7 years ago

People

(Reporter: rstrong, Unassigned)

Tracking

({crash, helpwanted})

Trunk
PowerPC
Mac OS X
crash, helpwanted
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [ccbr], crash signature)

Attachments

(1 attachment)

A crash can occur on Mac OS X in nsDirEnumerator::HasMoreElements() (CarbonCore
is at the top of the stack) when it is called after the directory has been
deleted. The nsIDirectoryEnumerator interface where this was discovered was
introduced by Bug 291177. This is a spin off of Bug 292362 which fixes the
incorrect code in the caller and this bug is for fixing the interface so that
when the calling code is incorrect this interface doesn't cause a crash on Mac OS X.

Note: This doesn't cause a crash on Win32 or Linux as reported in Bug 292362
Talkback data

http://talkback-public.mozilla.org/talkback/fastfind.jsp?search=1&searchby=stacksig&match=contains&searchfor=CarbonCore.557.0.0&vendor=MozillaOrg&product=FirefoxTrunk&platform=All&buildid=&sortby=bbid

Summary: Crash [@ nsDirEnumerator::HasMoreElements()] or [@ CarbonCore] → Crash [@ nsDirEnumerator::HasMoreElements()] or [@ CarbonCore.557.0.0]
OS: Windows XP → MacOS X
Depends on: 292362

Updated

13 years ago
Keywords: helpwanted

Comment 2

13 years ago
Is this still reproducable? If not, mark this as WFM.
Caleb - there are only a couple of call sites that use
nsDirEnumerator::HasMoreElements since it was recently added and they have to
use it improperly and test on Mac OS X to cause the crash as stated in comment
#0. It will take someone that has the time and possibly Mac OS X experience to
fix this.
Assignee: dougt → nobody
QA Contact: xpcom

Comment 4

9 years ago
rs, want to make a mochitest for this, so it will be easy for someone with the Mac OS X experience to reproduce and fix the bug?
Whiteboard: [ccbr]
I wrote a simple unit test and Mossop wasn't able to reproduce it. Resolving -> WFM. I'll attach the unit test in a bit in case someone wants to make a crashtest out of it
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → WORKSFORME
Created attachment 397129 [details]
unit test
(Assignee)

Updated

7 years ago
Crash Signature: [@ nsDirEnumerator::HasMoreElements()] [@ CarbonCore.557.0.0]
You need to log in before you can comment on or make changes to this bug.