FTP passwords being showed when logged in in the ftp://username:passwd@server

RESOLVED DUPLICATE of bug 186695

Status

()

Firefox
General
--
major
RESOLVED DUPLICATE of bug 186695
13 years ago
13 years ago

People

(Reporter: Joseba, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.7) Gecko/20050416 Fedora/1.0.3-2 Firefox/1.0.3
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.7) Gecko/20050416 Fedora/1.0.3-2 Firefox/1.0.3

When I log in to an ftp server putting the username and password in the URL bar,
and the login is successful, the username & passwd are no more shown in the URL
bar. But if then I print anything in the FTP (be it a file listing, or an html
page inside the ftp server, for example) In the upper right space where it
should show the URL to the file, it also shows the username and password in
plain text.
Sorry, I can only test this in Firefox, I don't have the full Mozilla suite
installed.

Reproducible: Always

Steps to Reproduce:
1.Login to a FTP server which requires authentification
2.Print the file listing
3.Done!

Actual Results:  
It shows your password and username.

Expected Results:  
Well, I suppose it shouldn't show my passwords... This afternoon I mostly gave
my teacher at the university my home computer username and password.
Already fixed, will be in Firefox 1.1.

*** This bug has been marked as a duplicate of 186695 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.