Firefox cuts the filename of files when saving from yahoo email account

VERIFIED DUPLICATE of bug 252309

Status

()

--
minor
VERIFIED DUPLICATE of bug 252309
14 years ago
14 years ago

People

(Reporter: cfdes, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.7) Gecko/20050414 Firefox/1.0.3
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.7) Gecko/20050414 Firefox/1.0.3

I usually receive files which contains undersores on it, like
"this_is_the_file.jpg", but when I try to download the file using the "save to
computer" option the filename is truncated just before the first underscore.

Reproducible: Always

Steps to Reproduce:
1.Open e-mail with attachment in yahoo account.
2.Click in "save to computer" next to the file you want to download
3.Click in "download attachment"

Actual Results:  
The file name of the file I expect to download is truncated 

Expected Results:  
Save it with the filename that appears in the yahoo webmail page

Comment 1

14 years ago
(In reply to comment #0)

I also experience this exact bug and can provide additional details, under
Windows XP Pro.     I have also confirmed that it is unique to Firefox as
opposed to Internet Explorer (ie, IE does the correct thing).

Here is a step-by-step analysis of what I see from both programs:

1. An attachment that the sender named "My PDF-Attachment.pdf" is available for
download from the mail.
2. Yahoo displays this filename as "My_PDF_Attachment.pdf" in both programs.
3. I press the "Save to Computer" link next to the file and both programs
show a page where the "File Name:" is shown as "My_PDF_Attachment.pdf"
4. Clicking the page's "Download Attachment" button using IE brings up IE's
"File Download" panel, from which I can "Open", "Save" or "Cancel".  On this
panel, the filename is shown as the sender intended:  "My PDF-Attachment.pdf"
Pressing "Save" preserves that name (with the spaces and punctuation) and I can
then choose a destination folder for the download.
5. From Firefox, clicking Yahoo's "Download Attachment" button brings up
Firefox's "Opening" panel, where the file name has been corrupted.  The panel
actually says "Opening My" in the title bar (instead of "Opening My
PDF-Attachment.pdf"), and the content of the panel says          
        
           You have chosen to open
                   My
           which is an application/octet-stream
           from http://b2.mail.yahoo.com.

I can "Save to Disk", but if I proceed with that, a panel with the title bar
"Enter name of file to save to..." is launched with the "File name:" field
reading "My".    The characters " PDF-Attachment.pdf" have been dropped.

This filename handling behavior will occur ANY and EVERY time the sender uses
space or punctuation characters in their file names.

I hope this is helpful.

- Dean

Comment 2

14 years ago

*** This bug has been marked as a duplicate of 252309 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.