If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Every timeout that a web produces, a new dialog opens

VERIFIED DUPLICATE of bug 28586

Status

()

Firefox
Tabbed Browser
VERIFIED DUPLICATE of bug 28586
13 years ago
13 years ago

People

(Reporter: jazzka, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; ca-AD; rv:1.7.5) Gecko/20041108 Firefox/1.0
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; ca-AD; rv:1.7.5) Gecko/20041108 Firefox/1.0

In the most cases, when you open a new link in a new tab so you can continue
reading the current tab, is very usefull.

But when the network is satured or when the network performance goes down, every
new web page that is requested becomes a time out, so Firefox opens a new dialog
(interrupting the user's navigation).

This happens in any platform I've tried windows xp, windows 2000 and ubuntu
linux. My current Firefox version is: Mozilla/5.0 (X11; U; Linux i686; ca-AD;
rv:1.7.5) Gecko/20041108 Firefox/1.0

My opinion is: when a time out is produced, change the tab color, or font color
or maybe the tab's icon; so the user can continue reading the current web but
can see that the web that was launched in another tab has not loaded succesfully.

Reproducible: Always

Steps to Reproduce:
1. I'am view a web page
2. Control+click over a link, so it opens in background in other tab
3. If it produces a timeout, a new dialog opens.

Actual Results:  
The user MUST stop reading the web and click ok in the new dialog

Expected Results:  
Just tell the user that there was a time out in another way (changing tab
color...) so the user can continue reading the old web.
you want "error pages"

*** This bug has been marked as a duplicate of 28586 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.