No support for autonumbering of headings, tables, pictures etc

RESOLVED DUPLICATE of bug 4522

Status

()

--
major
RESOLVED DUPLICATE of bug 4522
14 years ago
14 years ago

People

(Reporter: lagrave+bugs+mozilla.org, Assigned: dbaron)

Tracking

({testcase})

Trunk
testcase
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0

This css-construction is not supported by Firefox:

h1 {
list-style-type: decimal;
display: list-item;
list-style-position:inside
}

<h1>HeadA</h1>
<h1>HeadB</h1>
<h1>HeadC</h1>

Reproducible: Always

Actual Results:  
HeadA
HeadB
HeadC

Expected Results:  
1. HeadA
2. HeadB
3. HeadC
(Reporter)

Comment 1

14 years ago
Btw, if there is a generic workaround for this that works in most broswers
(Mozilla, KHTML/Safari and WinIE), please let me know. Currently only Opera 7+
supports autonumbering.

Comment 2

14 years ago
Reporter, in CSS 2.1 list-style-type only applies to OL and UL.

About auto-numbering : <http://www.w3.org/TR/CSS21/generate.html#counters>

Updated

14 years ago
Assignee: nobody → dbaron
Component: General → Style System (CSS)
OS: MacOS X → All
Product: Firefox → Core
QA Contact: general → ian
Hardware: Macintosh → All

Comment 4

14 years ago
(In reply to comment #2)
> Reporter, in CSS 2.1 list-style-type only applies to OL and UL.

No, it applies to elements with display:list-item. However, we need a minimal
testcase and someone testing this with a recent nightly to make sure it is
really a bug and not a duplicate of the bug mentioned in comment 3.

Comment 5

14 years ago
Created attachment 182852 [details]
Reporters testcase

With latest trunk the output is:

0. HeadA
0. HeadB
0. HeadC

Updated

14 years ago
Keywords: testcase
Version: 1.0 Branch → Trunk

Comment 6

14 years ago
Not sure what the new CSS 2.1 specification says about this. Ian?

Comment 8

14 years ago
In the testcase they have a display:block parent, namely the BODY element. Also,
the second testcase in that bug worksforme in a recent build of Firefox and the
first is incorrect per the unpublished CSS2.1 WD I believe. (Talking about the
non-obsolete testcases here.)
> Not sure what the new CSS 2.1 specification says about this. Ian?

dbaron is the counter man. I've completely lost all understanding of how
counters work at the moment. Now, questions on margin collapsing, on the other
hand...
This has nothing to do with counters.  I also don't know what the question is.

Comment 11

14 years ago
What should happen when you have an element foo, that occurs multiple times in a
document (as siblings) with the following style rule applied:

 foo{
  list-style-type: decimal;
  display: list-item;
 }

*** This bug has been marked as a duplicate of 4522 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.