menulist popup position doesn't update after scrolling when embed in listbox

RESOLVED DUPLICATE of bug 291390

Status

()

RESOLVED DUPLICATE of bug 291390
14 years ago
14 years ago

People

(Reporter: denis, Unassigned)

Tracking

1.7 Branch
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

796 bytes, application/vnd.mozilla.xul+xml
Details
(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.6) Gecko/20050223 Firefox/1.0.1
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.6) Gecko/20050223 Firefox/1.0.1

this is about the menupopup of the menulist embed in a listbox that appear at
the old menulist position after scrolling

Reproducible: Always

Steps to Reproduce:
try this:
<groupbox style="overflow: auto; height: 100px">
      <button label="button 1" />
      <button label="button 2" />
      <button label="button 3" />
      <button label="button 4" />
      <listbox allowevents="true">
        <listcols>
          <listcol />
        </listcols>
        <listitem allowevents="true">
          <menulist>
            <menupopup>
              <menuitem label="1" />
              <menuitem label="2" />
              <menuitem label="3" />
            </menupopup>
          </menulist>
        </listitem>
      </listbox>
    </groupbox>
(Reporter)

Comment 1

14 years ago
Created attachment 182837 [details]
the xul file that shows the bug

Comment 2

14 years ago
this got fixed recently

*** This bug has been marked as a duplicate of 291390 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
Version: Trunk → 1.7 Branch
You need to log in before you can comment on or make changes to this bug.