cache preference not obeyed

VERIFIED DUPLICATE of bug 21137

Status

()

Core
Networking: Cache
P3
normal
VERIFIED DUPLICATE of bug 21137
18 years ago
18 years ago

People

(Reporter: dbaron, Assigned: davidm)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [PDT-] 1d)

(Reporter)

Description

18 years ago
DESCRIPTION:  The preference for checking the web against the Cache ("Once Per
Session"/"Every Time"/"Never") in the preference UI does not seem to be obeyed.
I tested the first two values against the HTTP server on my own machine.  (I
exited and restarted after changing the value in case the preference doesn't
update dynamically, although it should.)

I found that, with both "Once Per Session" and "Every Time":
 * a request for a file is sent every time it is viewed (perhaps it only
compares timestamps and doesn't download - I'm not sure)
 * a request for an image is sent only the first time it is viewed

This is wrong.  With the "Once Per Session" pref, documents should not be
checked if they have been accessed during the session (an exception to this
could be if there is an Expires header or something that says otherwise - the
4.x behavior, whatever it was, was fine for me).  With the "Every Time" pref,
both documents and images should be checked, I would think.  (I don't know why
anyone would want this pref, but anyway...)

STEPS TO REPRODUCE (this is hard, because it requires looking at the logs that
only I have, but it's what I did):
 * load http://dbaron.student.harvard.edu/u/david/
 * click on leaks
 * hit back
 * hit forward

ACTUAL RESULTS:
 * With both "Every Time" and "Once Per Session", images are loaded only the
first time they are used, and pages are loaded/checked on every viewing

EXPECTED RESULTS:
 * With "Every Time", pages and images should be checked every time they are
viewed (if that's what it meant in 4.x - I never used this in 4.x so I don't
really know)
 * With "Once Per Session", pages should not be checked if they have already
been loaded during the session

DOES NOT WORK CORRECTLY ON:
 * Linux, mozilla, 2000-02-24-15-M14
(Reporter)

Comment 1

18 years ago
Marking beta1 because this makes quite a few pages painful to use - especially
ones that require (or work well with) back/forward navigation, like, say,
bugzilla.  Or, say, many online shopping sites, I'd think.  I certainly notice
it when using Bugzilla.
Keywords: beta1

Comment 2

18 years ago
Putting on PDT+ radar for beta1.
Whiteboard: [PDT+]

Updated

18 years ago
Target Milestone: M14

Comment 3

18 years ago
This seems like something that can be release noted given the tighter standards
for PDT+ bugs these days.  Some questions that need to be addressed in the bug
are things like what is the default pref?  How difficult is the fix?  When can
the fix be completed?

Removing PDT+ for reconsideration.
Whiteboard: [PDT+]

Comment 4

18 years ago
norris, do you think we are exposed to memory cache reading security host?  
Please comment, and remove PDT- if it is a problem so i gets back on out pdt 
radar.  
Whiteboard: [PDT-]

Comment 5

18 years ago
I think this bug is a subset of bug 21137.  That bug contains an explanation of
how to fix the bug (or really, how to finish implementing the feature).

One point that should be made in response to this bug report is that the
imagelib always looks in the image cache before going to the netlib, regardless
of the network cache settings.  At least, this is how it has worked in all
previous Netscape releases and I expect that this is how Mozilla users will want
it to work going forward.  The reason that the image cache behaves this way is
that checking the last-modified date for each embedded image on a page can cause
some pages to load *very* slowly.

Updated

18 years ago
Target Milestone: M14 → M15

Updated

18 years ago
Target Milestone: M15 → M16

Comment 6

18 years ago
Moving to M17 which is now considered part of beta2.
Target Milestone: M16 → M17

Updated

18 years ago
Keywords: beta1 → beta2
Whiteboard: [PDT-] → [PDT-] 1d

Updated

18 years ago
Keywords: nsbeta2
(Assignee)

Comment 7

18 years ago
reassign
Assignee: gordon → davidm
Keywords: beta2
(Assignee)

Comment 8

18 years ago
marking dup of 21137 since I attached a proposed fix there


*** This bug has been marked as a duplicate of 21137 ***
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → DUPLICATE

Comment 9

18 years ago
verified DUP
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.