Closed Bug 293701 Opened 15 years ago Closed 15 years ago

DNS SRV RR support

Categories

(Core :: Networking, enhancement)

enhancement
Not set

Tracking

()

RESOLVED DUPLICATE of bug 14328

People

(Reporter: james.mcininch, Assigned: darin.moz)

Details

User-Agent:       Mozilla/5.0 (compatible; Konqueror/3.3; Linux) (KHTML, like Gecko)
Build Identifier: 

The browser should check DNS SRV records for a site to obtain a server and 
port. For example, if DNS has the following record: 
 
_http._tcp.yourdomain.tld 60000 SRV 0 0 8080 serverA.yourdomain.tld. 
 
... the browser should interpret the URL 
 
http://yourdomain.tld/index.html 
 
as 
 
http://serverA.yourdomain.tld:8080/index.html 
 
(but show the former in the location bar). This is a well-documented feature of 
DNS that's becoming increasingly popular as it's being used by VOIP systems, 
SIP, Jabber, Zeroconf, and other protocols/software. 
 
It has the advantage of uncoupling the protocol from the arbitrary port 
assignment. Also, there may be multiple SRV records for a given hostname, which 
also allows for failover (that is, if you don't get a response from the first 
server in the list, try the next with the same path). 
 

Reproducible: Always
Assignee: nobody → darin
Component: General → Networking
Product: Firefox → Core
QA Contact: general → benc
Version: unspecified → Trunk
Reproter, always search first if it hasn't been reported yet.

*** This bug has been marked as a duplicate of 14328 ***
Status: UNCONFIRMED → RESOLVED
Closed: 15 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.