If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

li contents do not flow under a float

RESOLVED DUPLICATE of bug 143162

Status

()

Core
Layout: Floats
--
minor
RESOLVED DUPLICATE of bug 143162
13 years ago
13 years ago

People

(Reporter: niol, Unassigned)

Tracking

({testcase})

Trunk
testcase
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(3 attachments)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; fr-FR; rv:1.7.8) Gecko/20050511 Firefox/1.0.4
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; fr-FR; rv:1.7.8) Gecko/20050511 Firefox/1.0.4

If you have very big li elements, and a float right on top of those, the li sets
its width so as not to overlap the float.

Reproducible: Always

Steps to Reproduce:
1. Visit the testcase

<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Strict//EN"
 "http://www.w3.org/TR/xhtml1/DTD/xhtml1-strict.dtd">

<html xmlns="http://www.w3.org/1999/xhtml" lang="fr" xml:lang="fr">
<head>
	<meta http-equiv="Content-Type" content="text/html; charset=ISO-8859-15" />
	<title>Flowing on big li</title>

	<style type="text/css" media="screen">
		#container { width:400px; color:white; }
		.main { background-color:green; }
		.floating { float:right; width:200px; background-color:blue; margin:5px; }
	</style>

</head>

<body>

<div id="container">

<div class="floating">
	Look! The contents of the list DO NOT flow below me with the Gecko rendering
engine. Is this a bug?
</div>

<div class="main">
	<ul>
		<li>Hi, I am a list with very very long <code>li</code> elements. I can be the
contents of a news log, or I don't know, anything else. A list of really long
elements. This is really a matter of choice. Some weblogs use a list to let
posts flow, and some others use <code>div</code>s. Perhaps it is a bad idea
anyway to use a list.</li>

		<li>And I am the next post. I have no problem at all to flow below the float.</li>
	</ul>
</div>

</div>

</body>

</html>
Actual Results:  
The width of the li element is automatically set not to overlap the float.

Expected Results:  
The li elements should be behind the float, and its contents should flow around
the float.
(Reporter)

Comment 1

13 years ago
Created attachment 183369 [details]
test case
(Reporter)

Comment 2

13 years ago
Created attachment 183370 [details]
Symptom
(Reporter)

Comment 3

13 years ago
Created attachment 183371 [details]
Expected result

Updated

13 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: testcase

*** This bug has been marked as a duplicate of 143162 ***
Status: NEW → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.