Firefox crashes going to URL http://www.djh.de/

RESOLVED WORKSFORME

Status

()

Core
General
RESOLVED WORKSFORME
13 years ago
11 years ago

People

(Reporter: tps@vr-web.de, Unassigned)

Tracking

1.7 Branch
x86
FreeBSD
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (X11; U; FreeBSD i386; de-DE; rv:1.7.7) Gecko/20050502 Firefox/1.0.3
Build Identifier: Mozilla/5.0 (X11; U; FreeBSD i386; de-DE; rv:1.7.7) Gecko/20050502 Firefox/1.0.3

hazel> firefox http://www.djh.de/
NP_Initialize
New
SetWindow
SetWindow
SetWindow
NewStream
WriteReady
Write
WriteReady
Write
WriteReady
Write
WriteReady
Write
WriteReady
Write
WriteReady
Write
WriteReady
Write
WriteReady
Write
WriteReady
Write
WriteReady
Write
WriteReady
Write
WriteReady
Write
WriteReady
Write
WriteReady
Write
New block
WriteReady
Write
WriteReady
Write
WriteReady
Write
WriteReady
Write
WriteReady
Write
DestroyStream
init mp3-decoder, size: 10539
dismantle mp3-decoder
init mp3-decoder, size: 10539
dismantle mp3-decoder
firefox-bin in free(): warning: modified (chunk-) pointer
firefox-bin in free(): warning: modified (chunk-) pointer
firefox-bin in free(): warning: modified (chunk-) pointer
firefox-bin in free(): warning: modified (chunk-) pointer
firefox-bin in free(): warning: modified (chunk-) pointer
firefox-bin in free(): warning: modified (chunk-) pointer
firefox-bin in free(): warning: modified (chunk-) pointer
firefox-bin in free(): warning: modified (chunk-) pointer
firefox-bin in free(): warning: modified (chunk-) pointer
firefox-bin in free(): warning: modified (chunk-) pointer
firefox-bin in free(): warning: modified (chunk-) pointer
firefox-bin in free(): warning: modified (chunk-) pointer
firefox-bin in free(): warning: modified (chunk-) pointer
firefox-bin in free(): warning: modified (chunk-) pointer
firefox-bin in free(): warning: modified (chunk-) pointer
firefox-bin in free(): warning: modified (chunk-) pointer
firefox-bin in free(): warning: modified (chunk-) pointer
firefox-bin in free(): warning: modified (chunk-) pointer
init mp3-decoder, size: 10539
init mp3-decoder, size: 10539
dismantle mp3-decoder
Segmentation fault (core dumped)

Reproducible: Always

Steps to Reproduce:
1. firefox http://www.djh.de/
2.
3.
Actual Results:  
Firefox opens the page, displays it. It crashes clicking any of the states
within the map.

Expected Results:  
Go to a new page.
*** Bug 293873 has been marked as a duplicate of this bug. ***
We need a stack trace from a build with symbols...
To bad that there is no talkback for freebsd

Comment 3

13 years ago
the map is a flash file: http://www.jugendherberge.de/images/karte.swf

<object classid="clsid:D27CDB6E-AE6D-11cf-96B8-444553540000"
codebase="http://download.macromedia.com/pub/shockwave/cabs/flash/swflash.cab#version=4,0,2,0"
height=350 width=300><param name="quality" value="best"><param name="movie"
value="../images/karte.swf"><embed height=350 quality="best"
src="../images/karte.swf" type="application/x-shockwave-flash"
width=300></embed></object>
Component: General → General
Product: Firefox → Mozilla Application Suite
(Reporter)

Comment 4

13 years ago
Not shure if this is realy a duplicate:
Firefox crashes while clicking the map,
Mozilla crashes while displaying the map.

In my opinion this is a difference.

Comment 5

13 years ago
(In reply to comment #4)
> Not shure if this is realy a duplicate:
> Firefox crashes while clicking the map,
> Mozilla crashes while displaying the map.
> 
> In my opinion this is a difference.

Maybe. If the bug is in code common to both, there could code follow which is
different in both. Does the pure flash link work for you?

http://www.jugendherberge.de/images/karte.swf
Is this a problem in a current trunk build (current Seamonkey, or Deer Park
Alpha 2 for Firefox)?
(In reply to comment #6)
> Is this a problem in a current trunk build (current Seamonkey, or Deer Park
> Alpha 2 for Firefox)?

I'm not sure. My SeaMonkey 1.0a nightly build (20050710) does not crash when
clicking on the map. But neither do my Mozilla 1.7.8 or Firefox 1.0.6 (both from
 Debian). Either they changed their website or I cannot reproduce it.
(Reporter)

Comment 8

12 years ago
With both browsers (Firefox 1.0.6 and Mozilla 1.7.8) the link just doesn't work
with Linux (Gentoo) even if there is flash installed. Calling the home page
leaves a blank part where the flash map is expected. There is no information
about a missing plugin, neither a question to download and install it if flash
is installed. If it is not installed, you are asked to download and install it.

With Linux (SuSE 9.3) the map is working. Either called directly or indirectly
via the homepage.

With FreeBSD 5.4 it doesn't work either --- but this is expected, since flash
isn't installed. Calling the home page informs about missing flash, then asks if
you like to download the neccessary plugin.

With Windows there isn't any problem using the flash-map directly or by calling
the home page if flash is installed. If it is not, you are asked to download and
install flash.
QA Contact: general → general

Comment 9

12 years ago
Thomas, Mozilla 1.7.x and Firefox 1.0.x are too old for testing now.  Please try a trunk build:
ftp://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/latest-trunk/
ftp://ftp.mozilla.org/pub/mozilla.org/seamonkey/nightly/latest-trunk/
Component: General → General
Product: Mozilla Application Suite → Core
QA Contact: general → general
Version: unspecified → 1.7 Branch

Comment 10

11 years ago
This might be a dupe of Bug 124958 which has been duped to bug 236599.
(Reporter)

Comment 11

11 years ago
I Think it would be best to close this bug, because I do not have the same platform for testing any more (migrated to FreeBSD 6.1 meanwhile, trying to go with 7.0 --- the HEAD branch).

With the various upgrades done, it is impossible to find out if firefox or seamonkey (mozilla is gone ;-) ) are now fixed and what caused the error. AFAIS it is working at the moment.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.