with fastback on, clicking back *on your mouse* while viewing a PDF causes FF to hang

RESOLVED FIXED

Status

()

Core
Document Navigation
--
critical
RESOLVED FIXED
13 years ago
9 years ago

People

(Reporter: u49640, Assigned: Brian Ryner (not reading))

Tracking

({hang, regression})

Trunk
x86
Windows XP
hang, regression
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(2 attachments, 1 obsolete attachment)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b2) Gecko/20050513 Firefox/1.0+
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b2) Gecko/20050513 Firefox/1.0+

(note: Fast Back enabled, Adobe Reader 7.0.1 installed with the view PDFs in
Browser enabled)

goto any page that has a PDF link (like the one on the URL)
click on a PDF link
click on your mouse the go back button.

--> FF uses 99% CPU time every time i tried it, but it worked fine in a older
nightly)

It works if i click the Back Button in the Toolbar

Reproducible: Always

Steps to Reproduce:

Comment 1

13 years ago
I had it happen with the 12/05/2005 build too.

* Open a PDF...click backward with the "back" button *on the mouse*
Result: Fx sits at 85% together with acroread.exe 15%

* When using the back button *in the browser* (not mouse) it does not freeze

Used: Logitech MX 310 Mouse
O/S: W2K SP4
UA: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8b2) Gecko/20050512
Firefox/1.0+
Acrobat 6 *Professional*

Comment 2

13 years ago
Addition to my post:

Fastback was also enabled (like original poster said)

Comment 3

13 years ago
Created attachment 183643 [details]
Task manager when clicked backward on the mouse
(Reporter)

Comment 4

13 years ago
it also happens if i press the "Back" button on my Keyboard (note: my Keyboard
is a MS Internet Keyboard Pro and has an extra back button)

it doesnt appear if fast back is disabled (i'll try to switch it to
Core/Session:History)
Component: General → History: Session
Product: Firefox → Core
Version: unspecified → Trunk

Updated

13 years ago
Keywords: regression

Updated

13 years ago
Blocks: 274784
QA Contact: general → history.session
Summary: clicking back on your mouse while viewing a PDF causes FF to hang → with fastback on, clicking back on your mouse while viewing a PDF causes FF to hang

Comment 5

13 years ago
Since you've mentioned the keyboard... I've tried it too
(never tought on it before) My keyboard also has some back / forward buttons.

Exactly the same result as you (Fx freezes)

Updated

13 years ago
Attachment #183643 - Attachment description: Task manager when clicked backwared on the mouse → Task manager when clicked backward on the mouse

Comment 6

13 years ago
no problems for me with 20050513 on Win2K and Acrobat Reader 7, while reading
various pdfs from http://www.nsc.com :
1. I clicked back button while the pdf wasn't completely loaded. No hang.
2. I clicked back button after the pdf was completely loaded. No hang.

Is it possible for your issue to vanish after upgrading to Acrobat 7? Perhaps
the new plugin fixes it. Btw, the test url provided doesn't work with anonymous
login. You should provide another one where you see consistend hangs.
(Reporter)

Comment 7

13 years ago
(In reply to comment #6)
> no problems for me with 20050513 on Win2K and Acrobat Reader 7, while reading
> various pdfs from http://www.nsc.com :
> 1. I clicked back button while the pdf wasn't completely loaded. No hang.
> 2. I clicked back button after the pdf was completely loaded. No hang.

you have to pressback on your mouse or your keyboard that have an extra "Back"
Button.

Pressing the Back icon on the toolbar works fine.
 
> Is it possible for your issue to vanish after upgrading to Acrobat 7? 

no, i have Adobe Reader 7.0.1

> Btw, the test url provided doesn't work with anonymous
> login. You should provide another one where you see consistend hangs.

it happens on *every* site that has a PDF linked, but i have changed it to an
other one.
(Reporter)

Comment 8

13 years ago
okay, tested it a little bit more and it doesnt happen with a clean profile, so
i guess its an extension that i have installed.

(dont know if i should close this bug, or leave it open)

Comment 9

13 years ago
I enabled the backspace operation on a button of my mouse. Interestingly, it
works as a "back button" in all but a pdf page (where it doesn't work at all).
Anyway, since you don't see it with a new profile (and if no one else cc'ed here
doesn't see it as well), you can resolve this bug as worksforme or invalid.
(Reporter)

Comment 10

13 years ago
Created attachment 183807 [details]
the pref.js that causes the problem

okay, tested it even more and found out that something in this pref.js file
causes the bug

(i used a clean profile and only my old pref.js)

Comment 11

13 years ago
(In reply to comment #10)
> Created an attachment (id=183807) [edit]
> the pref.js that causes the problem
> 
> okay, tested it even more and found out that something in this pref.js file
> causes the bug
> 
> (i used a clean profile and only my old pref.js)

Removed prefs.js, and it worked for me too!
(using acrobat 6 professional)

I guess this can be closed?
(Reporter)

Comment 12

13 years ago
i'm confused:

new profile,  this as prefs.js (the only entries)
user_pref("browser.search.selectedEngine", "Google");
user_pref("browser.sessionhistory.max_viewers", 7);
user_pref("browser.startup.homepage_override.mstone", "rv:1.8b2");
user_pref("intl.charsetmenu.browser.cache", "UTF-8");
user_pref("network.cookie.prefsMigrated", true);
user_pref("security.warn_entering_secure", false);

and i see the bug.

(In reply to comment #11)
> Removed prefs.js, and it worked for me too!
> (using acrobat 6 professional)

if you remove the prefs.js the fastback setting is disabled again

i dont think that i should close this bug. i just enabled the fast back and the
bug is there again.
(Reporter)

Updated

13 years ago
Attachment #183807 - Attachment is obsolete: true

Comment 13

13 years ago
(In reply to comment #12)
> i'm confused:
> 
> new profile,  this as prefs.js (the only entries)
> user_pref("browser.search.selectedEngine", "Google");
> user_pref("browser.sessionhistory.max_viewers", 7);
> user_pref("browser.startup.homepage_override.mstone", "rv:1.8b2");
> user_pref("intl.charsetmenu.browser.cache", "UTF-8");
> user_pref("network.cookie.prefsMigrated", true);
> user_pref("security.warn_entering_secure", false);
> 
> and i see the bug.
> 
> (In reply to comment #11)
> > Removed prefs.js, and it worked for me too!
> > (using acrobat 6 professional)
> 
> if you remove the prefs.js the fastback setting is disabled again
> 
> i dont think that i should close this bug. i just enabled the fast back and the
> bug is there again.

Yeah, that's true.
Sorry for jumping too fast to conclusions.

S.

Comment 14

13 years ago
I apologize if this is a me-too, but I see this bug with a clean profile, the
only non-default setting is ..max_viewers = 2.  Using Acrobat reader 7.0.1. 
Firefox hangs when the back button is pressed, control is restored if an
AcroRead process is killed.

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b2) Gecko/20050517
Firefox/1.0+
(Reporter)

Updated

13 years ago
Flags: blocking1.8b3?
Flags: blocking-aviary1.1?
Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8b2) Gecko/20050518
Firefox/1.0+ ID:2005051808

Adobe Acrobat Plug-In Version 7.00

WFM

I simply give the pdf document time to load and unload and there's no crash at all
It's not a blazingly fast method I suppose.

Comment 16

13 years ago
(In reply to comment #15)

> I simply give the pdf document time to load and unload and there's no crash at all
> It's not a blazingly fast method I suppose.

For me it's not a matter of impatience, the hang has lasted for over
eight minutes (at which time I kill the AcroRd32.exe process).

Some other data points: the problem does not occur if I use Alt-Left
Arrow. I'm using a MS USB IntelliMouse Optical with driver version
5.1.2600.0.

Comment 17

13 years ago
Here's the build ID that I most recently tested on (see previous comment):
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b2) Gecko/20050518
Firefox/1.0+
(Reporter)

Updated

13 years ago
Summary: with fastback on, clicking back on your mouse while viewing a PDF causes FF to hang → with fastback on, clicking back *on your mouse* while viewing a PDF causes FF to hang
others crash using the mouse backbutton on images too.
same problem ?

Comment 19

13 years ago
This is not really a crash, FF merely hangs at 100% CPU until you kill
acroRd32.exe, then it switches back to the previous page normally.

Comment 20

13 years ago
(In reply to comment #18)
> others crash using the mouse backbutton on images too.
> same problem ?

With bfcache off FF crashes after pressing the mouse back button while viewing
an image.

With bfcache on (..max_viewers 2) the mouse back (and forward) button works
normally when moving from and to an image.  However, it crashes if the tab is
showing an image and I click on the X.

I wonder if all of the problems are connected?

Comment 21

13 years ago
(In reply to comment #20)
> (In reply to comment #18)
> > others crash using the mouse backbutton on images too.
> > same problem ?
> 
> With bfcache off FF crashes after pressing the mouse back button while viewing
> an image.
> 

No, this is not connected to this bug, there is a seperate bug filed for it: bug
294630

Updated

13 years ago
Keywords: hang
(Assignee)

Comment 22

13 years ago
Created attachment 185091 [details] [diff] [review]
patch

The problem happens in this case because we're inside of the plugin's event
loop (it has forwarded us the mouse button press).  Acrobat (and probably some
other plugins) don't like being torn down while handling an event.  I think we
can fix this by just tearing down the old content viewer asynchronously on a
PLEvent.  I no longer see the hang with this patch.
(Assignee)

Updated

13 years ago
Assignee: nobody → bryner
Status: NEW → ASSIGNED
Attachment #185091 - Flags: superreview?(jst)
Attachment #185091 - Flags: review?(jst)
Comment on attachment 185091 [details] [diff] [review]
patch

r+sr=jst
Attachment #185091 - Flags: superreview?(jst)
Attachment #185091 - Flags: superreview+
Attachment #185091 - Flags: review?(jst)
Attachment #185091 - Flags: review+
(Assignee)

Updated

13 years ago
Attachment #185091 - Flags: approval1.8b3?

Comment 24

13 years ago
Comment on attachment 185091 [details] [diff] [review]
patch

a=chofmann
Attachment #185091 - Flags: approval1.8b3? → approval1.8b3+
(Assignee)

Comment 25

13 years ago
checked in.
Status: ASSIGNED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → FIXED
(Reporter)

Comment 26

13 years ago
looks fine with Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b2)
Gecko/20050602 Firefox/1.0+

marking verified
Status: RESOLVED → VERIFIED
(Reporter)

Comment 27

13 years ago
happens again with
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b2) Gecko/20050608
Firefox/1.0+
and with the 20050607 version
Status: VERIFIED → REOPENED
Resolution: FIXED → ---

Comment 28

13 years ago
Confirming the regression with:
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b2) Gecko/20050609
Firefox/1.0+ ID:2005060915

Comment 29

13 years ago
Some Talkback IDs after killing the Acrobat Process because of hang (killing the
Firefox Process does not invoke Talkback): TB6593026Q, TB6592883E, TB6592881M
All with: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b2)
Gecko/20050610 Firefox/1.0+ ID:2005061023

Comment 30

13 years ago
Jay! This is WFM now with:
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b2) Gecko/20050616
Firefox/1.0+ ID:2005061621
One of the latest checkins for bfcache must have fixed it.
Well done!
(Reporter)

Comment 31

13 years ago
yep, works in Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b2)
Gecko/20050616 Firefox/1.0+
Status: REOPENED → RESOLVED
Last Resolved: 13 years ago13 years ago
Resolution: --- → FIXED

Updated

13 years ago
Flags: blocking1.8b3?
Flags: blocking-aviary1.1?

Updated

9 years ago
Component: History: Session → Document Navigation
QA Contact: history.session → docshell
You need to log in before you can comment on or make changes to this bug.