The default bug view has changed. See this FAQ.

Search/find fails on words containing soft hyphen (­)

RESOLVED FIXED in mozilla1.9alpha8

Status

()

Core
Embedding: APIs
P3
major
RESOLVED FIXED
12 years ago
9 years ago

People

(Reporter: Mikko Virkkilä, Assigned: mano)

Tracking

({html4, testcase})

Trunk
mozilla1.9alpha8
html4, testcase
Points:
---
Bug Flags:
in-testsuite ?

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.6) Gecko/20050306 Firefox/1.0.1 (Debian package 1.0.1-2)
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.6) Gecko/20050306 Firefox/1.0.1 (Debian package 1.0.1-2)

Soft hyphens (­) are never rendered in Firefox (Bug 9101). Many sites (esp
news outlets) use ­ since every other browser has support for them. This
causes problems for find, since "dis­cre­tion­a­ry" will be
rendered as "discretionary" but will not mach when you search for it.

Reproducible: Always

Steps to Reproduce:
1. Go to: https://bugzilla.mozilla.org/attachment.cgi?id=906
2. Press ctrl+f
3. Type "discretionary"
Actual Results:  
The word is not found

Expected Results:  
The ­ should be ignored, and the word should be found.

Comment 1

10 years ago
Bug 9101 is fixed, but this bug is still present.

We should ignore ­ when searching, if possible.

Comment 2

10 years ago
http://www.w3.org/TR/REC-html40/struct/text.html#h-9.3.3 says "For operations such as searching and sorting, the soft hyphen should always be ignored."
Keywords: html4, testcase
Created attachment 273268 [details] [diff] [review]
patch
Attachment #273268 - Flags: superreview?(jst)
Attachment #273268 - Flags: review?(jst)
Assignee: nobody → mano
Component: Find Toolbar / FastFind → Embedding: APIs
Priority: -- → P3
Product: Firefox → Core
Target Milestone: --- → mozilla1.9beta1
Version: unspecified → Trunk
Status: NEW → ASSIGNED

Updated

10 years ago
Attachment #273268 - Flags: superreview?(jst)
Attachment #273268 - Flags: superreview+
Attachment #273268 - Flags: review?(jst)
Attachment #273268 - Flags: review+
mozilla/embedding/components/find/src/nsFind.cpp 1.47
Status: ASSIGNED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → FIXED

Comment 5

10 years ago
We _may_ also want to ignore ​ (zero width space), which can be used as a line-breaking character without visible hyphen (for example in URLs).
Hi Jonathan, that seems a good idea to me, I filed bug 389651 for it.
Flags: in-testsuite?
Depends on: 404773
You need to log in before you can comment on or make changes to this bug.