Use $ORIGIN on HP-UX in linking LDAP C SDK CLUs

RESOLVED DUPLICATE of bug 322576

Status

Directory
LDAP C SDK
RESOLVED DUPLICATE of bug 322576
13 years ago
12 years ago

People

(Reporter: Ulf Weltman, Assigned: mcs)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.8) Gecko/20050518 Firefox/1.0.4
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.8) Gecko/20050518 Firefox/1.0.4

It's been a pet peeve of customers that the ldaptools can't be run "from
anywhere" without setting SHLIB_PATH.  The "bug" comes up every couple of
months...  Maybe we can link with $ORIGIN?

Here's some doc on using $ORIGIN on HP-UX:
http://docs.hp.com/en/B2355-90730/B2355-90730.html#RN.CVT.NN52a

Reproducible: Always

Steps to Reproduce:
1.
2.
3.
(Assignee)

Comment 1

13 years ago
This seems like a good idea.  I thought we used $ORIGIN on Solaris, but I don't
see where that is done in the code (maybe that was only for Directory Server???)

Do you have time to create a patch?
(Reporter)

Comment 2

13 years ago
Looks like it's done in mozilla/directory/c-sdk/build.mk for Solaris.  BTW, I
had originally thought this should be done only on HP-UX B.11.23 but it looks
like the patch to support $ORIGIN on B.11.11 has been out since 2003/04/11.  So
on B.11.11 it'll use $ORIGIN if patch PHSS_28436 or later is installed, or else
it'll look in two bogus places before it looks in the regular relative places. 
I believe that's the same behavior as Solaris 8.
(Reporter)

Comment 3

13 years ago
Created attachment 184336 [details] [diff] [review]
Patch to add $ORIGIN on HP-UX.
(Assignee)

Comment 4

13 years ago
Comment on attachment 184336 [details] [diff] [review]
Patch to add $ORIGIN on HP-UX.

The patch looks fine.  I cannot confirm that it works though (I do not have
access to an HP/UX computer).
Attachment #184336 - Flags: review+
(Reporter)

Comment 5

13 years ago
I've built and tested for $ORIGIN and relative paths on HP-UX B.11.11 on one
host with the dld patch and one without.

Comment 6

13 years ago
Is there a config test I can do to determine if the linker supports $ORIGIN?  Can I do something like
if test "$OS_RELEASE" = "B.11.11" -o "$OS_RELEASE" = "B.11.23"; then support origin ; fi
?
Preferably something easy like that instead of actually testing the linker directly with a program.

Comment 7

12 years ago
Mark, you can resolve this bug as a dup of https://bugzilla.mozilla.org/show_bug.cgi?id=322576 - the fixes for that bug will also have the $ORIGIN support as well.
(Assignee)

Comment 8

12 years ago

*** This bug has been marked as a duplicate of 322576 ***
Status: NEW → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.