Closed Bug 294779 Opened 15 years ago Closed 15 years ago

Delete profile could also delete user files (if user behaves wrong)

Categories

(Toolkit :: Startup and Profile System, defect, critical)

x86
Windows XP
defect
Not set
critical

Tracking

()

VERIFIED DUPLICATE of bug 270705

People

(Reporter: bazonbloch, Unassigned)

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; de-DE; rv:1.7.7) Gecko/20050414 Firefox/1.0.3
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; de-DE; rv:1.7.7) Gecko/20050414 Firefox/1.0.3

It is not possible to delete the profilefiles (using the profile manager)
without deleting all other files in the profilefolder. This could be a problem
if the user has other data in the profilefolder and ignores the warning message
when deleting the profile (or misunderstands the warning message - which
happend, see next bracket). Of course, the user acted wrong in severall ways if
he did so, but due to the severe consequences one could think about this
problem. (This behaviour was reported by 'wine' in the german firefox forum,
read it from here:
http://firefox.uni-duisburg.de/forum/viewtopic.php?p=131506#131506 if you could
read german. The user selected the 'My Documents' folder as his Profilefolder
and deleted this Profile afterwards, ignoring the warning message. He lost
nearly all his personal data!)


Reproducible: Always

Steps to Reproduce:
1.Create a new profile in a none empty test folder (with non important files)
with the profile manager
2.Delete this profile with the profile manager, ignore the warning, select
'delete files' 

Actual Results:  
The whole profilefolder is deleted, including the none-profile userfiles.

Expected Results:  
(a) Only delete profile files or
(b) Display a warning message when a user selectes a none-empty folder or
Systemfolder or even the root folder of a partition. or
(c) something else?

Another approach to this problem is
https://bugzilla.mozilla.org/show_bug.cgi?id=18927
But even that way (moving old profilefolder into trash, not delete it), it is
not possible to seperate user files from profile files.

*** This bug has been marked as a duplicate of 270705 ***
Status: NEW → RESOLVED
Closed: 15 years ago
Resolution: --- → DUPLICATE
Status: RESOLVED → VERIFIED
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.