Title shown in main window doesn't show title of currently opened tab.

RESOLVED DUPLICATE of bug 250423

Status

()

Firefox
Tabbed Browser
RESOLVED DUPLICATE of bug 250423
13 years ago
13 years ago

People

(Reporter: Rojas, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.8) Gecko/20050511 Firefox/1.0.4
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.8) Gecko/20050511 Firefox/1.0.4

After second tab is opened, the main title bar still shows Title of first tab,
and that title stays even if tab containing related site is closed. Same name
stays in taskbar (tray). 

Reproducible: Sometimes

Steps to Reproduce:
1.open any site in first tab, exp. www.tportal.hr
2.open any site in second tab, exp. www.iskon.hr
3.close first tab, and title in main Firefox still shows its title (after I
closed www.tportal.com tab, still main title shows T-Portal, even in taskbar,
altohoght only ISKON page is opened.

Actual Results:  
Title of first page stays, even I closed that tab, and am lookin another one.

Expected Results:  
Firefox should allways show title of site (tab) I'm currently browsing.

I noticed it in Firefox 1.0.4 version.

Comment 1

13 years ago
Created attachment 184464 [details]
image of the bug

Attached screenshot showing the bug.  Title bar displays different title from
the currently focused tab.

Comment 2

13 years ago
Is that Deer Park in the screenshot or an unofficial build?

Comment 3

13 years ago
I also experienced this bug, though I am using Firefox 1.0.4.(Mozilla/5.0
(Windows; U; Windows NT 5.1; en-US; rv:1.7.8) Gecko/20050511 Firefox/1.0.4)
I will add a screenshot. I used the same method as the submitter, however the
pages I experienced this with are:
http://forums.fark.com/cgi/fark/comments.pl?IDLink=1442081
and then
http://apple.slashdot.org/article.pl?sid=05/06/02/1523238&from=rss
Unfortunately, I can't reproduce this currently, but I will update if I can.

Comment 4

13 years ago
Created attachment 185210 [details]
From Andrew C.- Bug in Firefox 1.0.4

Comment 5

13 years ago
I experience this behavior with the lastest Deer Park.

Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8b2) Gecko/20050603
Firefox/1.0+

Comment 6

13 years ago
I've noticed this behavior for a very long time, I believe since before firefox
1.0 (though I am not entirely sure).

An easy work around is selecting a different tab, since firefox seems to always
load the title of a tab when you select it.

This happens to me every time I close a tab (I usually use the mouse wheel, but
occasionally use ctrl+F4 and the button).

I deal with MANY tabs OFTEN (I read many webcomics that I of course open all at
once in tabs) so this one is fairly obvious, but it didn't occur to me to report
it 'till tonight because it really is a fairly minor thing.

Comment 7

13 years ago
I too have witnessed this bug ever since I've started using Firefox. I'm using
the current update 1.0.6. However, the title bar doesn't refresh when a new tab
is selected. However, in opening a new Firefox window without closing the
problematic one, there is no problem, at least initially. This suggests that the
problem may be triggered somehow, but I can's see where or how.

Comment 8

13 years ago
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b4) Gecko/20050908 Firefox/1.4

I also have experienced this bug (using 1.5 Beta).
The last loaded tab's title remains in the title bar, and taskbar button until
another page is refreshed, toggling which tab is active makes no difference.

Comment 9

13 years ago
I'm experiencing this bug also, with the latest version of Firefox (1.0.7) in
Linux. I'm glad I searched for it here. :) It seems to happen on specially coded
CSS/JS pages, as I only noticed it when visiting the link below... it happens
with no other sites I've seen (so far). I get your exact symptoms... the Title
bar keeps the title of that page even when I switch the tab, close out of it, or
minimize Firefox.

Problematic link: http://www.gamepc.com/labs/view_content.asp?id=paxville&page=9

Comment 11

13 years ago
Please reopen if you disagree

*** This bug has been marked as a duplicate of 250423 ***
Status: NEW → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.