Firefox slows and crases when saving images

RESOLVED DUPLICATE of bug 159107

Status

()

Toolkit
Downloads API
RESOLVED DUPLICATE of bug 159107
13 years ago
9 years ago

People

(Reporter: plbailey, Unassigned)

Tracking

1.7 Branch
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.8) Gecko/20050511 Firefox/1.0.4
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.8) Gecko/20050511 Firefox/1.0.4

Alternate clicking on a graphic and saving to HD took ages and after a few saves
Firfox stopped responding.

Reproducible: Always

Steps to Reproduce:
1. Alternate click on graphic
2. Click Save Image As
3. Click Save

Actual Results:  
Image was eventually saved but Firefox took up to 30 seconds to respond. After
several repeats with different images Firefox stopped responding.

Expected Results:  
Saved image quickly

The problem was solved by cleaning out the Download mamager. It seemed as though
the download manager was going though the complete list every time and it
contained a couple of items that were not completely downloaded. 

Firefox crashed for weeks whenever a few images were saved before I discovered
the problem. Perhaps a later build could be altered to ignore checking the
Download list when saving images. Alternately, there could be a problem when
adding a new download to a large list and it needs addressing.

Comment 1

13 years ago
Problem is well known.

for FF use this to prevent a quick size growing: bug 132755 comment 106
or for all: write-protect the file downloads.rdf (disadvantage: no dl. history)

See Bug 159107.


*** This bug has been marked as a duplicate of 159107 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
Version: unspecified → 1.0 Branch
(Assignee)

Updated

9 years ago
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.