After clicking on a link from this page then clicking back, it always takes you back to the top of the page.

RESOLVED WORKSFORME

Status

SeaMonkey
General
--
major
RESOLVED WORKSFORME
13 years ago
12 years ago

People

(Reporter: Nathan, Unassigned)

Tracking

Trunk
x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b2) Gecko/20050521
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b2) Gecko/20050521

For example: if you go to the bottom of the page and click on 10 Guests 5 Users
then click back after going to that page it always takes you back to the top of
the page instead of back to the bottom where you were at before you left that
page.  

Reproducible: Always

Steps to Reproduce:
1.  Click on (for example, it will different every time depending on how many
people are on the site at the time)  15 Guests 10 Users.  This will take you to
a page showing what everyone is viewing at that time.
2.  Now click back (or use the back button on the mouse).  Instead of it taking
you back to the bottom of the page (15 Guests 10 Users)  it will go back but to
the top of the page (you will see Chitchat listed and it's the top of the page).
3.

Actual Results:  
It won't go back to where you were at.  It always goes back to the top of the
page no matter what.  Then you have to scroll back down again to get back to
where you were.

Expected Results:  
When you click a link on a page then use the back button to go back to it it is
supposed to return to the previous page exactly where you left that page from. 
Not to the top of the previous page.

This happens on both of my computers.  Windows XP Service pack 2.  I have tried
to reproduce the bug in Internet Explorer and I am unable to do so.  In other
words, I don't have this problem with Internet Explorer.

Comment 1

13 years ago

*** This bug has been marked as a duplicate of 215405 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
Summary: After clicking on a link from this page then clicking back, it always takes you back to the top of the page. → After clicking on a link from this page then clicking back, it always takes you back to the top of the page.

Comment 2

13 years ago
No dupe, site doesn't use no-store.
Reporter: Where can you click on (here: " 13 Guests, 0 Users") that link? Here
this is just normal text, but not a link. Anyway, when i scroll down, click on a
forum link and then go back, it takes me back to the position i was before (so wfm).
Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---
It uses pragma: no-cache, which has the same effect.

*** This bug has been marked as a duplicate of 215405 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago13 years ago
Resolution: --- → DUPLICATE

Comment 4

13 years ago
Still no dupe ;), i asked some dev and read some code myself. That bug it was
duped to is only for sites with no-store or no-cache+https.
Severity: normal → major
Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---

Comment 5

13 years ago
(In reply to comment #2)
> No dupe, site doesn't use no-store.
> Reporter: Where can you click on (here: " 13 Guests, 0 Users") that link? Here
> this is just normal text, but not a link. 

Same here, but I clicked below on one of the usernames and got to a page telling
me I must register or login to view profiles.
I assume that text will be a link if you are logged in, and maybe that bug only
can be seen if logged in?

wfm Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.8b2) Gecko/20050521

following some links in the site and off the site and going back.
Version: unspecified → Trunk
This worksforme with a current trunk build, with bfcache on or off.
Marking so.  Please reopen if this is still an issue, but only with trunk builds
(so not Firefox 1.0.x or Mozilla 1.7.x).
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago12 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.