Right click on Bookmarks, sort by name, causes bookmarks column to close after sorting.

RESOLVED DUPLICATE of bug 195031

Status

()

--
minor
RESOLVED DUPLICATE of bug 195031
14 years ago
14 years ago

People

(Reporter: theohmster, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.8) Gecko/20050511 Firefox/1.0.4 (ax)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.8) Gecko/20050511 Firefox/1.0.4 (ax)

Clicking on the Bookmarks menu causes it to open. I can then drag my mouse down
the open column of bookmarks and at any place, right click and choose "Sort by
name". This will immediately close the open Bookmarks menu but the menu will
properly sort the list by name. This is not serious, the sorting does work
properly, but is annoying in that I have to go back to the bookmarks menu again
after sorting the list. Internet Explorer does not make one have to reopen the
Bookmarks menu again after sorting, the list is sorted as it should be, and one
can then click on the bookmark of their choice. Firefox makes the user sort and
then reopen the Bookmarks menu again to select a bookmark. Annoying but not
serious. Causes user to do an extra step.

Reproducible: Always

Steps to Reproduce:
1. Open Bookmarks menu.
2. Right click anywhere on the list of bookmarks, choose "Sort by name", left click.
3. Observer the list of bookmarks close, when reopened, it will be properly sorted.
4. Feel mildly frustrated because you have to open the Bookmarks menu again in
order to see your newly sorted bookmarks.

Actual Results:  
Mild disappointment because I had to open my Bookmarks menu again to find my
freshly sorted bookmarks.

Expected Results:  
The bookmarks menu should have sorted the contents alphabetically and then
*remained* open so that I could have easily found the bookmark of my choice
after sorting. This is the way that Internet Explorer behaves.

I tried this with Firefox 1.0.4 on Windows XP and Fedora Core 3, both Firefox
programs exhibit the same behavior. Nothing relevant to my configuration, I use
the default Firefox theme on both browsers. This bookmark sorting behavior has
been consistent with all versions and builds of Firefox that I have ever used or
tried before. I think that the bookmark sorting behavior should be consistent
with IE and not make the user take an additional step of reopening the Bookmarks
menu again after sorting.

*** This bug has been marked as a duplicate of 195031 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.