Crash if opening a link (from Thunderbird) when profile picker window is open

RESOLVED WORKSFORME

Status

()

Toolkit
Startup and Profile System
--
major
RESOLVED WORKSFORME
13 years ago
9 years ago

People

(Reporter: Kathleen Brade, Unassigned)

Tracking

({crash})

unspecified
PowerPC
Mac OS X
crash
Points:
---
Bug Flags:
blocking1.8b5 -

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [has draft patch])

Attachments

(2 attachments)

(Reporter)

Description

13 years ago
I launched Firefox (1.0.2) on MacOSX (10.4.1) but did not pick a profile.  I
switched focus to Thunderbird (already running).  From an e-mail, I clicked a
link.  A Firefox browser window opened (with the profile picker window still
open).  Then Firefox crashed.

This may be a known issue; I don't have time to query right now.

Comment 1

13 years ago
Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.7.9) Gecko/20050711
Firefox/1.0.5

I just got this one also.
(Reporter)

Comment 2

13 years ago
This is a bad crash; I run into it often (several times per week).  Requesting
blocking status.
Flags: blocking1.8b4?

Updated

13 years ago
Flags: blocking1.8b4? → blocking1.8b4-
Created attachment 254913 [details] [diff] [review]
possible fix - work in progress and needs testing

this also fixes bug 370123 which I believe is for all practical purposes a dupe of this bug.
rob, I have applied your patch to my 1.8 branch build on mac, and I crash when I follow these steps:

1)  launch firefox with -ProfileManager
2)  when the profile manager UI is up, click on a link in thunderbird.

I'll attach the stack.  note, it is from official 1.8 build.
Created attachment 254992 [details]
crash report
robert and I sat down, and we think this code is at the root of the crash on mac:

#ifdef XP_MACOSX
    SetupMacCommandLine(gRestartArgc, gRestartArgv);
#endif

if you comment that out, we don't crash.

we put some alerts in his patch, and we never reach them.

perhaps this is something we can address for 2.0.0.3 / trunk on the mac.
Does this bug still happen? I'm not able to reproduce it on trunk and with the latest Gran Paradiso build. Perhaps Firefox 2.0.0.x related?
Henrik, no idea. I don't have a Mac OS X system and was working with Seth that had a Mac OS X system the last time I saw this / tried to fix it.
(Assignee)

Updated

10 years ago
Product: Firefox → Toolkit

Comment 9

9 years ago
needs additional Mac testing.

see comment 4, 5, 7
Whiteboard: [has draft patch]
WFM with FF 3.0.10 and Shredder ...
FF 3.0.10 and Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.1b5pre) Gecko/20090504 Shredder/3.0b3pre

Nothing crashes, but the results are strange. FF Profile Window is open, click the link in email, a nav bar (using default, not my) theme pops open but doesn't load a page, FF Profile Window still open, can click from FF nav bar window to Profile Window but not back, select profile and FF opens up but no tabs other than home tabs present.

No crashes though.
No crash -> WFM then.
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.