HTML Form doesn't refresh after page refresh

RESOLVED DUPLICATE of bug 46845

Status

()

Firefox
General
RESOLVED DUPLICATE of bug 46845
12 years ago
12 years ago

People

(Reporter: Jonathan Hohle, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.8) Gecko/20050511 Firefox/1.0.4
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.8) Gecko/20050511 Firefox/1.0.4

When an html page with a form is refreshed, if the data in that form is changed
(like the default selection in a drop down box that hasn't been changed), those
form fields aren't updated with the new default value.

it would make sense not to change *dirty* fields (fields that have been
modified), but unchanged fields should respect the new default value if its
different when the page is refreshed.

Reproducible: Always

Steps to Reproduce:
1. Create an HTML document with a form with a drop down box and no default selection
2. Load the page in Firefox
3. Change the default selection in your HTML text file
4. refrseh the page in Firefox

Actual Results:  
The selected item will remain as whatever was previously selected in Firefox,
even if that field hadn't been modified by the user. The html correctly reflects
the new default form value.

Expected Results:  
The "selected" field should appear as selected in the option dropdown.
This is as designed. Use Shift+Reload if you want form values reset.

*** This bug has been marked as a duplicate of 46845 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.