Last Comment Bug 295306 - Firefox is unusable in solaris x86 using Sun SOS10 compiler.
: Firefox is unusable in solaris x86 using Sun SOS10 compiler.
Status: RESOLVED FIXED
: fixed1.8.1.1
Product: Core
Classification: Components
Component: XPCOM (show other bugs)
: Trunk
: Sun Solaris
: -- normal (vote)
: ---
Assigned To: Leon Sha
:
Mentors:
: 305748 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2005-05-24 00:20 PDT by Leon Sha
Modified: 2006-11-28 19:08 PST (History)
8 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Patch (6.18 KB, patch)
2005-05-24 03:20 PDT, Leon Sha
darin.moz: review+
darin.moz: superreview+
asa: approval1.8b3+
Details | Diff | Splinter Review
To build mozilla in a sparated directory. (902 bytes, patch)
2005-11-09 19:20 PST, Boying Lu
darin.moz: review+
dbaron: review-
darin.moz: superreview+
Details | Diff | Splinter Review
address dbaron's comment (1.06 KB, patch)
2005-12-16 01:12 PST, Ginn Chen
dbaron: review+
benjamin: superreview+
Details | Diff | Splinter Review
Cleaned up patch (1.04 KB, patch)
2006-11-15 17:27 PST, Justin Dolske [:Dolske]
dveditz: approval1.8.1.1+
Details | Diff | Splinter Review

Description Leon Sha 2005-05-24 00:20:22 PDT
See also bug 268524.
Firefox can start up, but you can not type anything in url bar.
This bug is very similar to bug 268524.
But I don't know why there is no problem with mozilla.
Comment 1 Leon Sha 2005-05-24 03:16:48 PDT
But this time the problem is here:
mozilla/xpcom/reflect/xptcall/src/md/unix/xptcstubs_x86_solaris.cpp
I try to use the same method of bug 295306.
I write a inline template file, and compile it with 
xptcstubs_x86_solaris.cpp to assemble file. Then create a new assemble
file. But I met a problem. After compile the symble of 
STUB_ENTRY(0...9) is not confirmed with symble of STUB_ENTRY(10...99).
For example the symble of STUB_ENTRY(3) is 
__1cOnsXPTCStubBaseFStub36M_I_, the symble of STUB_ENTRY(33) is  
                   ^this is F
__1cOnsXPTCStubBaseGStub36M_I_,
                   ^this is G

I'll attach a patch of this bug. Although it is ungly, it do work.
Comment 2 Leon Sha 2005-05-24 03:20:30 PDT
Created attachment 184397 [details] [diff] [review]
Patch
Comment 3 Darin Fisher 2005-06-13 10:53:26 PDT
Comment on attachment 184397 [details] [diff] [review]
Patch

Requesting approval on behalf of Leon.
Comment 4 Leon Sha 2005-06-15 01:32:49 PDT
Checking in Makefile.in;
/cvsroot/mozilla/xpcom/reflect/xptcall/src/md/unix/Makefile.in,v  <--  Makefile.in
new revision: 1.80; previous revision: 1.79
done
RCS file:
/cvsroot/mozilla/xpcom/reflect/xptcall/src/md/unix/xptcstubs_asm_x86_solaris_SUNW.s,v
done
Checking in xptcstubs_asm_x86_solaris_SUNW.s;
/cvsroot/mozilla/xpcom/reflect/xptcall/src/md/unix/xptcstubs_asm_x86_solaris_SUNW.s,v
 <--  xptcstubs_asm_x86_solaris_SUNW.s
initial revision: 1.1
done
Checking in xptcstubs_x86_solaris.cpp;
/cvsroot/mozilla/xpcom/reflect/xptcall/src/md/unix/xptcstubs_x86_solaris.cpp,v
<--  xptcstubs_x86_solaris.cpp
new revision: 1.3; previous revision: 1.2
done
Comment 5 Boying Lu 2005-11-09 19:20:19 PST
Created attachment 202455 [details] [diff] [review]
To build mozilla in a sparated directory.
Comment 6 Christian :Biesinger (don't email me, ping me on IRC) 2005-11-14 14:57:10 PST
is there really no better way than this? the source dir should not be written to.
Comment 7 Ginn Chen 2005-11-17 19:39:00 PST
second patch checked in
Comment 8 David Baron :dbaron: ⌚️UTC+2 (mostly busy through August 4; review requests must explain patch) 2005-11-17 22:57:11 PST
Comment on attachment 202455 [details] [diff] [review]
To build mozilla in a sparated directory.

This is really backwards; the two lines that you changed were right before, and the line in the middle needs to do something different so that it works with what was there before.
Comment 9 Ginn Chen 2005-12-16 01:12:48 PST
Created attachment 206071 [details] [diff] [review]
address dbaron's comment
Comment 10 Ginn Chen 2005-12-20 21:31:57 PST
third patch checked in
Comment 11 Justin Dolske [:Dolske] 2006-11-15 17:22:34 PST
*** Bug 305748 has been marked as a duplicate of this bug. ***
Comment 12 Justin Dolske [:Dolske] 2006-11-15 17:27:07 PST
Created attachment 245710 [details] [diff] [review]
Cleaned up patch

This is a cleaned up version from comment #9 / attachment 206071 [details] [diff] [review] (since there's no mistaken "patch #2" to fix on the 1.8 branch).

I ran across the original problem when compiling FF2 on Solaris, and this fixed it.
Comment 13 Daniel Veditz [:dveditz] 2006-11-27 17:43:16 PST
Comment on attachment 245710 [details] [diff] [review]
Cleaned up patch

approved for 1.8 branch, a=dveditz for drivers
Comment 14 Ginn Chen 2006-11-28 19:08:08 PST
already checked in on 1.8 branch for Firefox 2.0.0.1

Note You need to log in before you can comment on or make changes to this bug.