Firefox is unusable in solaris x86 using Sun SOS10 compiler.

RESOLVED FIXED

Status

()

Core
XPCOM
RESOLVED FIXED
12 years ago
11 years ago

People

(Reporter: Leon Sha, Assigned: Leon Sha)

Tracking

({fixed1.8.1.1})

Trunk
Sun
Solaris
fixed1.8.1.1
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(4 attachments)

(Assignee)

Description

12 years ago
See also bug 268524.
Firefox can start up, but you can not type anything in url bar.
This bug is very similar to bug 268524.
But I don't know why there is no problem with mozilla.
(Assignee)

Comment 1

12 years ago
But this time the problem is here:
mozilla/xpcom/reflect/xptcall/src/md/unix/xptcstubs_x86_solaris.cpp
I try to use the same method of bug 295306.
I write a inline template file, and compile it with 
xptcstubs_x86_solaris.cpp to assemble file. Then create a new assemble
file. But I met a problem. After compile the symble of 
STUB_ENTRY(0...9) is not confirmed with symble of STUB_ENTRY(10...99).
For example the symble of STUB_ENTRY(3) is 
__1cOnsXPTCStubBaseFStub36M_I_, the symble of STUB_ENTRY(33) is  
                   ^this is F
__1cOnsXPTCStubBaseGStub36M_I_,
                   ^this is G

I'll attach a patch of this bug. Although it is ungly, it do work.
(Assignee)

Comment 2

12 years ago
Created attachment 184397 [details] [diff] [review]
Patch
Assignee: dougt → leon.sha
Status: NEW → ASSIGNED
(Assignee)

Updated

12 years ago
Attachment #184397 - Flags: review?(darin)

Updated

12 years ago
Attachment #184397 - Flags: review?(darin) → review+
(Assignee)

Updated

12 years ago
Attachment #184397 - Flags: superreview?(Henry.Jia)
(Assignee)

Updated

12 years ago
Attachment #184397 - Flags: superreview?(Henry.Jia) → superreview?(darin)

Comment 3

12 years ago
Comment on attachment 184397 [details] [diff] [review]
Patch

Requesting approval on behalf of Leon.
Attachment #184397 - Flags: superreview?(darin)
Attachment #184397 - Flags: superreview+
Attachment #184397 - Flags: approval1.8b3?

Updated

12 years ago
Attachment #184397 - Flags: approval1.8b3? → approval1.8b3+
(Assignee)

Comment 4

12 years ago
Checking in Makefile.in;
/cvsroot/mozilla/xpcom/reflect/xptcall/src/md/unix/Makefile.in,v  <--  Makefile.in
new revision: 1.80; previous revision: 1.79
done
RCS file:
/cvsroot/mozilla/xpcom/reflect/xptcall/src/md/unix/xptcstubs_asm_x86_solaris_SUNW.s,v
done
Checking in xptcstubs_asm_x86_solaris_SUNW.s;
/cvsroot/mozilla/xpcom/reflect/xptcall/src/md/unix/xptcstubs_asm_x86_solaris_SUNW.s,v
 <--  xptcstubs_asm_x86_solaris_SUNW.s
initial revision: 1.1
done
Checking in xptcstubs_x86_solaris.cpp;
/cvsroot/mozilla/xpcom/reflect/xptcall/src/md/unix/xptcstubs_x86_solaris.cpp,v
<--  xptcstubs_x86_solaris.cpp
new revision: 1.3; previous revision: 1.2
done
Status: ASSIGNED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → FIXED

Comment 5

12 years ago
Created attachment 202455 [details] [diff] [review]
To build mozilla in a sparated directory.
Attachment #202455 - Flags: superreview?(darin)
Attachment #202455 - Flags: review?(darin)

Updated

12 years ago
Attachment #202455 - Flags: superreview?(darin)
Attachment #202455 - Flags: superreview+
Attachment #202455 - Flags: review?(darin)
Attachment #202455 - Flags: review+
is there really no better way than this? the source dir should not be written to.

Comment 7

12 years ago
second patch checked in
Comment on attachment 202455 [details] [diff] [review]
To build mozilla in a sparated directory.

This is really backwards; the two lines that you changed were right before, and the line in the middle needs to do something different so that it works with what was there before.
Attachment #202455 - Flags: review-

Comment 9

12 years ago
Created attachment 206071 [details] [diff] [review]
address dbaron's comment
Attachment #206071 - Flags: review?(dbaron)
Attachment #206071 - Flags: review?(dbaron) → review+

Updated

12 years ago
Attachment #206071 - Flags: superreview?(darin)
Attachment #206071 - Flags: superreview?(darin) → superreview+

Comment 10

12 years ago
third patch checked in
*** Bug 305748 has been marked as a duplicate of this bug. ***
Created attachment 245710 [details] [diff] [review]
Cleaned up patch

This is a cleaned up version from comment #9 / attachment 206071 [details] [diff] [review] (since there's no mistaken "patch #2" to fix on the 1.8 branch).

I ran across the original problem when compiling FF2 on Solaris, and this fixed it.
Attachment #245710 - Flags: approval1.8.1.1?
Comment on attachment 245710 [details] [diff] [review]
Cleaned up patch

approved for 1.8 branch, a=dveditz for drivers
Attachment #245710 - Flags: approval1.8.1.1? → approval1.8.1.1+

Updated

11 years ago
Keywords: fixed1.8.1.1

Updated

11 years ago
Whiteboard: [checkin needed]

Comment 14

11 years ago
already checked in on 1.8 branch for Firefox 2.0.0.1
Whiteboard: [checkin needed]
You need to log in before you can comment on or make changes to this bug.