rounding error with padding

RESOLVED DUPLICATE of bug 224753

Status

()

Core
Layout
RESOLVED DUPLICATE of bug 224753
13 years ago
13 years ago

People

(Reporter: brian hirt, Unassigned)

Tracking

Trunk
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.8) Gecko/20050511 Firefox/1.0.4
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.8) Gecko/20050511 Firefox/1.0.4

Setting a fractional em padding causes some sort of rounding error that
generates incorrect layouts.  I have created a simple test case to display this
at http://www.berkhirt.com/bugs/mozilla-padding-rounding-error.html  This will
fail to render with both firefox on mac and windows.

Reproducible: Always

Steps to Reproduce:
1. view page mentioned above

Actual Results:  
you will see a red line displayed that should not be displayed.

Expected Results:  
The border should have been displayed at the bottom of the box, and the red line
should not have been visible.
I see the error with Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7.8)
Gecko/20050509 Firefox/1.0.4
I do not see the error with Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US;
rv:1.8b2) Gecko/20050525 Firefox/1.0+ ID:2005052509
Either way, this looks like a dupe.

*** This bug has been marked as a duplicate of 224753 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.