Autofilled forms cannot be edited

RESOLVED INVALID

Status

()

Toolkit
Form Manager
RESOLVED INVALID
13 years ago
10 years ago

People

(Reporter: tomlin coggeshall, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Win 9x 4.90; en-US; rv:1.7.8) Gecko/20050511 Firefox/1.0.4
Build Identifier: Mozilla/5.0 (Windows; U; Win 9x 4.90; en-US; rv:1.7.8) Gecko/20050511 Firefox/1.0.4

When Firefox (1.0.4) hits a page that has a form I've filled out before, it
correctly pops up the pick box (right term?) when I put the cursor in the field
which has history of me filling it out before.  Up pops other things I've typed
here before.  In IE, I think I could edit or delete the contents of these pick
boxes.  For instance, I entered a wrong account number once and it keeps popping
up everytime I go there.  If I highlight it as if I want to pick it, I should be
able to pick it or delete it.  The bug is that I can only pick it (the wrong
number I entered one time) and then correct it after it has autofilled into the
field.  The other bug is that the corrected number does not end up in the pick
box next time, only the wrong one.  The solution is to allow the user to delete
wrong items in the pick box and allow Firefox to save new entries.  Thanks!

Reproducible: Always

Steps to Reproduce:
1. Go to a web page that has forms
2. Fill out the forms with wrong information
3. Go back to the same page again and try to delete/correct the wrong
information in the pick box(es)
Actual Results:  
The bug occured

Expected Results:  
As explained above, I would prefer to have the software allow me to delete wrong
entries in the pick box and have it remember new ones

Not a crach problem.  This is about the only bug I've noticed.  I love the
program, thanks!

Comment 1

13 years ago
Shift+Delete should delete a form entry, duplicate of bug 239186 -> bug 171605?
(Reporter)

Comment 2

13 years ago
Sorry for the (sort of) dupe posting but I don't consider this bug really fixed
if plain old 'delete' doesn't delete (highlighted) unwanted entries in an
autocomplete pick box (as it does in IE, also noted in comments on bug 171605).
 As Firefox is now, it is frustrating for a user that has learned to use
'delete' in IE and wantes to clean up an unwanted entry or typo.  I can
certainly learn shift-del but, as a Joe Schmoe user, I had no way of knowing
about it.  Just 'delete' is so much more intuitive that it think this merits a
second look.  How about retaining 'shift-delete' for offering the user the
ability to delete only the autocomplete item (and not the edit area) and using
'delete' to allow the user to delete both the autocomplete item and the edit
area at the same time?
<P>
It would also be nice to be able to edit existing (fix/change) entries in an
autocomplete pick box.  Maybe better control over this aspect could be a new
extention?  But thanks, I'll try 'shift-delete'...

Comment 3

13 years ago
(In reply to comment #2)
> Sorry for the (sort of) dupe posting but I don't consider this bug really 
> fixed if plain old 'delete' doesn't delete (highlighted) unwanted entries in
> an autocomplete pick box (as it does in IE, also noted in comments on 
> bug 171605).

I guess that's bug 241774?

> It would also be nice to be able to edit existing (fix/change) entries in an
> autocomplete pick box.  Maybe better control over this aspect could be a new
> extention?  But thanks, I'll try 'shift-delete'...

Bug 279188 and bug 289829 propopse a 'view saved form information' button and
maybe an 'edit' item could be added to the context menu suggested in Core bug
198327?
(Reporter)

Comment 4

13 years ago
Thanks for Add'l comment #3.  That clearly summarizes and follows existing
threads on the need for the ability to use simply 'DEL' to remove typos.  In
addition, a way to allow viewing/editing of autocomplete form data would be great.
Per comments, this bug is now invalid. There is Shift+Delete to delete the
entries, and a myriad of other bugs to handle other improvements. Changing to
using only Delete is bug 241774 (likely WONTFIX).

Resolving INVALID.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → INVALID
(Assignee)

Updated

10 years ago
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.