Text select cursor (caret) in input fields is always overlapped (invisible) by fixed positioned elements

VERIFIED DUPLICATE of bug 230701

Status

()

defect
--
major
VERIFIED DUPLICATE of bug 230701
14 years ago
14 years ago

People

(Reporter: info, Unassigned)

Tracking

({testcase})

Firefox Tracking Flags

(Not tracked)

Details

()

Attachments

(1 attachment)

Reporter

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7.8) Gecko/20050511 Firefox/1.0.4
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7.8) Gecko/20050511 Firefox/1.0.4

Fixed divs 'eat away' the cursor in input fields, if the input fields overlay
the fixed divs. (fixed div: low z-index; div containing the form: high z-index).
The input fields remain editable as usual, but the text select cursor turns
invisible exactly where the fixed positionned element underlapps.

Reproducible: Always

Steps to Reproduce:
check out the submitted URL:
1. Click into the field labelled 'Betreff'
2. Scroll down very slowly and keep an eye on the cursor
3. Check out the other input fields



Sometimes fixed positioned divs produce a 1px solid bottom border with the color
of their background. This phantom border may become visible, if images on an
overlapping, absolute or relative positioned element overlay it. The images get
striked through. This effect depends on the font-size and on the actual text
zoom. (should be fixed too)

Cursor and border problem with
Tested platforms: win2k sp4, winXP sp1, osx 10.3.8
client: ffox 1.0 - 1.0.4
Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8b2) Gecko/20050527
Firefox/1.0+ ID:2005052711

Confirmed

The cursor appears in a :fixed position and simply disappears when you scroll 1
or more lines down

Comment 2

14 years ago
Related to/duplicate of Core bug 282358 and Suite bug 230701?

Updated

14 years ago
Summary: Text select cursor in input fields is allways overlapped (invisible) by fixed positionned elements → Text select cursor in input fields is always overlapped (invisible) by fixed positioned elements

Updated

14 years ago
Depends on: 167801
Keywords: testcase

*** This bug has been marked as a duplicate of 230701 ***
Status: UNCONFIRMED → RESOLVED
Closed: 14 years ago
No longer depends on: 167801
Resolution: --- → DUPLICATE
Summary: Text select cursor in input fields is always overlapped (invisible) by fixed positioned elements → Text select cursor (caret) in input fields is always overlapped (invisible) by fixed positioned elements

Comment 5

14 years ago
Verified duplicate.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.