aSubject has no properties during software update

RESOLVED FIXED in mozilla1.8final

Status

()

defect
RESOLVED FIXED
14 years ago
11 years ago

People

(Reporter: rstrong, Assigned: rstrong)

Tracking

({regression})

Trunk
mozilla1.8final
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment, 1 obsolete attachment)

This is a regression from the patch for bug 293583. Sometimes item is null which
is how update determined if there was an update to an item. Also, since it
relied on item being null there was no way to update the ui with the item that
was checked. Patch coming up.
Posted patch patch (obsolete) — Splinter Review
I'm going to do a bit more testing since this is more than likely too late for
1.1a
Posted patch patchSplinter Review
Benjamin - this is a simple fix for a regression caused by the patch for bug
293583 where the subject didn't always contain a valid item. I'd like to get
this in if possible before 1.1a instead of backing out the patch for bug 293583
since that fixed the case where an extension could get installed when it was
not compatible.
Attachment #184785 - Attachment is obsolete: true
Attachment #184892 - Flags: review?(benjamin)

Comment 3

14 years ago
Comment on attachment 184892 [details] [diff] [review]
patch

I'm not certain the status of 1.1a1, I will land this if appropriate.
Attachment #184892 - Flags: review?(benjamin)
Attachment #184892 - Flags: review+
Attachment #184892 - Flags: approval-aviary1.1a1?

Comment 4

14 years ago
Comment on attachment 184892 [details] [diff] [review]
patch

a=chofmann for alpha
Attachment #184892 - Flags: approval-aviary1.1a1? → approval-aviary1.1a1+

Comment 5

14 years ago
Fixed on trunk.
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox1.1
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.