[FIXr]Memory leak in nsDOMUIEvent::GetClientPoint

RESOLVED FIXED in mozilla1.8beta3

Status

()

P1
normal
RESOLVED FIXED
14 years ago
14 years ago

People

(Reporter: bzbarsky, Assigned: bzbarsky)

Tracking

({memory-leak})

Trunk
mozilla1.8beta3
x86
Linux
memory-leak
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Assignee)

Description

14 years ago
We're assigning a raw addrefed ptr into an nsCOMPtr...
(Assignee)

Comment 1

14 years ago
Created attachment 184897 [details] [diff] [review]
Fix

docWidget is an nsCOMPtr and GetParent() returns a raw addrefed pointer...
Attachment #184897 - Flags: superreview?(rocallahan)
Attachment #184897 - Flags: review?(rocallahan)
(Assignee)

Updated

14 years ago
Keywords: mlk
Priority: -- → P1
Summary: Memory leak in nsDOMUIEvent::GetClientPoint → [FIX]Memory leak in nsDOMUIEvent::GetClientPoint
Target Milestone: --- → mozilla1.8beta3
file a bug about converting nsIWidget::GetParent to return already_AddRefed?
Attachment #184897 - Flags: superreview?(roc)
Attachment #184897 - Flags: superreview+
Attachment #184897 - Flags: review?(roc)
Attachment #184897 - Flags: review+
(Assignee)

Comment 3

14 years ago
That's bug 227489.

The problem is that it requires either manual inspection of all GetParent calls
(and we have lots of those for frames and content nodes that would need to be
filtered out) or changing the method name, test-compiling on all platforms to
catch all users and fix them up as needed, then changing it back....
(Assignee)

Comment 4

14 years ago
Comment on attachment 184897 [details] [diff] [review]
Fix

Requesting 1.8b3 approval for simple leak fix.
Attachment #184897 - Flags: approval1.8b3?
(Assignee)

Updated

14 years ago
Summary: [FIX]Memory leak in nsDOMUIEvent::GetClientPoint → [FIXr]Memory leak in nsDOMUIEvent::GetClientPoint
Comment on attachment 184897 [details] [diff] [review]
Fix

a=shaver
Attachment #184897 - Flags: approval1.8b3? → approval1.8b3+
(Assignee)

Comment 6

14 years ago
Fixed for 1.8b3.
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.