fresh profile startup: no initial calendar [trunk]

RESOLVED FIXED

Status

Calendar
General
--
major
RESOLVED FIXED
13 years ago
12 years ago

People

(Reporter: gekacheka, Assigned: Mostafa Hosseini)

Tracking

({regression})

Details

Attachments

(1 attachment)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7.8) Gecko/20050511 Firefox/1.0.4
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8b2) Gecko/20050526 Mozilla Sunbird/0.2+

When starting sunbird from a new profile, there is no initial calendar.

Reproducible: Always

Steps to Reproduce:
0. rename or delete old sunbird profile directory
1. start sunbird


Actual Results:  
1. there are no calendars in the calendars tab.

2. because there are no calendars, creating a new event fails on 'ok' with

Error: document.getElementById("server-field").selectedItem has no properties
Source File: chrome://calendar/content/eventDialog.js
Line: 707

Expected Results:  
An initial calendar in calendars tab.

Creating an event should work.
The last patch in bug 285014 tries to do something about that.
Keywords: regression
Created attachment 185260 [details] [diff] [review]
patch v1

Patch adds a home calendar when no calendar exists. Not sure if this is the
right place to do this, we might want a general Initialize() somewhere, that
also sets the timezone etc. But for now, this should do it.
Attachment #185260 - Flags: first-review?(pavlov)

Updated

13 years ago
Attachment #185260 - Flags: first-review?(pavlov) → first-review+
patch checked in
Status: NEW → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → FIXED

Updated

12 years ago
QA Contact: gurganbl → general
You need to log in before you can comment on or make changes to this bug.