residual style bug? after </font> and <font>, </i> ignored and italics run on

VERIFIED FIXED in M15

Status

()

Core
CSS Parsing and Computation
P3
normal
VERIFIED FIXED
18 years ago
18 years ago

People

(Reporter: ekrock's old account (dead), Assigned: rickg)

Tracking

({testcase})

Trunk
x86
Windows NT
testcase
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [TESTCASE], URL)

Attachments

(1 attachment)

(Reporter)

Description

18 years ago
Using Commercial 2/28 (which reports itself as Build ID 1999122808) on WinNT 4.0 
SP4, a </i> is ignored, causing the italic text property to propagate all the 
way to the end of the document.

I suspect this is caused by an erroneous residual style correction. The source 
HTML is a mess. Here's the key section from the simplified test case 
I'll attach:

<font face="Arial, Helvetica" size="2">
<p>where
<ul>
<li>
<i></font><tt>EventTarget</tt><font face="Arial, Helvetica" size="2"></i> is a 
reference</li>

Somehow it's forgetting about that </i>, causing "is a reference" (and the 
entire rest of the original document) to be italicized. This doesn't happen on 
Nav4.
(Reporter)

Updated

18 years ago
Keywords: 4xp
(Reporter)

Comment 1

18 years ago
Created attachment 5890 [details]
simplified testcase
(Reporter)

Comment 2

18 years ago
Marking [TESTCASE] and testcase keyword (as BugAThon's in transition).
Keywords: testcase
Whiteboard: [TESTCASE]

Comment 3

18 years ago
This bug appeared in build 2000-02-28-08. It did not exist in 2000-02-25-12 where 
the rendering was identical to Nav4 (ie. nothing in italic).

Reassigned to rickg to re-evaluate his checkins from 02/25 22:14 in htmlparser, 
especially the one in CNavDTD.cpp:
http://bonsai.mozilla.org/cvsview2.cgi?diff_mode=context&whitespace_mode=show&
subdir=mozilla/htmlparser/src&command=DIFF_FRAMESET&file=CNavDTD.cpp&rev1=3.267&
rev2=3.268&root=/cvsroot

Note that I did not try to back out this checkin in my local tree to see if it 
would fix the problem. It's just a guess.
Assignee: pierre → rickg
(Assignee)

Comment 4

18 years ago
Hmm -- let me take a look.
Status: NEW → ASSIGNED
(Assignee)

Comment 5

18 years ago
The problem sequence is: <b><i></b>text<u></i>text. Arg.
Target Milestone: M15
(Assignee)

Comment 6

18 years ago
I have a fix in hand, for what it's worth.
(Assignee)

Comment 7

18 years ago
PDT team granted PDT+ status to this on Thursday; a=jar.
Whiteboard: [TESTCASE] → [PDT+][TESTCASE]
(Assignee)

Comment 8

18 years ago
Actually -- I meant to imply that this is a dupe of 3944, which the PDT team 
approved on thursday.
(Assignee)

Comment 9

18 years ago
Actually -- I meant to imply that this is a dupe of 3944, which the PDT team 
approved on thursday.
Whiteboard: [PDT+][TESTCASE] → [TESTCASE]
(Assignee)

Comment 10

18 years ago
Fixed as side effect of bug 3944 -- improvement to cnavdtd::closecontainersTo().
Status: ASSIGNED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → FIXED

Comment 11

18 years ago
Using 08_09_08_m18 build, verified fixed.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.