Closed Bug 29665 Opened 23 years ago Closed 23 years ago

profile manager dialog box split across 2 monitors

Categories

(SeaMonkey :: Startup & Profiles, defect, P3)

PowerPC
Mac System 9.x

Tracking

(Not tracked)

VERIFIED DUPLICATE of bug 29640

People

(Reporter: koch, Assigned: bugs)

References

Details

profile manager dialog box split across 2 monitors.  Should be centered on main
screen.
Status: UNCONFIRMED → NEW
Ever confirmed: true
*** Bug 30808 has been marked as a duplicate of this bug. ***
I've looked into this a little bit and there are two problems:

1) when centerWindowOnScreen() is called, the window has yet to be reflowed/sized 
so the window's width/height are (1,1). This is why it appears down and to the 
right of where you think it should be.

2) the screen object is just too stupid for use in this situation. In fact, it 
causes more harm than good with multiple monitors. We need a totally new API that 
understands primary screens and multiple monitors and we should not be using the 
screen object for anything in our code -- ever. That will have to come post beta-
1 and dan or I will have to write it.
adding dep for new screen object.
Depends on: 30898

*** This bug has been marked as a duplicate of 29640 ***
Status: NEW → RESOLVED
Closed: 23 years ago
Resolution: --- → DUPLICATE
.
Status: RESOLVED → VERIFIED
OS: Mac System 9.x
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.