File, edit and view menus missing from chatzilla

RESOLVED FIXED

Status

--
critical
RESOLVED FIXED
14 years ago
13 years ago

People

(Reporter: ajschult784, Assigned: bugzilla-mozilla-20000923)

Tracking

({regression})

Trunk
x86
All
regression
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [cz-patch][cz-0.9.69])

Attachments

(1 attachment)

(Reporter)

Description

14 years ago
The file, edit and view menus are missing from chatzilla with linux suite trunk
2005060403.  They were there with 2005060301, so I'm guessing this is fallout
from bug 295711.
(Reporter)

Updated

14 years ago
Severity: normal → critical
Flags: blocking-seamonkey1.0a?
(Assignee)

Comment 1

14 years ago
WFM, Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8b2) Gecko/20050605
(Assignee)

Comment 2

14 years ago
The menus usually don't appear if a startup JS error occurs, which will trigger
a popup dialog with the error in it. If you don't see that, check the Mozilla
console (NOT JS Console) when starting CZ with browser.dom.window.dump.enabled
enabled.
(Reporter)

Comment 3

14 years ago
no JS errors in the console with dump enabled.
(Assignee)

Comment 4

14 years ago
Does CZ actually work otherwise, then? 'cos that would be very odd indeed.

What is in the menubar according to DOMI?
(Reporter)

Comment 5

14 years ago
> Does CZ actually work otherwise, then? 'cos that would be very odd indeed.

yes, it's fully functional other than the lack of menus

> What is in the menubar according to DOMI?

all of the menus are in the menubar.  the CSS styles being applied appear to be
the same.  The only difference I noticed was that in the computed style pane,
the missing menus have "height:auto" and the visible menus had "height:16px".

I also backed out xul.css change from bug 295711 to test it out and the menus
came back.  But that seems strange since DOMI showed that the missing menus have
"display:-moz-box"
(Assignee)

Comment 6

14 years ago
Ok, so this isn't actually a CZ bug.

It sounds like the empty menu CSS stuff I remember from the DOMI landing is
being applied initially and not correctly updated when ChatZilla adds the items
to these menus.
(Assignee)

Comment 7

14 years ago
I can see this on Windows now, dunno why it worked before.

Anyway, bug 98997 needs a-fixin'. I'm leaving this one open to catch dups, but
technically this bug is a dup of 98997.
Depends on: 98997
OS: Linux → All
(Reporter)

Updated

14 years ago
Depends on: 295711

Comment 8

14 years ago
Silver, can I suggest that you add the <menupopup> statically, and populate *it*
dynamically? That way the :empty designation will not affect you.
(Assignee)

Comment 9

14 years ago
That seems fairly logical (though wrong ;) ). I'll try to do a patch by this
evening, if no-one beats me.
(Assignee)

Comment 10

14 years ago
Created attachment 185404 [details] [diff] [review]
Hack to work around bug 98997

bsmedberg, you're lucky the Menu Manager in CZ copes with the <menupopup/>
already existing. ;)
Assignee: rginda → silver
Status: NEW → ASSIGNED
Attachment #185404 - Flags: review?(samuel)

Updated

14 years ago
Attachment #185404 - Flags: review?(samuel) → review+
(Assignee)

Updated

14 years ago
Attachment #185404 - Flags: approval1.8b3?
(Assignee)

Updated

14 years ago
Whiteboard: [cz-patch][cz-0.9.68.6]

Updated

14 years ago
Attachment #185404 - Flags: approval1.8b3? → approval1.8b3+
(Assignee)

Comment 11

14 years ago
Checked in --> FIXED.
Status: ASSIGNED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → FIXED
Flags: blocking-seamonkey1.0a?
(Assignee)

Updated

13 years ago
Whiteboard: [cz-patch][cz-0.9.68.6] → [cz-patch][cz-0.9.69]
You need to log in before you can comment on or make changes to this bug.