Closed Bug 296847 Opened 14 years ago Closed 11 years ago

Drag and drop of multiple elements (.url internet shortcuts, html files, image files) does not open multiple tabs

Categories

(Firefox :: Tabbed Browser, enhancement)

x86
All
enhancement
Not set

Tracking

()

RESOLVED DUPLICATE of bug 92737

People

(Reporter: emergence, Unassigned)

References

(Depends on 1 open bug)

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.8) Gecko/20050511 Firefox/1.0.4
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.8) Gecko/20050511 Firefox/1.0.4

If you select multiple IE shortcut files and drag them into Firefox, only one
shortcut would be loaded.

What must happen is that each shortcut file must open in a separate tab.

Maxthon is able to do this, so this isn't an OS issue.

Reproducible: Always

Steps to Reproduce:
1. Select multiple IE shortcut files in Windows Explorer.
2. Drag the selected group of shortcuts into Firefox.
3. Drop the shortcuts.

Actual Results:  
Only one shortcut loaded.

Expected Results:  
Opened each shortcut in a separate tab.
*** Bug 296848 has been marked as a duplicate of this bug. ***
Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8b2) Gecko/20050606
Firefox/1.0+ ID:2005060607

confirmed
->NEW

Status: UNCONFIRMED → NEW
Ever confirmed: true
Summary: Drag and drop of multiple IE Favorites shortcut files does not open each shortcut in a separate tab. → Drag and drop of multiple internet shortcuts (.url) does not open multiple tabs
I'm wondering if this perhaps is related to what is described in Bug 286985 in
which case files are highlighted in explorer and then "open with... -> Firefox"
selected in the context menu. Similar behaviours, not sure if they would have
similar/same solutions in the actual code though. Just thought I'd bring it to
attention here as well.
Firefox should also do that if the elements dropped are not .url but any file type that Firefox handles natively (.html, .jpg, etc.).

Severity: normal → enhancement
Summary: Drag and drop of multiple internet shortcuts (.url) does not open multiple tabs → Drag and drop of multiple elements (.url internet shortcuts, html files, image files) does not open multiple tabs
Firefox trunk Linux build has also this problem.

Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9a1) Gecko/20060123 Firefox/1.6a1
OS: Windows XP → All
Blocks: 286985
(In reply to comment #3)
> I'm wondering if this perhaps is related to what is described in Bug 286985 in
> which case files are highlighted in explorer and then "open with... -> Firefox"
> selected in the context menu. Similar behaviours, not sure if they would have
> similar/same solutions in the actual code though. Just thought I'd bring it to
> attention here as well.

Good point.  It is related, but they are distinct issues because the (operating system's) loading mechanism is different.  The problem reported here needs to be addressed in the drop handler mechanism (at least on Windows), but I think (someone correct me if I'm wrong) that this is a single instance startup with multiple files (objects) as arguments.

The other bug is a case of multiple, simultaneous startups, so you have to figure out, first of all, which are all the newly started instances (non trivial, especially on slower systems).  Then you have to decide which instance will be the one that gets to stay alive (presumably the first one in some (but not alphanumeric) sort order.  Finally, all the other instances must transfer their page to the one staying alive and commit hari kiri.

Csaba Gabor from Vienna
Sorry to have additional submissions on this.  However...

1.  I open an Windows Explorer (not IE) directory onto the Firefox executable (This is on Win XP Pro).  I open a second Explorer directory onto two .htm files (not shortcuts.  That is: not .lnk files) and then drag them over Firefox.exe, the behaviour is exactly as expected: Once instance of FF opens with two tabs, one for each selected .htm
This shows that the drop handler mechanism is in place.

2a.  Same two directories as above.  Only, I create shortcut files (by selecting one and then doing a ctrl+shift+click, then drag, then release in the same directory).  Now if I drag just one of these shortcut files (never mind two) over the executable Firefox.exe and release, I get an alert box error message popping up, to the tune of:
C:\DOCUME~1\CSABAG~1\LOCALS~1\Temp\rrr41you.lnk could not be saved, because an unknown error occurred.

Try saving to a different location

This indicates that this is not a multiple files issue on FF 1.5 but a basic loading issue of .lnk files

2bi.  IE 6's behaviour for the same single file drag is to first pop up a File Download - Security Warning dialog with
Name: My_Testfile.htm.lnk
Type: Shortcut, 677 bytes
From: C:\Marti\Munka\Bombak
with Open, Save, and Cancel buttons

2bii.  Hey!  I found an IE bug.  Check it out, if I select two .lnk files and drag them over IE 6, then I get an error alert saying:
Cannot find 'file:///C:/Test/My_Testfile1.htm.lnk%20C:/Test/My_Testfile2.htm.lnk'. Make sure the path or internet address is correct.

Of course the thing to observe here is that %20 that IE has added in.  Oops.  

Actually, it has nothing to do with .lnk files.  The same type of thing happens if you drag multiple .htm or .lnk files (or combinations thereof).  It converts the space delimiter to %20 and then chokes as a result.  One must always be careful about escaping strings, eh?

3.  The loading mechanism of this bug is distinct from that of selecting multiple files and then right clicking for "open with", as in bug 286985.  I say this having programmed a poor man's version of both for my PHP scripts (specifically, I have a .php script to resize .jpg files.  If one selects multiple .jpg files to simultaneously resize, the cycle time skyrockets and the machine grinds to a halt.  Therefore, I decided to have a single script responsible for serially doing the resizing, hence the development effort).  Therefore, unless someone has a specific justification, I will remove the dependency of that bug on this one.
No longer blocks: 286985
Depends on: 286985
Duplicate of this bug: 488183
Status: NEW → RESOLVED
Closed: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 92737
You need to log in before you can comment on or make changes to this bug.